I've got a friend with a home network, two computers; one desktop running Windows 7 x674 and one notebook running Windows 8.1. There's a Cannon printer attached to the desktop (by USB) and the computer is connected via a wired connection, the notebook connects by wireless.

The problem is that I shared the printer and then installed it on the notebook and several times now the printer just stops working and Window says "Cannot connect to printer". The first time this happened I just deleted the printer and reinstalled and everything was fine; the second time I noticed that for some reason the network connection had somehow changed from Private to Public and I had to disconnect and delete the wireless profile and reattach to get it back to private and then the printer worked again.

The printer worked again for a couple days and then stopped, this time I read a few threads about this 0x00000002 "Can't connect" error message and one person suggested stopping and starting the print spooler which I did and the printer started working again.

Is this a known problem with Windows 8.1? Is there anything that can be done to keep this problem from happening time after time?


- Norm