Windows 8 and 8.1 Forums


"Run as administrator" when I'm already an Administrator?

  1. #1

    "Run as administrator" when I'm already an Administrator?


    Hello,

    Yesterday I upgraded Windows 7 to 8.1, and I'm wondering if there is a solution for a problem that really gets under my skin. I have to run programs as administrator to actually get full rights, even though I'm on an administrator account and I have UAC completely disabled. I have never had this issue before in Windows 7, but today marks my first day that running something as administrator has solved a problem. To be more specifc, I had to add a few ip routes using "route add" in cmd, and it came up with the error "The requested operation requires elevation." After running Command Prompt using Run as administrator I could successfully add routes. I have never had to do this in Windows 7 and it annoys me a lot that I have to right click every program and run them as administrator to actually have administrator rights over them, even though I AM an administrator...
    Is there any way to actually make my account a full administrator on Windows 8.1, or always run programs "as administrator" by default?
    Thanks in advance

    Edit: apologies, already found a solution:
    Windows 8- Run everything as Administrator - Microsoft (Windows) Discussion & Support - Neowin Forums

      My System SpecsSystem Spec

  2. #2


    Posts : 22,576
    64-bit Windows 10


    Hello Nuclear,

    In addition:

    User Account Control (UAC) - Elevate Privilege Level

    Just to let you know that when you do what you posted or this, you will no longer be able to open modern apps, the Store, or any modern UI screen (ex: PC settings) since they will not work while signed in to an elevated account and have UAC disabled.
    Last edited by Brink; 07 Jan 2014 at 14:11.
      My System SpecsSystem Spec

  3. #3


    Thanks for the info Brink!
    I do not use the Metro UI at all so it's no issue for me.
      My System SpecsSystem Spec

  4. #4


    Posts : 22,576
    64-bit Windows 10


    Anytime.
      My System SpecsSystem Spec

"Run as administrator" when I'm already an Administrator?
Related Threads
Hi, I purchased an HP Notebook PC 2000-2c20NR last week that came pre-installed with Windows 8. Somehow - I think it was when I was trying to change settings to where I do not have to give a password everytime I log in - I became lost as the Administrator. I am the only one who uses this laptop....
So today I got the Sims 4, and I went to download it. But, the error message "your system administrator has blocked this program" came up. I checked the UAC, but it was set at default. And I have no idea how to reimage my computer...so I'm hoping that I can fix this issue without reimaging? Any...
Windows 8.1 Administrator password "missing" in User Accounts and Family Safety
I have windows 8.1 and whenever I try and install a program or make any changes that requires administrator permission, I get the normal popup window but there is no field to enter an admin password. The "yes" field is also shaded out. I also, cannot log in as the admin -- there is not a visible...
Arrrgh! :mad: When I copy into certain folders I keep getting nagged that I have to get "Administrator permission to copy to this folder". I am the administrator and I know what I am doing. Please before I go crazy with all this patronising nagging............. please tell me how to turn this...
Good day all, I've done a quick search (here and google) but can't find a solution for the following: Windows 8 pro: I have a user account with admin rights. It used to work fine till one day, after rebooting, I had no tiles in the start view. I ran chkdsk and it seems to have fixed the...
Hello, I have searched extensively for a solution to my problem and everything I have found thus far simply shows me how to setup permissions to modify files. I apologize in advance if this is not the proper place or etiquette for posting. I have a game file that I have deleted/modified many,...
Hi everybody, I'm experiencing a weird problem with Windows 8 Pro x64. Although I'm on the only user account on Windows (that is the administrator one), it looks like I don't have the Admin privileges and need to manually request them each time. For instance, when I install some programs (e.g.,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook