Windows 8 and 8.1 Forums

File Size on disk for NAS showing as 4GB a piece

  1. #1

    Posts : 2
    windows 8.1

    File Size on disk for NAS showing as 4GB a piece


    I've spent hours looking trough google searches for every possible search combination, but I cant find anyone else with the same exact problem.

    I bought a "Dlink NAS 320L", everything works fine and I had no issues setting it up, however on my only windows 8.1 PC, all the files show as taking 4GB size on the disk.


    I have updated to the latest firmware and the problem still persist. This issue does not happen on my other pc's and laptops which all run windows 7. My windows 8.1 is a fresh install is fully updated as well.

    Disk checks out for errors.

    Does anyone know why my windows 8.1 is showing every file as being 4GB in size on the NAS only? Even files larger than that. It seems like a windows explorer issue but I cant find any fixes for it.

    It's also purely a display bug, on my windows 7 pc's and connecting online to the NAS shows the files as not taking up that much space. The problem is, windows tells me there's no room on the NAS based on it's reading the Size on disk as 4GB. Part of my music collection on it was 20~GB in size, but it showed as 14+TB on disk. The disk that's inside is 2TB large.

    The NAS is running some kind of linux os with an ext4 file system (cant be changed).

    I hope someone knows why my explorer is reading those files as that.

    Much appreciated for any help anyone could offer. Thank you.

      My System SpecsSystem Spec

  2. #2

    Posts : 146
    Windows 8.1 Pro x64

    That's interesting. "Size on disk" is reported wrong for files on my NAS also:

    Click image for larger version

    Time to go Google!

    Edit: Ok, like the OP, when I check this from a Win 7 machine the "size on disk" is reported correctly. Googling around found lots of "wrong size on disk" issues, but nothing specifically related to Win 8.1. Oh well....
    Last edited by WiFi Ed; 29 Dec 2013 at 13:18.
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    windows 8.1

    It's nice to know I'm not the only one with that weird issue, though I'm baffled at the reason it all reads as 4gb. Replying as bump because this issue is really annoying.
      My System SpecsSystem Spec

File Size on disk for NAS showing as 4GB a piece
Related Threads
Hi, How do I determine the cluster size that is from the Manufacturer of any hard disk drive (HD or SSD or External USB HD) (not the ones I can choose when reformatting but what the company that made the hard drive had hard-coded set when they made the drive -sector size) -and no, I can't go...
I have Windows 8 installed on a Hyper-V VM in Windows 8.1. It turned out that the size I originally allocated for the virtual hard disk was too small, so I went into settings for the VM and expanded it. But Windows 8 in that VM still sees only the smaller hard disk size. In Hyper-V manager,...
Hello guys, i've solved the blue screen problem 0xc0000225 using EasyRE but now the problem is the total hard disk space it is showing as 200GB (mine is 1TB) i thought of taking backup of image file using OneKey Recovery but it says"Current System Cannot Support Backup" i'm confused :( help...
So, after I let a baby play with my keyboard, my desktop icons now display the file type and size of the icon. I've tried looking in the personalization options and googling for a fix but haven't had any luck thus far. If any one could lead me to a fix or point me in the right direction, it...
Purchased and installed W8 Pro. I followed the instructions to redownload an ISO image and the size of the file is just over 2 MB. I recalled reading somewhere in the instructions or threads that the ISO should be 4 MB or larger and that my download is in error. Did I misread this or do I really...
64 GB ram PC page file size in Performance & Maintenance
I prefer to set min and max page file sizes the same, but was wondering what to set it at with 64 GB of ram.
I have windows 8 installed on a separate partition I made with the recommended size of 20gb. leaving me with 5gb free. is there any way to increase the partition size without reformatting/wiping anything? I went into computer management and the extend volume option is grayed while the shrink volume...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook