Windows 8 and 8.1 Forums

Windows shell common dll has stopped working

  1. #1

    Posts : 9
    Windows 8.1 Pro x64

    Windows shell common dll has stopped working

    Hi all and Merry Xmas

    I'm having a strange issue and wondered if someone could help me please. I was trying to adjust my recording volume settings and realised that I couldn't access them at all.

    I can access volume mixer, recording devices and playback devices but as soon as I click properties I get an error "windows shell common dll has stopped working" checking for solutions. No solutions are found.

    In the event log I have this:
    Log Name: Application
    Source: Application Error
    Date: 24/12/2013 14:45:38
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: *******
    Faulting application name: rundll32.exe_shell32.dll, version: 6.3.9600.16384, time stamp: 0x5215f00d
    Faulting module name: mmsys.cpl, version: 6.3.9600.16384, time stamp: 0x5215eaef
    Exception code: 0xc0000005
    Fault offset: 0x00000000000188f2
    Faulting process id: 0x1700
    Faulting application start time: 0x01cf00b6ceae319c
    Faulting application path: C:\WINDOWS\system32\rundll32.exe
    Faulting module path: C:\WINDOWS\system32\mmsys.cpl
    Report Id: 0d7784e5-6caa-11e3-be8c-3085a98cff08
    Faulting package full name:
    Faulting package-relative application ID:
    Event Xml:
    <Event xmlns="">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2013-12-24T14:45:38.000000000Z" />
    <Security />
    I have updated the sound drivers and this does not solve the issue.

    I have run sfc /scannow and get this error: Windows Resources Protection found corrupt files but was unable to fix some of them. I checked the CBS.log and mmsys.cpl is in the log:

    2013-12-24 15:52:11, Info CSI 000002cc Hashes for file member \SystemRoot\WinSxS\amd64_microsoft-windows-mmsys_31bf3856ad364e35_6.3.9600.16384_none_4f2e2a4bb3222341\mmsys.cpl do not match actual file [l:18{9}]"mmsys.cpl" :
    Found: {l:32 b:v60xHehSiEiGjfRlTb3xF2V1fdfK8KIzSOzRm9aKp4U=} Expected: {l:32 b:2m3lgNuMsB36rZd+AC744RhI+hN1eLbb7TCANW8w8/I=}
    2013-12-24 15:52:11, Info CSI 000002cd [SR] Cannot repair member file [l:18{9}]"mmsys.cpl" of Microsoft-Windows-mmsys, Version = 6.3.9600.16384, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch

    There are also lots of other files with errors. I think this was caused by my faulty SSD and when I re-imaged back to my new drive, these errors are still present.

    Do I need to re-install windows or can I repair install without losing my profile and data? I'd rather repair than re-install

    Thanks all!

      My System SpecsSystem Spec

  2. #2

    Do a Refresh, like a Repair Install: How to Refresh or Reset Your Windows 8 PC |
      My System SpecsSystem Spec

  3. #3

    Posts : 9
    Windows 8.1 Pro x64

    I will give this a go once my backup has finished and report back.
      My System SpecsSystem Spec

  4. #4

    Posts : 9
    Windows 8.1 Pro x64

    Ok so I tried the "refresh" and it sits on "please wait. .. Preparing" for ages and when I click "cancel" there is an error message saying "systemreset.exe - Bad Image c:\windows\system32\dismcoreps.dll is either not designed to run on Windows or it contains an error. Try installling the program again using the original installation media or contact your system administrstor or the software vendor for support. error status 0xc0000020."
      My System SpecsSystem Spec

  5. #5

    Run System File Checker from a Elevated Command Prompt.

    From the Metro Desktop, type command.
    Right click on Command prompt and then Run as Administrator at the bottom of the screen.
    Type sfc /scannow and press Enter.
    Let that run to completion.

    If that doesn't help the problem, try a Refresh again, see if it completes this time.

    Here is another tutorial for refresh: Refresh Windows 8
      My System SpecsSystem Spec

  6. #6

    Posts : 9
    Windows 8.1 Pro x64

    I've already tried that as I put on my original message that errors also
      My System SpecsSystem Spec

  7. #7

    Oops, sorry. I saw that you had run sfc but forgot.

    If refresh won't work, try a Repair Install: Repair Install Windows 8
      My System SpecsSystem Spec

  8. #8

    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center

    Try running

    Dism /Online /Cleanup-Image /RestoreHealth

    then sfc.
      My System SpecsSystem Spec

  9. #9

    Posts : 9
    Windows 8.1 Pro x64

    Thanks, I tried that and got :

    Deployment Image Servicing and Management tool
    Version: 6.3.9600.16384

    Error: 193

    An error occurred. DISM could not be initialized in the local folder.
    Ensure that DISM is installed correctly and that all of the binaries are present
      My System SpecsSystem Spec

  10. #10

    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center

    It needs to be run in Administrator command prompt.

    Click image for larger version
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Windows shell common dll has stopped working
Related Threads
Solved Windows 8 Pro Activation stopped working in Windows Updates & Activation
Hi All, I bought windows 8 Pro over 2 years ago and upgraded from Windows 7 on a Dell desktop. Everything has been working fine until about 2 - 3 weeks ago when I started my computer I got the message to activate Windows 8 Pro, when I clicked on activate it said " Windows cannot activate at...
I have windows 8 pro in my desktop.When i started to run nfs mw 1 it opened but while loading for gameplay it stops working and windows says that there is a problem to work the program properly,so i will have to close it.I have tried for all compability mode but its sltill does not work.Please help...
Okay guys, so i installed Classic Shell on my Windows 8.1 laptop and i kinda didn't like it too much so i uninstalled it. But it has'nt uninstalled completely, when i try running setup again, and choosing the 'remove' option it doesn't uninstall! Anyways, that isn't really the problem, the thing...
Hi everybody, There's no sound from the speakers nor is my microphone working. All the drivers are up to date and windows said the devices are working properly. When I go to the playback settings and all, I get the "Windows Shell common DLL has stopped responding" message. Can anyone help me...
Every time I go to control panel and then hardware and then to touchpad settings I get a crash after making whatever change I want and clicking OK to finish and close. I don't know what the shell common dll is or why it fails but it gets old. Any input will be appreciated.
Shell:Startup Not Working in Software and Apps
On Windows 7, if I wanted to manually add a program to the start up list I would simply go to "shell:startup" via the run command and add the shortcut of the program I wish windows to start. Now.. With windows 8 this doesn't seem to be working? Realtemp will not automanically start up. ?...
Windows 8 pro machine. Ethernet. Machine was connecting to home network computers fine. I was troubleshooting an issue disabling a lot of services and drivers. I thought I restored everything, made sure all essential services are on according to Black Viper's website. Other computers on...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook