Windows 8 and 8.1 Forums

Windows 8.1 can't access NTFS partitions

  1. #1

    Posts : 9
    Windows 8

    Windows 8.1 can't access NTFS partitions

    I have a strange error. Suddenly Win 8.1 (on partition F) can't read anymore my other partions on the same drive, also it coudn't read my external USB drive.

    When clicking on the partitions c: or d: it says 'cannot access local device' and 'device not ready'.

    I have a dual boot system with Windows 7 and 8.1. I can boot into Windows 7 and read all partitions. I also checked the MBR which looks fine. I also have controlled in Computer Management that all drives have a letter assigned.

    However Windows 8.1 can read my USB drives and the installation DVD of Windows 8.

    Clicking on properties of e.g. drive c:\ there is of course no security tab, so it shouldn't be a question of permissions. Also no error codes in event log.

    Booting in safe mode does still does not solve the problem. Of course Windows 8.1 can read perfectly its partition where it has been installed.

    I know, a repair or refresh might be the solution, but if anyone has a good idea where to look because if possible I want to avoid it.

    Checked also with my different antivirus and spyware programs. All comes clean.

      My System SpecsSystem Spec

  2. #2

    Posts : 1
    Win 8

    I had a similar problem, i think that windows 7 messes up partitions that touch Windows 8, i think the solution is to Update Windows 7, at least that is what i think because mine was outdated(i had windows update turned off), but to be honest i uninstalled windows 8 just after noticing problems with my partitions(that was when windows 8 was out), now in windows 8.1 i don't see the problem, but in my case windows 7 deleted files created on windows 8 and Vice versa, i really, really really, really, suggest you to backup your files, i have 9TB of space, you can't imagine the pain, good luck & please post back what you made to solutionate your problem, i want to know as well.
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    windows 8

    Your problems might be from windows 8.1 hybrid boot option. Please try this How to Disable Hybrid Boot in Windows 8 / Windows 8.1 - YouTube and then shut down completely and then try again access on either partions.
      My System SpecsSystem Spec

  4. #4

    Posts : 9
    Windows 8

    I already have hybrid boot off. But here's what I've found out so far.

    As the disk management recognizes the partitions and there is a drive letter, I opened a command prompt and did the following:

    1) diskpart

    2) list volume

    I saw that all volumes except where Windows 8.1 has been installed and of course the 200 Mb system partitions were offline, so I did

    3) select volume x (where x is the number of the offline volume)

    4) online volume

    So I could put all volumes again online and in fully working conditions.

    What is the problem? On my next boot this morning the volumes were offline again. So something must be messed up.

    I tried to make another new local account. Same story. I restored Windows to a previous known working snapshot. Same story.

    Now when I put an external FAT32 HD into my USB port it is seen, if I detach my 1 TB HD drive and plug it in again, the volume is again offline and I have to do the diskpart again.

    So the story becomes more interesting (sarcastically speaking). What and where has been messed up?

    What I did before it happened. I installed two security updates for the .net., but I also have another Windows 8.1 on a VHD disk and did the same, and this installation is working without a hitch.

    Besides, when I boot into the command prompt, all volumes are online.
      My System SpecsSystem Spec

  5. #5

    Posts : 9
    Windows 8

    Was a hard one. Well I've found the solution. One installation I did must have modified the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices\Offline changing all the values e.g. \DosDevices\C from 0 to 1, so effectively putting all volumes offline.

    Changing back the values to 0 resolved the problem.
      My System SpecsSystem Spec

  6. #6

    Posts : 1
    Windows 8.1

    I'm having the same problem, even though I don't have a dual boot system. Can you tell me how to exactly do what you did? I mean, I accessed Mounted Devices but I don't know which values I should change when I open DosDevices\E , for example.
      My System SpecsSystem Spec

  7. #7

    Posts : 9
    Windows 8

    Double click on the \DosDevices\E and a window 'Edit DWORD Value' will pop up. Change the value data from 1 to 0 to make the drive accessible again.
      My System SpecsSystem Spec

Windows 8.1 can't access NTFS partitions
Related Threads
Solved ntfs.sys X.24 BSOD in BSOD Crashes and Debugging
So I have been having a few issues with my system as of late... have not been able to pin point where they are coming from though. What do you guys think?
RAW as USB but NTFS as SATA in Drivers & Hardware
My 3TB toshiba suddenly turned RAW from NTFS today out of nowhere. Drive letter is still there, but when I click on it, it asks me to format. HD does not seem to be failing and it fairly new (5 months). So I decided to hook it up to SATA, and all of sudden everything works perfectly again. I'm...
Fat 32 vs NTFS usb format in Software and Apps
A while back,someone posted that Macrium Reflect was limited to making 4GB files when making a system image. That's true if you use a USB drive formatted in Fat 32. If using Fat 32 format you will end up with probably 5 or more small image files. If using a USB formatted as NTFS you will...
Solved Ntfs bsod in BSOD Crashes and Debugging
I thought I solved this problem, but something else is popping up causing a BSOD. Please see attached.
happened to do a chkdsk recently and discovered that my newly formated ssd drive, with my newly installed win8p/64 os on it, is divided into 3 partitions including 2 ntfs partitions and 1 fat32 partition as follows: c - vol 1 - ntfs 111gb hdd boot c - vol 2 - ntfs 300mb hdd hidden c - vol 3 -...
I purchased a new SSD drive for running windows 8, while installing I unplugged all of my other drives in my machine including a WD 2TB drive I use for files. I cannot seem to get the Windows 8 installation to be able to access the drive when I select it it says "F:\ is not accessible. Access is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook