Windows 8 and 8.1 Forums


Stange Issue with uEFI and Bios on Acer AO756 Netbook

  1. #21


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    You might want to tone down the attitude.

    I noticed on my Wife's Acer Laptop that the UEFI Firmware Settings option is missing from the Troubleshoot > Advanced Options screen in Windows 8. Disk Management shows a EFI partition though. I'm not sure what's up with that. "Windows Boot Manager" is listed as no.1 in the Boot Priority Order and "HDD ST500L is no 2. On her BIOS Boot screen, above the Boot Priority Order listing is Boot Mode [UEFI] and Secure Boot [Enabled]. I see from your screen shots that those two options are missing on your PC. I have no idea why though. My ASUS laptop that is UEFI also lists "Windows Boot Manager" as the first option in the Boot list.

      My System SpecsSystem Spec

  2. #22


    Posts : 9
    OSX 10.6.8


    Just following up with an update for anyone encountering the same weird issues as i was.
    Thinking about how my mac would fail to start up from external devices sometimes, i remembered that purging the NV ram would sometimes fix things, i looked for how to do that with an acer laptop.

    Bridging the CMOS reset would not flush items from the NVram.
    Flashing new bios apparently does not clear it either, it only writes to the EPROM (odd, id thought it would flush out the nvram as well, just to get rid of any configs and start anew)

    According to acer you can clear the NVram with the following steps :
    Disconnect the A/C power > Remove the Battery > then press and hold the power key for 1-2 minutes to drain all power from any capacitors still holding a charge (and thus clearing the NVram (isnt it then still volatile if you clear it by removing power?) )

    After that i was finally able to boot off my windows 7 DVD and the flash drive i had made as well.
    An elegantly simple solution to a rather frustrating issue.

    Apparently windows 8 writes the uefi stuff to the NV ram?
    Im still not sure what happened, or why it was causing so much trouble, or how it even functioned. But hopefully it either happens to no one else, or that if it does, this helps someone
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
Stange Issue with uEFI and Bios on Acer AO756 Netbook
Related Threads
Hi, can someone please give me a step by step guide for Step1 - C IF YOU ARE IN DOS / FREEDOS I have burned the driver files as a data DVD but don't know how to run the disk and downgrade the bios in dos and the model I have came with no windows os thank you ...
Hi All, I bought a new Acer V5-572 Laptop which came pre-installed with Linux and BIOS was UEFI mode selected. To install windows 8.1, I made a installable USB of windows 8.1 and selected Legacy boot in BIOS to boot from it. While installing I formatted the harddisk completely using DISKPART...
Hi There, I just built a desktop with a sabertooth x79 motherboard, and am running Windows 8.1 pro 64-bit. When I click the UEFI BIOS Firmware live tile via the change PC settings>update and recovery>recovery>etc. my computer reboots normally to Windows and will not open BIOS. I have tried...
Acer > no BIOS pass test beep in Drivers & Hardware
Hi all. Went to boot up my Acer this evening to no avail. I can see it start to cycle through searching the DVD drive and see the read/right red LED light for the hard drive go on for about 5 seconds, then nothing. No BIOS test pass beep. I know that it beeps once for passing, then continues to...
I have Windows 8 64-bit (tried 32-bit too with same results) installed in my netbook (Samsung N145P) and everything is fine EXCEPT the brightness control, it's stuck at maximum and there is no way to lower it as the Windows 8 slider nor the keyboard controls do nothing. I have installed Samsung...
Solved Windows 8 for Acer Netbook in Installation & Setup
Hi, i have this netbook (Acer AO751h) and i was wondering if its possible to run windows 8 on it. Here is the Specs from the site Acer Support: Aspire One AO751h Series Specifications It has the Z520 processor and has 2GB RAM
Hi all Not sure if this has been posted before but running Metro UI needs a minimum resolution of 1024 X768 which IMO seems a bit absurd in view of the large number of netbooks and tablets having a slightly lower resolution like 1024 X 600 which seems to be a common size. You can "poodle...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook