Windows 8 and 8.1 Forums


Watermark won't go away on Windows 8.1 upgrade

  1. #11


    Posts : 529
    Windows 8.1 Pro


    Thats what i want gone the watermark this is sick why they do this make a permanent watermark.

      My System SpecsSystem Spec

  2. #12


    Posts : 1,925
    Windows 8.1 Pro


    You should not see the watermark if your BIOS is not UEFI or cannot support SecureBoot.
      My System SpecsSystem Spec

  3. #13


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Have a read of post 7
      My System SpecsSystem Spec

  4. #14


    Butler, PA
    Posts : 32
    Windows 8.1 Pro with Media Center


    I am in the process of contacting HP on this issue. I was not able to find a bios update through their website.
      My System SpecsSystem Spec

  5. #15


    Posts : 2,191
    Windows 8.1


    Quote Originally Posted by TonyB View Post
    Thats what i want gone the watermark this is sick why they do this make a permanent watermark.
    If you have a UEFI bios configuration, an interim test might be to turn off fast boot in your bios (or Win 8.1) and see if that gets rid of your watermark temporariliy. However, the final solutios is to get a UEFI GOP bios update for your specific graphics card. Here is an example of one vendor that has already taken such action:

    GOP UEFI BIOS Available for ASUS GeForce GTX 680 Series Graphics Cards

    Good luck.

    Update: This only applies to those who have both issues. A watermark and a video card warning. FYI, I was able to remove my watermark by just enabling secure boot and my graphics config was already UEFI GOP compliant.
      My System SpecsSystem Spec

  6. #16


    Posts : 529
    Windows 8.1 Pro


    Yes PNY is going to try and fix my issue they had me send in a picture of the card with all labels and my main board bios version as well as what revision my alienware x51 is. I just hope they can read the stickers on my card as all i have is a camera on my phone so i did the best i could.
      My System SpecsSystem Spec

  7. #17


    Butler, PA
    Posts : 32
    Windows 8.1 Pro with Media Center


    I contacted HP and they said there is no firmware or bios update for my PC. They said that since my PC originally came with windows 7 there is no need for secure boot. They said to do a factory restore back to windows 7, then upgrade to 8 and then 8.1 which I really don't wanna do but it looks like that's what I'm gonna have to do. Thanks anyways for the help and any other suggestions would be appreciated.
      My System SpecsSystem Spec

  8. #18


    Posts : 2,191
    Windows 8.1


    HI pbm5362,

    I'm a bit lost as to how their advisement would change you current situation; however, I must admit I haven't read every post in this thread. So, if anyone else can confirm that they understand HPs suggestion and thinks it will work, I'd certainly like to hear why because, there has been no mention of anything relative to changing any BIOS setting to Legacy during this entire process, so it just sounds up like you will end back up in the same place again. What am I missing here? Anyone?
      My System SpecsSystem Spec

  9. #19


    Butler, PA
    Posts : 32
    Windows 8.1 Pro with Media Center


    I was a bit perplexed about their suggestion myself. I don't wannna spend all day resetting and reinstalling with no result. The HP tutorial said for a computer preinstalled with windows 8 to go into the setup utility and then go to secure boot configuration but my PC came with win 7 preinstalled I don't have that option. I haven't tried setting my bios to legacy yet. I'm not sure how to do this. My bios version is AMI 7.10, date 4/9/2012 if anyone has any further suggestions.
      My System SpecsSystem Spec

  10. #20


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Quote Originally Posted by pbm5362 View Post
    I was a bit perplexed about their suggestion myself. I don't wannna spend all day resetting and reinstalling with no result. The HP tutorial said for a computer preinstalled with windows 8 to go into the setup utility and then go to secure boot configuration but my PC came with win 7 preinstalled I don't have that option. I haven't tried setting my bios to legacy yet. I'm not sure how to do this. My bios version is AMI 7.10, date 4/9/2012 if anyone has any further suggestions.
    If have installed Windows 8 in UEFI mode, & reset the UEFI/BIOS firmware to Legacy, Windows 8 will NOT BOOT.
      My System SpecsSystem Spec

Page 2 of 4 FirstFirst 1234 LastLast
Watermark won't go away on Windows 8.1 upgrade
Related Threads
Hi! I recently tried the "sfc /scannow" command. It said it fixed corruptions and after a restart a "Windows 8.1 Pro" watermark showed. I tried to remove it using the My_WCP_Watermark_Editor.exe app. However, it gave me errors in various Modern Apps like the Windows Store app wherein it would...
Hello, How can I remove the Windows 8.1 Enterprise Watermark on my laptop? On the right bottom side this is what Windows 8.1 says. "Windows 8.1 Enterprise Evaluation Windows License Valid for 90 days Build 9600"
Hi everyone, Past Friday windows 8.1 ran some updates and I think it's since then the watermark with SecureBoot disappeared from my desktop. I tried to remove this watermark before with my friend; My2cents. But we couldn't remove it because I had not eufi boot control panel. He told me he...
My Windows is activated and the watermark was removed but soon after a restart the watermark was back. Is there a way to remove it? 31850 31851
I have done a fresh install of Windows 8.1 Pro Build 9600 using a genuine MSDN ISO. After the installation was complete i did all the updates and after that i decided to activate. The activation was a success and the watermark disappeared but after a restart it came back on my desktop. If...
Hello everyone, I am running Windows 8 on my Macbook Pro Retina 15 inch laptop via Bootcamp, I bought Windows 8 normal version from their website, and downloaded it to my computer, then installed it, activated it after installation, customized and set my computer as i feel comfortable, and...
I used the WCP Watermark Remover to remove the Windows 8 watermark. I restarted and, as I had hoped, the watermark was gone. However, any indication as to the edition of Windows I used as it should be displayed in the System window was also gone. Hence is there any way to keep the watermark...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook