Windows 8 and 8.1 Forums


No more admin rights in win8

  1. #1

    No more admin rights in win8


    Since yesterday it seems that I don't have any control over my windows(8).
    When I want to open a certain program Windows gives me the following error message:
    "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item".

    When I press Windows button + 'X' - Command Prompt (admin) I get an 'Unspecified Error'.

    I'm also unable to install new programs and to access the task manager.
    My UAC is(was) already set to 'Admin'.

    Any suggestions?


    Thx!

      My System SpecsSystem Spec

  2. #2


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Do you have Windows 8 Installation disk ? Or did you create a recovery disk ?
    If the answer is NO to the above then download: https://dl.dropboxusercontent.com/u/...3/Recovery.rar
    then:
    1. unzip/unrar it to a USB stick
    2. Change the BIOS or BOOT menu to boot up your PC from the USB
    3. Select US Keyboard->Trouble Shooting->Advanced->Command Prompt
    4. From command prompt Run: diskpart->List Volume and take a note of what Drive letter is your Windows OS then type Exit
    5. Now run: sfc /scannow /offbootdir=d:\ /offwindir=d:\windows
      replace d: with the drive letter in step 4.
      My System SpecsSystem Spec

  3. #3


    Thanks for your help!

    I receive following message after completing the scan: Windows Resource Protection found corrupt files but was unable to fix some of them.
    Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log.

    I tried to view the CBS.log file but access is denied..

    Maybe it's helpful to say that I've encountered these problems after running CCleaner (I cleaned the register as well) but normally this shouldn't give any problems I think.
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    You might have to run sfc multiple times until you get the following message:
    Windows did not find any integrity violation
      My System SpecsSystem Spec

  5. #5


    Posts : 681
    Windows 7 Pro x 2/Windows 10 Home/10 Pro/Windows 10 TP


    Another common cause of No more admin rights in win8 is attempting to patch your system & install custom themes. With Windows 8 new security features it is nearly impossible to install custom themes & a windows update may cause a loss of admin rights or black screen at startup (usually when the patched version of a file doesn,t match the new version of a file installed via update, Also attempting to rename a system file can be the cause.

    In this case Windows can be fixed using system restore, restore from an image or worst case scenario a refresh.
      My System SpecsSystem Spec

No more admin rights in win8
Related Threads
Admin rights in 8.1 in General Support
Looking to make changes to my host file. Windows saying I need admin rights to make the chnage. However the account I have has admin rights! I have checked in control pannel manage accounts. Any ideas on how to fix this? Just a new laptop.
Okay, I'm very sure I set my account to be Admin, there's only one account anyway, yet W8 requests admin permission to do everything. All because of this, I can't change the .ini of a game, I can't update Neverwinter Nights using the updater, I can't save .inis or .txts anywhere except...
Solved I needed admin rights using built-in admin account in User Accounts and Family Safety
Using Win 8.1 First off, the account I'am signed on with is listed as admin type account. It's the one I had to enter my windows account email. Since installing the new MalwareBytes 2.0 program (which went in without any problem) it put an shortcut icon on desktop. I tried too move the icon...
Admin rights problem in User Accounts and Family Safety
I have windows 8. I recently restored my laptop to factory settings. I entered my microsoft account to make a user, and this was an admin. I created another user, went to control panel, and made my first account standard, and my new account admin. The account I changed to standard still acts...
Solved Need help with admin rights. in User Accounts and Family Safety
I only have 1 account and it doesn't have administrator rights. Is there any way I can give it admin rights?
Heres a little about my setup: Lenovo Z580 Windows 8 Pro 1 single HDD split into 2 partitions, 1 for windows / program files, the other (data) for my data / downloads etc. 1 User account (administrator)
I have two Windows VMs, one Windows 7 and the other Windows 8. On both machines there is an account with administrative rights. On the Windows 7 VM if I run a DOS cmd window it is run with with administrative rights. However, on the Windows 8 VM the DOS cmd window has NO administrative rights. ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook