Windows 8 and 8.1 Forums


All partition/drive labels show as Local Disk in Explorer

  1. #1


    Posts : 216
    Win 8.1 Pro x64

    All partition/drive labels show as Local Disk in Explorer


    Either with my startup today, or sometime in the last day or two, all my drives/partitions in Windows Explorer (and XYplorer) have lost their labels and are now showing as "Local Disk." Looking in Windows 8 Computer Management and EaseUs Partition Manager, the labels are there, as shown in the screenshot. I ran all three main repair modules of Yamicsoft Windows 8 Manager and there have been a few reboots, but still the same. Any ideas what might be going on? Thanks,
    Attached Thumbnails Attached Thumbnails Windows 8 drives-partitions labels error.jpg  

      My System SpecsSystem Spec

  2. #2


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Sometimes they show your labels, sometimes they show "Local Disk" - My system does this too. Right now, they are all showing "Local Disk".

    In every other place that matters, like in Sharing, the right names will show up. I've tried for the last 3 years to get them to show my labels, it did this in Windows 7 too. I eventually gave up. You can try "SFC /Scannow" and see if it helps.

    When I am looking at the drives in my other workstations, they are all named with the Label. So I figure the labels are still there, just not being shown in Explorer.

    If anyone knows a permanent solution for this, I'd like to know too.
      My System SpecsSystem Spec

  3. #3


    Posts : 216
    Win 8.1 Pro x64


    Interesting. For me this is new. I primarily use XYplorer and the labels have been there, as well as in Explorer, consistenly for a long time, through XP, 7 and now Win 8. One of the repair modules I ran in Yamicsoft Win 8 Manager looked like SFC scannow.
      My System SpecsSystem Spec

  4. #4


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Windows Manager pulls up SFC, where it says "Windows File Protection".

    There may be a Repair for this in that app.

    Actually, on page III of Repair, there is a repair for "Fix Problem that cannot rename Volume Partition Label" - Try that, I'll do it as well.

    I have to reboot, bblater.
      My System SpecsSystem Spec

  5. #5


    Posts : 216
    Win 8.1 Pro x64


    Hah! As I was getting ready to run it, my computer froze - Pandora was playing. Strange problem. Happens one day, maybe two days later, then not for two weeks. Recycle.

    In any case, yes, that page 3 repair brought the labels back. Thanks! Now, I just have to run Yamicsoft repair some more to undo the damage from the freeze.
      My System SpecsSystem Spec

  6. #6


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    OK it worked:

    Click image for larger version

    Just remember, open Repair Center, go to page III and click "Fix Problem that cannot rename Volume Partition Label":

    Click image for larger version

    Then Reboot, they should all come back.
      My System SpecsSystem Spec

  7. #7


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Just remember, don't use the "1-Click Cleaner" - It deletes installer packages you need to delete programs! That's the only part of the program I don't use.

    Use cCleaner, I use the Pro version of cCleaner, it was worth it.

    The thing I like about the Manager, is that they have common fixes for common problems right there.
      My System SpecsSystem Spec

  8. #8


    Posts : 216
    Win 8.1 Pro x64


    Our posts may have crossed. Your suggestion worked. As for undoing the freeze damage I mentioned, "Repair all system components" on page 1 brings back the full Win 8 backup screen (CP: Win 7 Recovery). Thanks!
      My System SpecsSystem Spec

  9. #9


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Good, I'm glad it worked.

    When Windows 8 freezes or Crashes, I always run GWscan or some other full drive scan, and then a full CHKDSK. I use Hiren's cos it's all there. But I need to make a Boot CD that has all of those drive scanning programs there, one that I can make a tutorial for and give instructions how to use, because I can't use Hiren's to make a tutorial.

    That's why I always seem to repeat myself with some of these solutions I offer, because they all involve having to use Hiren's. I need a solution where I don't have to cite using it.
      My System SpecsSystem Spec

All partition/drive labels show as Local Disk in Explorer
Related Threads
Hi All, I would really appreciate some expert advise on this issue I have, I am running Windows 8.1 Professional. (and no thats not the issue :p) I have just bought myself a new Seagate 5TB internal drive, model is a ST5000DM000. I managed to put the drive as an external and formatted the...
my computer management do not shows local user and group snap-in in windows 8.1, how to enable it,sometime before it was enabled in it,but when i again see it,it is not there,plzz tell me how to fix this problem.
The program Acronis True Image failed when attempting to clone win 8.1 C drive. The destination disk is now hidden in File Explorer but is present in Disk Management (and in Device Manager). The Disk Management command "Change Drive Letter ..." is grayed out. How can I unhide the drive? The...
My Local disk D and E disappeared in Drivers & Hardware
its been 2 hours since this problem occured. i started my laptop and saw that some icons were white, when i clicked on the icon it says "The drive or network connection that the shortcut Counter-Strike.lnk refers to is unavailable. this is the screenshot of my disk management Help me please i...
I have never seen anything like it!: I have only put one folder in my local disk (D:), I dont run windows on that disk, nor do I download anything for storage on that disk. Every time I shutdown, my computer it says Scanning and Repairing Drive (D :), It gets stuck on 41% or 42%, then when I...
Hi all, I have an ASUS vivotab smart running windows 8.1 pro with media centre. The tablet is running it well. One problem I am having is that some packages, such as the samsung smartview for windows 8 does not recognise the hard disk on the tablet or the 64gb sd card I have installed as a local...
Hey all, I recently upgraded from Windows 7 to Windows 8 and I'm loving it, EXCEPT for this one problem I'm having. Immediately after I upgraded, my external hard drive (WD Ext HDD 1021 3TB) was missing from "My Computer." I never had any problems with this HDD before I upgraded, and the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook