Windows 8 and 8.1 Forums


Can't Access CD Drives/Virtual Drives

  1. #1


    Posts : 3
    windows 8

    Can't Access CD Drives/Virtual Drives


    Been googling this for the last hour, and I still can't install a game via a virtual drive; keep getting "Windows cannot access specificed device, path, or file. You may not have appropriate permissions to access". Using Win8

    Checked the Cdrom registry key to see if it was disabled (it's not), and also checked gpedit to see if "prevent access to computer drives" was checked (it's not). Reinstalled daemon tools and deleted all virtual drives, unplugged cd drive cables, restarted, and reinstalled drivers, nothing. I'm at my wits end here.

    Fwiw, I get the same msg when double clicking my physical drive with a cd in it. It says it's working when I check device properties, and I can right click either the physical or vd's and hit "open", and I can see that all the files are there, so it's working obviously. Tried 2 separate restore points from a week ago, still nothing. Thanks in advance.

    P.S: tried wincdemu instead of daemon, and it didn't work. It created the virtual drive & brought up the loader, but when I click on the drive, it says access is denied. I then tried alcohol 120%, & didn't work either. I opened the iso from within alcohol, and inside the program it says the media is loaded onto the virtual drive, but no autoplay option pops up. Also, for both alcohol and wincdemu, there's no icon on the drive under my computer (with daemon, the virtual drive at least show the icon of the program I'm trying to run).

      My System SpecsSystem Spec

  2. #2


    Manchester CT
    Posts : 693
    Windows 8.1 Pro 64 bit GA


    Try Disk management. t run it, type in disk management in the control panel search and click on Create and format hard drives under Admin. See if your CD and virtual drives show up there and have a drive letter.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    windows 8


    They all show up, and they also all show the title of the program I loaded onto them next to the drive letter. Still can't access them, though. Thanks.
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    windows 8


    I managed to bypass this problem by using the virtual disc program here: Tools and utilities for Windows



    Still gonna need to reinstall windows at some point since my computer is obviously wonky.
      My System SpecsSystem Spec

  5. #5


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Sometimes Optical Drives fall off the system bus, they power down and do not power back up when accessed like they should. Usually, restarting the machine fixes this.

    I just fixed a laptop where the guy had dropped it, his Optical drive stopped working. But eventually it came back up. After hibernating then restarting a few times, the Optical Drive was no longer there until I rebooted again.

    They are finicky that way, but I don't see how a Virtual Drive program can be affected.

    Instead of Daemon Tools, I use UltraISO and MagicDisc, Magicdisc for mounting more than 1 drive permanently, I have a set of 8 CDs I mount this way.

    I never had any trouble with the Windows 8 built in Virtual Drive
      My System SpecsSystem Spec

Can't Access CD Drives/Virtual Drives
Related Threads
Hello! I have this problem since Windows 7, i don't remember this happens on Windows XP. I have 2 computers with Windows 8.1 installed: desktop and laptop. I am trying to access local disk drives of "desktop" from "laptop". For example, i type in Windows Explorer "\\desktop\c$". "Windows...
Hello, First post here. Was a gamer for years but no time for it or the video editing I once did anymore so I traded my 2011 2k custom desktop rig for a laptop. Have a Toshiba Satellite L955-S5330 running Windows 8. I took my Seagate 2TB, and two WD 1 TB hard drives out of my pc before...
Have two Win8 machines and one has a bunch of drives connected to it, that I use informally as a file server. Generally, what happens is the following: 1) Boot the Win8 "server" machine (Win8 pro, not a Server OS) 2) Boot my Win8 Pro desktop 3) Open file manager app, double-click the icon for...
Poor Leo, He has lost two complete drives now due to corruption after booting from one drive, restarting, then using the BIOS to boot from another drive (both win8). He keeps getting "ERRORS, attempting to repair" on all of his drives. After chugging along for awhile, they usually boot but with...
I have a batch file that must be run as administrator. The batch file simply starts an application (MyApp.exe). the problem is that because the batch file is run as admin, MyApp.exe can't access networks drives. Since mapped drives are specific to users context, I activated admin account,...
Hi Guys. Hope everyone is having a great new year so far. :party: After formatting and installing a fresh Windows 8 Enterprise I am still unable to access any shared drives or folders on external devices via our domain authenticated network. Any drive/folder located on the internal drive (...
Just upgraded to Windows 8 via clean install. Everything seemed to be working OK, and then I noticed that I was not able to mount an .iso. Looking a little closer, I noticed that my DVD and BD drives were missing. I have checked for updates, but everything seems to be up-to-date. I have also...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook