Windows 8 and 8.1 Forums

Missing some Metro hot keys

  1. #1

    Missing some Metro hot keys

    Recently I was communicating with a dictionary app developer asking why some of the hot keys didn't work in their app. They wrote back claiming they did. In further research of my system I found out they were correct. I found that some of my hot keys on my metro side are not working. The idea is to snap this thing to the side, highlight a word which lights up a bar in the app, Alt/Tab over to it, and then press Enter for it to look up the word, but Enter doesn't work. Left mouse click within the app works as it should.

    All of my single keys and most of my combination keys like Alt/Tab for flip, WinKey/E for FE, Alt/F4 for closing, etc work, but my WinKey/Arrow(s) combination to snap apps don't work, however they all work on the desktop. Mouse-pointer-to-hand-gestures work for snapping Metro apps. Strangely hot keys work with snapping desktop apps. At some time within the last couple of days things went south on the Metro side. I booted into my 8.1 partition to find out they all worked there.

    I ran scannow. It fixed some files but not some others, of which was confirmed in the log file. That didn't fix my problem. Then ran DISM (online) which fixed all files, but didn't do the trick either. Then just for grins I ran the app troubleshooter which didn't find anything, but that warned me that my video driver may be out of date. I checked that out and that is not the case. It's the same driver on my 8.1 side and all works there.

    All worked until a few days ago. It may be an update that goofed things up but then again all works on my 8.1 side, although I know that's somewhat of a different animal. Besides regular Defender updates and a Flash Player update recently, there hasn't been a major 8 update since 9/12, so I think rolling it back won't help. Thing is too is that I didn't mirror after I installed Office. I chanced it with thinking of the 8.1 upgrade coming up. I lost!

    I know all worked before, for I'm big on hot keys. Does anyone have any suggestions?

      My System SpecsSystem Spec

  2. #2

    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7

    Winkey+Arrow don't work on my system either, on either system. Maybe it is a function of the App you are referring to? Do they have a trial version I can install to check it out?
      My System SpecsSystem Spec

  3. #3

    Posts : 959
    Windows 8.1, 10

    The standard functionality of the Windows + Arrows Key are described as follows here:
    Keyboard shortcuts - Microsoft Windows Help

    Windows logo key Windows logo key +Up arrow Maximise the desktop window
    Windows logo key Windows logo key +Down arrow Minimise the desktop window
    Windows logo key Windows logo key +Left arrow Maximise the desktop window to the left side of the screen
    Windows logo key Windows logo key +Right arrow Maximise the desktop window to the right side of the screen
    The left and right are described as moving the desktop to the left or right, and indeed this is what they do for me. In Metro they don't do anything for me, so I think I'm seeing the same as XweAponX.

    So maybe it's a feature specific to the app?
      My System SpecsSystem Spec

  4. #4

    Thanks for answering, guys and thanks for the offer to test, XweAponX. I appreciate it. It's a free app called Sidebar Dictionary. They do have a "Pro" version for a price also.

    Of course we all know that Aero snap on the desktop is nothing new, for it was introduced in 7. I would imagine it's the same code brought over to 8. Not sure on that.

    I guess I'm wrong about 8 then if you guys say so, but then again, all of our systems could be broke.

    I know I'm getting old and senility runs in the family, but I swear the snapping hotkeys worked with Metro apps in 8. I know for a fact they work in 8.1 RP for I use them there and I booted over there to make sure I wasn't going totally bonkers.

    BTW, I didn't mention to them that snapping keys didn't work, I just assumed that after fiddling with them in 8 and then 8.1.

    Well, anywho, the enter key doesn't work as they say it should and damn if I forgot to try it in 8.1 when I was there last!

    It would be great if you could test that out for me in 8. Thanks again.
      My System SpecsSystem Spec

  5. #5

    Posts : 959
    Windows 8.1, 10

    It couldn't be these which you were using could it?
    Windows Key + <
    Windows Key + >

    (In practice that's
    Windows Key + Shift + ,
    Windows Key + Shift + .
    on a UK keyboard anyway)
      My System SpecsSystem Spec

  6. #6

    Thank you! That's it! I was using the wrong keys. It's WinKey/> key instead of arrow keys for Metro snap in 8. In 8.1 it's arrow keys. WinKey/> once snaps app right. Once more and it goes left. 3 times it goes full window.

    On the desktop it gives like a flip view snapped right that shows apps that are open. Once more it goes left. And again it goes to desktop.

    The enter key doesn't work in the dictionary app. The dev stated that if it didn't to send them my system specs.

    BTW, WinKey/+ is magnifier. At least on the U.S. keyboard.

    Thanks again, David. That's a rep for you.
      My System SpecsSystem Spec

Missing some Metro hot keys
Related Threads
Hello, I am used to using the hjkl keys as arrow keys on my home computer by using xmodmap to avoid moving from the home row. Is there any way on 'microsoft windows 8' to configure the hjkl keys to be used as arrow keys while a modifier key such as 'ctrl', 'alt' or 'meta' is held down? The hjkl...
Hey all, So I noticed the Start button's Windows icon is missing in my metro mode. I'm not exactly sure what it's called, but it's the multitask pane on the left side of the screen that appears when you hover over the top left corner and slide down. Rather than a Windows icon it now assumes the...
Got a weird bug that's just happened: 14581 This happened after I uninstalled all my metro apps this morning, rebooted then reinstalled them. Chrome also updated in the meantime. They're the only icons that are broke so clearly something has happened between now and then to stop icons...
Hey there, I just upgraded to windows 8 ( i just bought the upgrade from the microsoft website). After installing the upgrade I noticed that I was missing ALL the Metro Tiles basic ICONS ie: windows app store, internet explorer, mail , maps , messaging , music , news , people , photos ,...
Solved missing icon on Metro desktop in General Support
I installed windows solitaire and classic shell broke the link to the icon on the metro desktop. I can't reinstall the app. Windows store says I have it. Couldn't uninstall the app. No uninstall button. Clicking on the tile just opened the store not the app, so I unpinned it. Any...
I know what the problem is, I have Firefox set as default browser in Windows 8. Is there a way around this to get Internet Explorer Metro UI title back without setting Internet Explorer 10 as default browser? Thanks in advance,
Solved IE10 Metro app missing? in Browsers & Mail
I upgraded both my laptop and my girlfriends from win 7 home premium to windows 8 pro on Saturday. Although mine has worked perfectly I can't find the IE10 metro app on hers. It was never on the home screen after the upgrade and I can't find it when searching for apps on the home screen or in the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook