Windows 8 and 8.1 Forums


Screen going blank randomly

  1. #1


    Posts : 26
    Windows 8.0

    Screen going blank randomly


    When I leave my computer for an extended period of time, after returning the screen is sometimes blank. I know that everything is still on, the screen just won't come on. I know things are still running in the background because when I restart my computer by pressing the reset button (the only thing that works), when I boot back into Windows a few seconds later and relog into an IRC channel I was in before, my old nick gets ghosted. If my old nick was still in IRC this means my computer was still on and working fine until I hit the reset button - screen being blank was the only issue.

    I've tried multiple things, such as hitting the "wake" button on the keyboard. I've checked my power settings carefully, modified them, but still no luck. There doesn't seem to be any pattern to this behavior, it either happens or it doesn't, and the time period it takes for it to happen seems random. Thank goodness for browser session auto-recovery.

    System:
    Windows 8
    i5 2500K @ stock
    Asus Z68 mobo
    2x8GB 1600Mhz memory
    256GB SSD
    Radeon 7770 Sapphire 13.4 stable driver
    3TB external WD HDD using wall-power
    21.5" Samsung monitor 1080p

    I've checked temps, nothing overheating.

    Software of note:
    Classic shell
    KCP (WMP-HC codec pack)
    Malwarebytes
    Windows defender AV (built-in)
    Online armor
    QTTabBar

      My System SpecsSystem Spec

  2. #2


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    I had an old Dell that would do this, it was trying to go into Sleep mode and it was hanging up, the Power light would change to Orange. It would do this regardless of how I had the sleep options set up, on or off, it would do this randomly.

    My solution was to swap out power supplies, do you have an extra one you can put in there? Don't know if it will work for your system.

    What is your Motherboard Chipset, see if there is a new version of software drivers for it, also check for a new BIOS package for the MB.

    You should try a check of your system memory as well, download Hiren's Boot CD from my link, boot to it, and run one of the memory checkers that it lists. If you run Memtest, run the full thing, don't stop it halfway.
      My System SpecsSystem Spec

  3. #3


    Posts : 36
    Windows 8 64-bit


    This happened to me just recently, and I was told here to look at the device manager and if there were any yellow exclamation marks. There was indeed one next to the printer and after uninstalling that driver it was reinstalled again properly, and the problem with the hanging monitor disappeared. They don't seem to be related problems, but it worked!
      My System SpecsSystem Spec

  4. #4


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Yah, check your Hardware, thanx PaulA
      My System SpecsSystem Spec

  5. #5


    Posts : 26
    Windows 8.0


    There's no way to run some kind of memory test in Windows itself?
    Checked device manager, all seems fine.
    I'm very reluctant to swap out my power supply, as it would mean an upgrade, and that would be expensive. I also rather like my current PSU.
    I'll try and look for newer motherboard drivers later this week.
      My System SpecsSystem Spec

  6. #6


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Yes, there is a memory test, do a search for "Windows Memory Diagnostic" - It will pull up a result, click on it, and hit it, it will reboot. But sometimes, it fails to run.

    The Hiren's disk has a better testing program.

    If you have another PSU you can try in the system, put it in and see if it still happens- Don't go out and buy a new one, just swap out the PSU from something else - If you can. Do you have any local computer stores that can test your PSU? I have a place that can test your hardware for 20 bucks. I had an 80 dollar Works PSU go bad after a year, one day after the warranty expired. I still have the other one, it's been running for 12 years. But even good PSU's will go bad, if your has, you should be qualified to get a replacement.

    I've had 3 Dell systems do exactly what you describe. The power light would go Yellow, would not wake up. It would do this right in the middle of work! Does yours do that, it goes blank while you are in the middle of something? If so, then you should try another PSU. But for now, download Hiren's, burn it, boot to it, and do the memory test.
      My System SpecsSystem Spec

  7. #7


    Posts : 26
    Windows 8.0


    I'll try the Windows memory test if I can.
    Hiren's boot CD = 592.5 MB and with a 5GB monthly cap, I'll have to pass.
    My PSU cost roughly $60, so it would be a bit pointless to spend $20 testing it.
    My PSU is 600W and 80+ certification. All other PSU's I have available for testing are less than half the quality, none of them 80+ certification, and all of then either 450W or less.
    I don't have a warranty on my PSU, I got it through a weird transaction - it was supposed to be borrowed until I could get my own one, but that kind of never happened.
    My system doesn't do this while I'm working, only when I've been AFK for quite a while (usually 15+ minutes)

    I can live with the issue, I just hoped there would be an easy fix on the software side.
      My System SpecsSystem Spec

  8. #8


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    5 GB Cap? That's absurd! Thats almost as bad as my original ATT iPhone data cap, which I don't have anymore since I got Sprint. Well, you can download Memtest and use that.

    the ISO image is only 610 kb, you think you can handle that?

    Memtest86 - Download now!

    Anyway, you don't have to spend any money on tests or PSUs, just swap it out with a PSU from another system, borrow one from a friend if you have to. I'm not saying that this is your problem, but it needs to be checked, and until you check it, there really is nothing else that can be done. Cos it is either your PSU or your Memory or maybe even your hard drive that's doing this. If ya can't do this stuff, then you'll have to just live with it.

    The only other thing I can suggest, is to run an In-Place Install, put your Disk in the drie while the computer is up, and then run Setup, when it gets to "upgrade or full install" choose Upgrade. This will replace anything that got corrupted. But I wouldn't do it until I check that PSU.
      My System SpecsSystem Spec

  9. #9


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Ok, there is an issue with Online Armor that causes it to Black Screen. Check your Configuration:

    On Vista, it still black screens some machines due to their configuration, but this is something that Tall emu are working on again, as it did the same in the previous version.
    Online Armor vs. Outpost Firewall | Forum | WOT (Web of Trust)

    [Windows] Best free firewall -- Online Armor vs Comodo vs Privatefirewall vs ZoneAlarm vs Outpost vs TinyWall | Reviews, news, tips, and tricks | dotTech

    There are lots of issues with Online Armor, try changing the configuration, or removing it temporarily. Virtua Box causes a direct conflict


    Maybe you should read this too:

    Black screen after login Windows 8 x64 - Online Armor - Emsisoft Support Forums

    So, it may be Online Armor causing this, and not your PSU or Memory at all. So try different configurations of it, or remove it, Windows 8 has the same Firewall that 7 does and it is a good firewall, I only use free firewalls for XP.
      My System SpecsSystem Spec

  10. #10


    Posts : 26
    Windows 8.0


    Thanks a lot for following up on that info! I'll look into Online Armor's side of things next I think.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Screen going blank randomly
Related Threads
about once out of ever 8 or 9 times the screen will go blank instead of going to the screensaver, under power options I have all settings set to "never", also I do not think its a setting because it only does it ever now and then, also when I tap the spacebar or wiggle mouse it goes to green...
Blank screen on restart in General Support
Hi,I have a MSI cx640dx notebook the core i3 version and it came with windows 7 installed on it,I replaced it with windows 8.1 pro with media center and everything was fine,but when I installed the intel graphics drivers (either from windows updates or manually) it started to give me a blank screen...
Solved Help screen went blank in General Support
After a update last night I put my password in and then the screen went blank all I have is the mouse pointer, I removed the battery and did the Sony vaio assist button I can put my p/w in then the screen goes blank I tried the f8 and f10 key but nothing happens ,can anyone help me fix this , thanks
Hello (new to forum), I have been having a persistent, but seemingly random problem with Windows 8 desktop mode. Periodically, all GUIs that are open on my desktop will turn completely black (blank) inside the frame and remain that way. I can still move the black windows around, minimize them,...
A cry of help from one whose laptop refuses to screenblank and also to go to sleep. I've tried the usual by going to Power Options and making sure everything is in sync there but nought works. I'm wondering if the following will help. Will the download work in Windows 8.1. I am referring to what...
Blank Start Screen in General Support
This did not qualify as a BSoD but I managed to lose all of my tiles from the Start Screen, and since my background was blue, well, it was like a time warp. Anyway, after installing Google Chrome and making it my default browser, I looked on the Start Screen and could not find a Chrome tile....
I have recently installed Windows 8 Pro on my PC, which is a Gateway FX, with a Dell 23" LED monitor. For the most part, everything is fine. On occasion, however, the screen goes completely blank, and there is nothing I can do to "wake it up". I have tried Ctrl-Alt-Del, the Windows key, right...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook