I am running windows 8 and Ubuntu 13.04 on a Sony Vaio SVE14A27CXH.

I had installed both, and had the dual-boot working, but after i tried to mount my windows partition in ubuntu using https://help.ubuntu.com/community/Mo...dowsPartitions , i haven't been able to boot windows 8; it gives windows error 0xc000021a on "windows boot UEFI loader" and "error: can't find command "drivemap" and "error: invalid EFI file path" when i try "windows 8 (loader) (on /dev/sda3)". I tried the recommended settings in boot repair, which yielded a recommendation of retrying after creating a boot partition via tools like gParted. I have tried to refresh my PC through the troubleshooting menu, but it says that there was an error. I have also tried a linear drive test, which was negative.

I tried to execute a system restore, but it says I "must enable system protection on this drive [drive C:]" and the checkbox to select that drive is greyed out.

I have very little knowledge of ubuntu code, so if any solution involve a command prompt, if the lines could be written out for me so I just have to copy paste, that would be fantastic.

I have tried to restore from a recovery disc made on another computer (HP desktop), but it's not recognized by the utility.

I posted this on a Ubuntu forum, so I have Ubuntu Pastebin as the Bootinfo, for anyone that is familiar.

I can post the windows 8 log file as well as the disk layout txt file if that would be helpful.

Thank you in advance!