Windows 8 and 8.1 Forums


Playing music, computer freezes and Admin Event errors

  1. #1


    Posts : 216
    Win 8.1 Pro x64

    Playing music, computer freezes and Admin Event errors


    Win 8x64. I play music a lot with foobar2000 - mp3 files, CDs - most often but not always using its ASIO/JPlay device and driver; i.e., I also use JPlay (service + process + settings - JPLAY - hi-end audio player for Windows). Lately, I've had some computer freezing problems and that's why I write. For example, before leaving for the weekend, I played music for 13 hours, no problem. Returning home yesterday, starting the computer and then the music in exactly the same fashion, within minutes I started getting a string of computer freezes, all occurring when music was playing.

    On a previous occasion, I had run a few malware scans that turned up nothing, so I tried to isolate the problem by removing pieces step by step, starting with getting JPlay out of the way, so it was foobar alone, but none worked (my working hunch has been that the problem is foobar itself or the ASIO/JPlay combo getting corrupted somehow). Finally, I uninstalled and reinstalled foobar again and it played ok, although I didn't let it go for long enough to be sure. Then I added JPlay and things seemed ok for awhile, then came back after 90 minutes to find a freeze.

    Looking at Admin Events, I notice the following happening a lot, at startup and maybe also related to when the crashes occur:

    - The Open Procedure for service "WmiApRpl" in DLL "C:\Windows\system32\wbem\wmiaprpl.dll" failed. (1008)
    - Windows cannot load the extensible counter DLL rdyboost (1023)
    - The Open Procedure for service "MSDTC" in DLL "C:\Windows\system32\msdtcuiu.DLL" failed. (1008)
    - The Open Procedure for service "Lsa" in DLL "C:\Windows\System32\Secur32.dll" failed. (1008)
    - The Open Procedure for service "ESENT" in DLL "C:\Windows\system32\esentprf.dll" failed. (1008)
    - The Open Procedure for service "BITS" in DLL "C:\Windows\System32\bitsperf.dll" failed. (1008)

    I ran sfc /scannow as admin and it apparently fixed some things and said it couldn't fix others. See the screenshot below, as well as the CBS log file. Any ideas? Thanks.

    (You may ask why I'm raising it here. Mainly, because I'd like to figure out if Windows has become corrupted or is producing the problem. There's also extreme hostility over at foobar re use of other players, specifically JPlay.)

    Gigabyte Z68X-UD3H-B3, i7 2660K cpu, 16gb RAM

    -----------
    2013-07-22 11:28:59, Info CBS TI: --- Initializing Trusted Installer ---
    2013-07-22 11:28:59, Info CBS TI: Last boot time: 2013-07-22 11:08:26.494
    2013-07-22 11:28:59, Info CBS Starting TrustedInstaller initialization.
    2013-07-22 11:28:59, Info CBS Ending TrustedInstaller initialization.
    2013-07-22 11:28:59, Info CBS Starting the TrustedInstaller main loop.
    2013-07-22 11:28:59, Info CBS TrustedInstaller service starts successfully.
    2013-07-22 11:28:59, Info CBS No startup processing required, TrustedInstaller service was not set as autostart
    2013-07-22 11:28:59, Info CBS Startup processing thread terminated normally
    2013-07-22 11:28:59, Info CBS Starting TiWorker initialization.
    2013-07-22 11:28:59, Info CBS Ending TiWorker initialization.
    2013-07-22 11:28:59, Info CBS Starting the TiWorker main loop.
    2013-07-22 11:28:59, Info CBS TiWorker starts successfully.
    2013-07-22 11:28:59, Info CBS Universal Time is: 2013-07-22 17:28:59.154
    2013-07-22 11:28:59, Info CBS Loaded Servicing Stack v6.2.9200.16613 with Core: C:\Windows\winsxs\amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.2.9200.16613_none_6273bd8950d6cae2\cbscore.dll
    2013-07-22 11:28:59, Info CSI 00000001@2013/7/22:17:28:59.173 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7fc48d26429 @0x7fc4e6895ca @0x7fc4e644d64 @0x7f6b43ed1df @0x7f6b43ed95c @0x7fc56792005)
    2013-07-22 11:28:59, Info CSI 00000002@2013/7/22:17:28:59.173 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7fc48d26429 @0x7fc4e6e5e9c @0x7fc4e6a7349 @0x7fc4e644ed7 @0x7f6b43ed1df @0x7f6b43ed95c)
    2013-07-22 11:28:59, Info CBS SQM: Initializing online with Windows opt-in: False
    2013-07-22 11:28:59, Info CBS SQM: Cleaning up report files older than 10 days.
    2013-07-22 11:28:59, Info CBS SQM: Requesting upload of all unsent reports.
    2013-07-22 11:28:59, Info CBS SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm, flags: 0x2 [HRESULT = 0x80004005 - E_FAIL]
    2013-07-22 11:28:59, Info CBS SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]
    2013-07-22 11:28:59, Info CBS SQM: Queued 0 file(s) for upload with pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6
    2013-07-22 11:28:59, Info CBS SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]
    2013-07-22 11:28:59, Info CBS NonStart: Set pending store consistency check.
    2013-07-22 11:28:59, Info CBS Session: 30312192_4081815742 initialized by client WindowsUpdateAgent.
    2013-07-22 11:30:59, Info CBS Trusted Installer is shutting down because: SHUTDOWN_REASON_AUTOSTOP
    2013-07-22 11:30:59, Info CBS TiWorker signaled for shutdown, going to exit.
    2013-07-22 11:30:59, Info CBS Ending the TiWorker main loop.
    2013-07-22 11:30:59, Info CBS Starting TiWorker finalization.
    2013-07-22 11:30:59, Info CBS Ending the TrustedInstaller main loop.
    2013-07-22 11:30:59, Info CBS Starting TrustedInstaller finalization.
    2013-07-22 11:30:59, Info CBS Ending TrustedInstaller finalization.
    2013-07-22 11:30:59, Info CBS Ending TiWorker finalization.
    Attached Thumbnails Attached Thumbnails Windows 8 sfc-scannow local-admin results 7-22-13.jpg  

      My System SpecsSystem Spec

  2. #2


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    You have a soundcard that uses ASIO?

    Well, you can test it is it the Audio hardware, by installing VLC Media Player - Set it up to use the ASIO driver for Audio, you have to go into preferences and show "all" - Then go to Audio and check the box for "Use S/PDIF when available" - That should shunt your audio through the S/PDIF into your ASIO, there are also other settings to choose ASIO - If you go to "Output Modules" you will be able to choose that ASIO device in the settings for DirectX and WaveOut.

    Then play a few MP3's and see if it hangs up at all, I would stick a whole playlist in there and run it for at least half an hour. This will at least tell you if the Audio device is working correctly.

    You should also check your settings in the program you are using, make sure it is finding the device and using it properly, and not using "Microsoft Soundmapper"
      My System SpecsSystem Spec

  3. #3


    Posts : 216
    Win 8.1 Pro x64


    No sound card. Ciunas USB dac + its Amanero USB driver + ASIO driver on the other end should do. Note I was able to replicate the freeze without using foobar's ASIO component driver, i.e., just using the Dac's driver and device setting for such in foobar. Not sure what all this has to do with the Windows errors.
      My System SpecsSystem Spec

  4. #4


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    You said you were using ASIO, which is associated with high-end sound cards like Gina, Gadget Labs and Digi, which all use either S/PDIF or Optical cable. Ok, so it's a USB device. Same thing applies, try using VLC, set VLC to use the audio properties of the USB device, see if it locks up during playback.

    Even though it's a USB device, it uses S/PDIF:

    https://sites.google.com/site/jkciunas/home


    The S/PDIF setting in VLC just tells the program to use the Digital Audio Out. In my case, this is through the HDMI cable into my Monitor, but I still have to use the S/PDIF setting to get it to work. In your case, it will be through your USB device.

    But it sounds like it's the program that's causing this, not the hardware. If you say it still has problems even with the ASIO shut off, then it's the program. I'll see if I can install Jplay into my system, I'm getting the trial version now.

    Ok - I see now, that's one damn good player. All I have to do is right-click and copy my WAV files and it gives me the best, uncoloured playback I've heard. I am not even using any other player, you said you were using Foobar to select the tracks? What if you just used Explorer instead don't run Foobar at all? Maybe it is the interaction between Foobar and Jplay. Jplay doesn't need any other Audio Programs running. When I installed it, it went right in, no errors. here is how I set it:

    Click image for larger version

    As you can see I'm just using the Audio from my Video Card, I had to set Bitstream to Native before it would play - Native is 24 bit, thats how I set it up in the Audio Settings.

    Have you tried changing these settings? I wanted you to try using another player just to see if your Audio device was choking, I don't use ASIO in that system at all but I use it in my Digi system. Maybe I'll set it up in there and tell it to use my Digi to play it back, that will take a while to set up.
    Last edited by XweAponX; 22 Jul 2013 at 14:40.
      My System SpecsSystem Spec

  5. #5


    Posts : 216
    Win 8.1 Pro x64


    Hmm, still not clear. I have VLC. Looking under Audio, I see the s/pdif setting but don't see anything indicating the Dac/Amanero driver. In addition, where does the ASIO driver come from? My understanding looking around online is that VLC doesn't support ASIO. I know Zoom Player Pro doesn't, but it does show the Amanero driver under Playback > Audio and handles it admirably (no computer freezes, no buffer size related cutouts).

    Since you've referenced the Ciunas site, please see item 2 under Recommendations: https://docs.google.com/document/d/1...AQ9Vl_0gw/edit. To use JPlay with foobar2000, one installs the recommended ASIO driver (foobar) and then sets device to ASIO/JPlay. See Manual | JPLAY - hi-end audio player for Windows (Using JPlay with foobar 2000).

    I would like to know about the Windows errors and what to do to fix them.
      My System SpecsSystem Spec

  6. #6


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Do you NEED that ASIO driver at all? maybe that's the culprit. I think it comes with your device. Maybe you don't need Foobar...

    In VLC, the settings are here, under Output Module:

    You'll want to sheck "32-bit float" as well.

    Click image for larger version

    You also have to set the "WaveOut" as well - Your device should show up in those two areas. It MAY just say "ASIO Driver"


    As far as the windows errors, you ran SFC /scannow, and it fixed some but not all of the problems. You MAY have to do an in-place install to repair the rest of them.

    I use a Program called "Yamicsoft Windows 8 Manager" and it has some extra repair settings you can try... you can download it from Yamicsoft, they give you a 15 day full working trial.

    Click image for larger version

    Going through those errors again, does it freeze only when using Foobar, or when using Jplay too? I would just install Jplay by itself, you don't really need foobar to play the files, you can set up a playlist by right clicking in Explorer. as I had no trouble installing Jplay, it may be foobar, I'll have to get that too. It may just be a setting in your ASIO panel that one of these programs doesn't like.

    To make sure, I would just do an In-Place Install, because once I start seeing those kinds of errors, sometimes that's the only way to deal with them. Does it affect any other programs you run?
      My System SpecsSystem Spec

  7. #7


    Posts : 216
    Win 8.1 Pro x64


    Thanks, but I don't see how this is helping solve the problem I posed. I found what you're referring to in VLC and it plays with the Amanero, but there's no ASIO. VLC does directly not support ASIO. Look it up for yourself if you don't believe me.* I don't expect any freezing with VLC, just as there wasn't any with Zoom Player (and Zoom Player's sound quality is much better than VLC's).
    * e.g., see the 3rd and 4th posts at The VideoLAN Forums • View topic - VLC 2.0.1: Not possible to change Audio- Outputdevice

    Among reviewers at least, foobar2000 is considered the best of the free music player/libraries. JPlay (and others?) use foobar's play and library functions as a foundation, while taking it over sonically and, in my and many others' opinions, improving it (a big fight not for here). Hence, the ASIO/JPlay driver.

    Please, the topic of this thread is the slew of Windows errors I'm getting, along with their possible relationship to the freezes. That's why I posted on a Win 8 forum. May we please stick to that? Thanks.
      My System SpecsSystem Spec

  8. #8


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    Read the last part of my last post, not all of your errors were fixed by SFC /scannow,it could not fix all of them. When that is the case you have little left you can do other than in in-place install. The program I suggested has one other repair function, it restores all of your original system files, depending on if you check or uncheck "skip hidden files" or "Files signed by Microsoft". If that doesn't fix it, then you'll have to do an in-place install, or a full re-install. In any case, get your Windows 8 install disk out and get ready to do an In-Place Install.

    I was trying to get you to isolate which one of your programs were causing the problems. Jplay doesn't even need any other player, and I don't know anything about foobar. You don't need Jplay if you are just using Foobar. I was trying to find out if any of these programs would cause a conflict within your system the way you have it set up now, and if your audio setup may be causing it due to not being set up properly or maybe there is some other conflict.

    Maybe the Audio stuff has nothing to do with the errors at all, and I would try repairing the system first by trying the Repair Center in Yamicsoft, and if that fails, an In-Place install.

    Look FooBar uses some kind of SQL server? That might be what's corrupted. Whatever database FooBar uses, that's what those SQM errors are from. So, it may not be a Windows 8 problem at all, but just to make sure, try those repairs I suggested just to get that out of the way. If you don't want to try the Yamicsoft program, then just do an IN-Place Install from a Windows 8 Install disk from within the Windows 8 GUI.

    FooBar SQL Server 2008 install

    Ok I just got back from the doctor, and now I can spend some hours looking into this. I think your Problem is with FooBar, and with whatever version of SQL you have. I found an interesting discussion here:

    backup restoration - Fresh SQL Server DB restore works most times, but fails sometimes - Server Fault

    So I'm going to look for any discussions about Foobar that relate in any way to what's happening to you.
    Last edited by XweAponX; 22 Jul 2013 at 19:19.
      My System SpecsSystem Spec

  9. #9


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7
      My System SpecsSystem Spec

  10. #10


    Posts : 216
    Win 8.1 Pro x64


    I was so focused on the VLC stuff that I missed your other discussions. I tried Yamicsoft's repair center - system components, wmi, scan - but the latter came up with the same scan result. An in-place install is a clean install, right? That and reinstalling all my apps is not a short afternoon project. I noticed and wondered the same thing about the SQM errors re foobar. One thing I've tried today is running foobar as admin, so far without any freezes, but it's not been that long.

    I see you added JPlay trial.* I don't Consider adding foobar, installing the ASIO component driver and seeing what you get and what it sounds like. Don't know if JPlay's Kernal Streaming will work with your set up, but it's said to be better. If it's like mine(dac), you'll notice a difference, starting with having to readjust the volume control. In any case, I'm not glued to foobar, but it's there is a ASIO driver and it's awfully convenient to have all one's music folders down the left side and just choose what one wants (if you try, ask about the set up if needed). Before foobar (and the Ciunas), I was using a file manager. Oh, and I don't use JPlay mini because it's not so convenient and it doesn't have a ready volume control; the Ciunas is a no-control dac (run out the back of my computer on the floor with two USB adapters to eliminate a USB cable). JPlay buffer size hasn't affected the freeze problem.

    *N.B. A rude annoyance of the trial is that after some variable number of days the sound will stop randomnly for a couple of minutes.
    Attached Thumbnails Attached Thumbnails JPlay Settings.jpg  
      My System SpecsSystem Spec

Page 1 of 5 123 ... LastLast
Playing music, computer freezes and Admin Event errors
Related Threads
While playing war thunder on steam my screen went black and i couldn't do anything. I restart my computer and play again it crashes. After one more time i look at my event viewer and find critical error event ID:41. I don't whether its the game or my pc.
Hi, I just bought a new laptop and have been using it a few days when today while playing World of Warcraft and listening to DI.FM on my browser it crashed. I was able to reproduce this a few times with the same conditions. I am hoping you can help me figure out what is causing this issue. ...
Solved Windows 8.1 Event Log Errors in General Support
I recently upgraded to W8.1 from W8 and started getting a whole bunch of Event Log Errors. Today I downloaded and installed new drivers for W8.1 that were posted on the ASRock site dated 10/25/2013. Much to my surprise the new drivers actually made most of the Event Log Errors go away - at least...
Lots of errors in event viewer in General Support
Hi, Since installing Windows 8 Professional 64bit I have been experiencing lots of differnt erros / warnings in event viewer. I have been working with usasma in the BSOD Crashes and debugging section of the forum and it was suggested that I should post in the general forum section to see if...
So I searched around for a bit and found a few discussions about the Music app crashing, but none appear to be the problem I'm having. I can open the app and do most things in it. Search, navigate around, I can even play music most of the time except for one notable exception. When you click on...
Huge Event Log errors - Help in BSOD Crashes and Debugging
Hi folks, Been with Win 8 for just over a day now, after severe grief with two installs going bad. (Upgrade doesn't work at all, 2nd I should have run Windows update before installing newer nvidia drivers).... I am left with an OS in reasonable working order. But look at this... taskhostex...
Event Viewer errors in BSOD Crashes and Debugging
What is generating these errors has been tracked down. What can eliminate them has not... SChannel errors are seen after each Windows Update. Distributed COM (lack of permission) errors pop up after clicking on certain start menu tiles. Though several posts in forums suggest how to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook