Windows 8 and 8.1 Forums

'Pick an app' is always default program for .TXT

  1. #21

    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)

    I'm familiar with the sysinternal tools and I've used procmon many times.

    This test will generate an enormous output log unless I craft some good filters.

    I'll postpone that test and hope someone else has already solved this problem.

    It's very late here, I'm off to bed.



    If I log in as Administrator, that account works fine.
    The user registry settings for .txt are identical to my own.
    Looking at some very old registry backups, these fields have been like that for a long time.

      My System SpecsSystem Spec

  2. #22

    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)

    Quote Originally Posted by Vadikan View Post
    Ok, then let's try to take a look inside.

    1. Download and start Process Monitor.
    2. Right-click a text file -> Open with - UltraEdit.
    3. Right-click a text file -> Open with - Notepad.
    4. Stop logging and upload the PML somewhere.

    For 2 and 3, make sure the checkbox "Use this app" is checked.
    For 3, has it changed the association to Notepad?
    I'm not sure why you want the test run like this.
    I already know that I can't change the association to Notepad.
    The trace for this would probably look the same for both changes.

    After I get some sleep, my head will be clearer tomorrow, this has been a frustrating day.
      My System SpecsSystem Spec

  3. #23

    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)

    Well, I've figured out what is wrong, but not why.

    The default program setting is controlled by this key in my directory:

    Windows Registry Editor Version 5.00
    (I obfuscated the HASH value for the sake of security).

    This looked all well and good, but PROCMON kept reporting an 'access denied' for the UserChoice key.

    Looking at the key permissions, indeed it showed me as 'Denied' for some reason, so I changed the permissions to allow me and now all is good.

    While it is nice to fix problems, especially obscure things like this, it is still disturbing that I have no idea why I was restricted access for my own choice settings.

    I will mark this as SOLVED, but I'm not really satisfied.
      My System SpecsSystem Spec

  4. #24

    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)

    As a followup, I looked over some of the other file types I've assigned to UltraEdit.

    Choosing the extension '.log' as an example, I see the same issue there - I don't have access to the UserChoice key even though it is set for UltraEdit.

    I'm not going to go through the entire list of extensions.

    I believe this may have something to do with the last Windows Update.
      My System SpecsSystem Spec

  5. #25

    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)

    Yet another followup.

    Perhaps the issue is something else. I use to have UltraEdit set up to run as administrator.

    I remember removing that a while back for some reason - it didn't seem necessary.

    But this could be the reason, for every time I change file associations in UE this problem recurs now.

    I've set UE to run as administrator again and I've sent a note off to the UE tech support about this.
      My System SpecsSystem Spec

  6. #26

    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7

    So it was an "Access Denied" on UUedit? I'm glad you were able to fix it.

    You said the last program you installed was Firefox, maybe that program took over one of the file extensions you had used for UUedit, and then locked UUedit out. I never use Firefox, Only Chrome and IE, usually Chrome.

    Are you using a Local account in 8 or an MS account? It may also be, that you had installed a new Windows 8 instance on a new PC. and the TXT was still set up to use Notepad by default, It might have locked out UUedit if it was not installed on the new machine.

    That's the only thing I can think of, Interference from the Synced Settings of another machine via the MS account.
      My System SpecsSystem Spec

  7. #27

    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)

    Access denied was from the registry access to the UserChoice setting of .txt files. Every program I run in my account would get that error because my account was denied access. That is why the default editor could not select it.

    My installation was an in-place update from Windows 7, I only use the local account and desktop. UltraEdit was installed long ago.
      My System SpecsSystem Spec

  8. #28

    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7

    Now that is odd. I've never had a particular file type ever get restricted like that, at least no common file types.
      My System SpecsSystem Spec

  9. #29

    Posts : 480
    Windows 8 Pro x64

    Quote Originally Posted by arachnaut View Post
    I'm not sure why you want the test run like this.
    I imagine you're sure now
    Quote Originally Posted by arachnaut View Post
    PROCMON kept reporting an 'access denied' for the UserChoice key.
    I'm glad you solved the problem by yourself
      My System SpecsSystem Spec

  10. #30

    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)

    For the sake of completeness and to help others looking into this, I'll summarize what I've been able to learn about the default program handling in Windows 8.

    I'm just going to focus on one particular extension '.txt' and one application 'UltraEdit' which I'll call UE for short.

    By default, Windows 8 sets up 'Notepad' as the default handler for this.

    A user can change the default program in several ways, I'll use the Default Programs Control Panel as the standard way to manage this.

    You can select the list of file extensions handlers and alter them with that control panel, but it will only supply ones that have readable registry keys by the running user account.

    In my case, some of these keys were restricted to Administrator only so I could not change them.

    After allowing myself access to the proper keys, I was able to change them.

    The particular keys involved in this are under this registry key:


    For a particular extension there are several sub-keys:
    OpenWithList - a set of programs that can open this extension
    OpenWithProgids - a set of program IDs that can open this extension
    UserChoice - the program ID that the current user chose to handle this extension

    In addition, the UserChoice has an addition key called 'Hash' which I presume is added as a security feature.

    Now to focus on UltraEdit and the problem I observe.

    At some point recently, I don't know when, I lost the association of .txt files to UltraEdit. Since I mostly access UE through the right-click menu and not by double-click, I didn't notice that. UE adds a right-click option to edit all file types (or maybe I set it up that way). I've been using UE for decades so I don't always remember the default behavior and what I've changed.

    When I investigated that problem I discovered that my account was denied access to the UserChoice field of '.txt'.
    I have no idea why that happened, but I changed it to allow me access.

    After getting access I was able to choose UltraEdit as my default program.

    However, there were further problems which remain unsolved. I am attempting resolution with the UE people.

    Here is what I see happening.

    Firstly, UE is not registering itself with capabilities in the HKLM\Software\RegisteredApplications, so it is not recognized as a default program handler. If it did so, the defaults handler could query it and list it as an application with default settings.

    Instead, it has it's own File Associations handler in its configuration menu.

    Unfortunately, this does not seem to work in Windows 8 because it does not set the Hash key.

    If I use UE to set file associations, the OS reverts back to NotePad because the Hash key is gone.
    If I select UE manually, the Hash key is set and all works well.

    I have a feeling that this Hash key is a recent change, maybe a security fix.
      My System SpecsSystem Spec

Page 3 of 4 FirstFirst 1234 LastLast
'Pick an app' is always default program for .TXT
Related Threads
Solved Cannot set a PDF default program in Software and Apps
Hi, I cannot setup a program to open up PDF files on default. EXPLORER all ways ask me to choose between 3 options: Nitro Pro 9 Reader (MS app) Word (Desktop)
Default program issue in Software and Apps
Please could anyone offer me some assistance with a little problem I have with my computer. I have reinstalled the operating system Windows 8.1 Pro and since then am unable to change the default programs. Whenever I click to change program I get a message on the top right that says "You have new...
changing a default program in Software and Apps
I am trying to open the help files that are associated with Corel Psp x6 but every time I click help, it tries to open Dreamweaver. Dreamweaver won't open and gives me a message saying it stopped working and has to close. I tried opening the help files when Dreamweaver was already opened and got...
Solved Default Program for Photography in Software and Apps
In setting up the default program of Photo Gallery for my photographs, there are a ton of .xxx that I don't recognize that open in Photos. Since I don't know what they are, I've left them alone for now; however, I still wonder about them. Some of them are .ari, .cap, .dcf, .dcs, and the list...
Solved Windows 8 default mail program in Browsers & Mail
I am a recent user of Windows 8. Most things are self explanatory or can be deduced but the default mail program has beaten me. If I select a photo from the photo file and try to send be e-mail the screen shows 'there is no e-mail program associated with this'. I have followed the suggestions...
I noticed that you can only set the default program for FTP to a browser. I've created an FTP share in Explorer, and it would be useful to be able to click on a video file and directly play it with e.g. VLC instead of a browser. Would this be possible? Thanks in advance.
How can I change the default program for mp3 files from windows media player to metro player? thanks
Eight Forums Android App Eight Forums IOS App Follow us on Facebook