Windows 8 and 8.1 Forums

Windows Search - access denied to start service

  1. #1

    Posts : 9
    Windows 8

    Windows Search - access denied to start service

    hi there!

    My Windows Search is not working.

    I try to start it from services management but the error 5 (access denied) rises (with user SYSTEM)

    I tried create another user with admin privilegies, but it is not working as well, error 1297 rises

    I think I added some folder to indexing and COULD this folder is not with SYSTEM privilegies...BUT I cannot see the folder indexed because the service IS NOT WORKING

    any clue ?

      My System SpecsSystem Spec

  2. #2

    Posts : 1,093
    Windows 8 Pro Windows 8.1 Preview

    You could try removing the feature by unchecking the box in the image below and then try adding the feature back again to see if that fixes your problem:

    Attachment 24049
      My System SpecsSystem Spec

  3. #3

    Posts : 480
    Windows 8 Pro x64


    In addition to the post above:

    1. Run sfc /scannow in the elevated command prompt.
    If it can't repair files, follow DISM - Fixing Component Store Corruption in Windows 8, then repeat SFC.

    2. Restore Windows Search service settings using the REG-file. Services - Restore Default Services in Windows 8

    3. Open the registry editor and make sure that SYSTEM has Full Control and Read on
    4. Open the classic Control Panel (control.exe) and search for search. Use the troubleshooter you find in there. Ignore a message about incorrect permissions, if you see one.

    Report the results of each step in the next post.
      My System SpecsSystem Spec

  4. #4

    Posts : 9
    Windows 8

    Hi guys...I appreciate all the proposals...but I had made some procedures, one of I change the permissions in regedit set LOCAL SYSTEM with full control. and after that, my private user lost completely the admin permissions... I couldnt access admin processes, as taskmgr, regedit, services msg etc...

    I would like to thank you all to the ideias, but I did have to resign and formated my windows to the frabric configs.. :/

    BTW: the ideias had been done. I post the print screen in brazilian site: Windows Search - acesso negado para iniciar serviço - FórumGdH

    Thanks all!!!
      My System SpecsSystem Spec

  5. #5

    Posts : 7
    Windows 8.1


    I was troubleshooting a very similar error for a couple hours, and I tried a couple things, of course. When I started or stopped the Windows Search service, I had an 'Error 2.' My IE pages were talking to the windows search code, because it would send an error every minute to the event viewer. I could not start the Windows Search service, and it was counting the number of times that it failed in my event log, and it was a couple thousand times.

    Steps that I did:
    1) virus scans/maleware scans
    2) sfc /scannow
    3) running the "DISM /Cleanup-Image" tool for both from a command prompt and also from a powershell.
    4) ran another sfc /scannow
    5) rebuild the indexer from the control panel from the advanced tab
    6) tried the computers Troubleshooting Tool for the Indexing
    7) checked the services

    Alot of 'yuck, yuck, yuck, yuck!!!!' Nothing worked. I was lucky to Google and find this link.

    [FIX] "Windows Search'' Service Failed To Start In Windows 8.1 - Kapil Sparks?
    [FIX] "Windows Search'' Service Failed To Start In Windows 8.1 - Kapil Sparks?

    8)a)launched regedit
    b) Went to this key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\FileChangeClientConfigs
    c) On the right pane, I changed VALUE DATA from 0 to 1
    d) clicked OK
    e) rebooted computer

    I would check the event viewer and the errors were still launching, so I had to continue with the link and went to the regedit again.

    9) Went to this folder: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\FileChangeClientConfigs
    10) Renamed the folder FileChangeClientConfigs to FileChangeClientConfigsBK
    11) rebooted the computer again
    12) I now have 2 versions of the FileChangeClient Configs, and I could still start/stop the Windows Search service, and NOW the error messages are no longer timestamped in the eventvwr.

    Of course, I had a backup of my registry already on my HDD when troubleshooting earlier, so this my logic why I did not mention about saving a backup of my registry. I also cleaned-out all of my logs in the eventvwr, because having all of those entries takes up space too.
    Last edited by Charles14921984; 18 Jan 2014 at 22:12.
      My System SpecsSystem Spec

Windows Search - access denied to start service
Related Threads
Hi, Yea this problem started from no reason, it first happened when my avast warns me that it cant start the service i tried to do that manually but it gives a "Access Denied" warning, so i went to the registry and tried to set the permissions there by going to:...
Hi, I have the same issue. System stopped booting, HDD - "Access Denied" when I'm trying to transfer data on other computers. Tried taking the ownership, still nothing has changed. I've followed a suggestion on one of the Forums to boot from Windows 7 bootable disk. Te result - "Wrong...
I just upgraded to W8.1 and now I find the my indexing/search service won't start. It tries, but won't start. I have used the Search Troubleshooter and Search Service still fails to start. Also, a right click on the start button, a menu pops up that resembles classic Windows Start Menu. Most...
Hi All! I'm relatively new here and I have a very annoying problem with my new laptop that, (unfortunately), runs the despicable OS, Windows Hate....oops, I mean '8'. I'm the ONLY user, the owner AND Administrator of my laptop, but I'm denied access to my own files!! I'm only a casual user,...
Since installing Windows 8, I have been having sporadic problems with access denied. Examples follow: PIMEX is a Personal Information Manager that I have been using through several generations of Windows. When I first converted to Windows 8, this program worked with no problems. Now, however,...
I get the following error The Windows Search service terminated with the following error: Access is denied. in the event viewer and also, the metro interface freezes when i try to search something and clicking onto files, i get this event viewer error at the same time. Why is this?
I've been getting a "File Access Denied, You'll need to provide administrator permission to rename this file", popup window even with UAC turned off? The files in question are shortcuts in the C:\ProgramData\Microsoft\Windows\Start Menu\Programs. It also happens in ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook