Windows 8 and 8.1 Forums


Windows Modules Installer service was changed

  1. #1


    Posts : 9
    windows 8 pro

    Windows Modules Installer service was changed


    Hi,

    After last week' update I started seeing a lot of "The start type of the Windows Modules Installer service was changed from auto start to demand start." Even ID 7040 in my system event log.

    It triggers when laptop is idle (win 8 pro 64 bit), the CPU usage goes to 30% and higher and the event log gets pounded with the above messages.

    Any help is appreciated. Thanks.

      My System SpecsSystem Spec

  2. #2


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Even if you set it to automatic it will revert to manual on its own.
      My System SpecsSystem Spec

  3. #3


    Posts : 9
    windows 8 pro


    Thanks for reply. Now I'm noticing different stages of 7040

    The start type of the Background Intelligent Transfer Service service was changed from demand start to auto start.
    The start type of the Windows Modules Installer service was changed from demand start to auto start.
    The start type of the Windows Modules Installer service was changed from auto start to demand start.
    The start type of the Windows Modules Installer service was changed from demand start to auto start.
    The start type of the Windows Modules Installer service was changed from auto start to demand start.

    etc.
      My System SpecsSystem Spec

  4. #4


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    I'm no expert but I think the modules will activate as needed if left on manual.
      My System SpecsSystem Spec

  5. #5


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    This is "Trusted Installer" - It loads when needed. Keep it on Manual.

    My BITS goes through the same permutations.
      My System SpecsSystem Spec

  6. #6


    Posts : 9
    windows 8 pro


    yep it is manual. it seems i had some issues with the Windows Update. I had ran 'Fix problems with windows update' and it reported 2 issues it managed to fix. now when idle, laptop doesn't get into Windows Update hog.
      My System SpecsSystem Spec

  7. #7


    Posts : 9
    windows 8 pro


    I'm still perplexed why this service utlilizes CPU with 100%, it is just beyond me. Properly designed OS should not peg CPUs to 100% during idle periods, period.
      My System SpecsSystem Spec

  8. #8


    Posts : 9
    windows 8 pro


    resolved the issue. it looks it had to do with the Logitech wireless mouse (M185) driver. Module service and system service consumed 60% and above of the CPU when in idle state. Windows 8 should really have a means of isolating bad behaving drivers or at least some way of recognizing the situation and providing the feedback. i know ddk provides utilities for troubleshooting system issues, however people with linux (or similar) background wouldn't want to deal with windows at that level.
      My System SpecsSystem Spec

Windows Modules Installer service was changed
Related Threads
User Profile Service service failed to sign-in in User Accounts and Family Safety
Hello All, So for the past few hours I have been trying to create an account on my computer and have not been able to log onto it. It doesn't matter if I create a local User, Admin, or use a Microsoft account (Admin or not). I've tried restarting my computer. Tried turning it off and letting it...
The User Profile Service service failed the sign-in. I reimaged the pc with Easeus Todo Backup and I get the above message. Can't start in safe mode or use a restore point. I may have used the image from one of my other gigabyte desktops. Is there any way I can make this work?
Hey guys, today I just found my 2 ram modules hidden in my drawers, since these 2 are the same as the 2 I am using along with 2 other modules, I decided to install the 4 identical ram modules(GEIL 1D DDR2 800mhz). Initially, I had 2 ramaxel 1g 667mhz and 2 GEIL 1G DDR2 800mhz. When I did this,...
Solved The User Profile Service service failed the sign-in. in User Accounts and Family Safety
The User Profile Service service failed the sign-in. User profile cannot be loaded. (Window 8) Today when I tried to use my laptop, I got an error when attempting to log on with my profile. It states: "The User Profile Service service failed the sign-in. User profile cannot be loaded." ...
Hi guys, new guy here hoping to get some help. So after encounter a failure of the User Profile Service and messing around on my computer a bit, I was able to get the problem fixed and have created a new account. The problem is that now everything on my old account is now under the old user folder....
Hello everybody! I am not sure if this is the right subforum, but I didn't see where else to post it, so... Since I upgraded to Windows 8 Pro, I keep getting the error "The Windows Installer Service could not be accessed" when trying to install programs from an msi package. Unfortunately, Google...
Hi, I have win8 Enterprise. when i connection to internet two service with names service host: Network service and service host: local system download automatically, i thought that it relate to windows update but automatic update is off and my windows is up to date. what is the problem? what can i...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook