Windows 8 and 8.1 Forums

Unable to registrer "RICHTX32.OCX" and "MSWINSCK.OCX"!!!

  1. #1

    Unable to registrer "RICHTX32.OCX" and "MSWINSCK.OCX"!!!

    Hello! I'm trying to registrer the .ocx's mentioned above.
    I first put the .ocx's in the windows/system32, and thereafter ran the regsvr32 command in cmd (as an administrator). I also tried to registrer them from the windows/SYSwow64. (I run x86).
    However, I get the following error for both of the attemps:

    The module ".ocx" failed to load
    Make sure the binary is stored at the specified path or
    debug it to check for problems with the binary or
    dependent .DLL files.

    The specified module could not be found.

      My System SpecsSystem Spec

  2. #2

      My System SpecsSystem Spec

  3. #3

    Posts : 5,360
    7/8/ubuntu/Linux Deepin

    Did you copy the ocx files into syswow64, then do this?

    cd \windows\syswow64
    regsvr32 filename.dll
      My System SpecsSystem Spec

  4. #4

    It's a .ocx not a .dll.
    Yes. I opened CMD (as Administrator)
    cd windows
    cd syswow64 regsvr32 filename.OCX

    I also did exacly the same with two other files (in system32), and it worked. It is just RICHTX32.OCX and MSWINSCK.OCX that's not working.
      My System SpecsSystem Spec

  5. #5

    Posts : 5,360
    7/8/ubuntu/Linux Deepin


    Try installing Karen's tiny replicator program - see if that is able to register RICHtx32.OCX ( it does that during installation ). Great program, btw. Tho it says sys32 below, they are in fact in syswow64

    Checking for Visual Basic Runtime v6.0
    Visual Basic Runtime v6.0 installed
    RICHED32.DLL Installed
    Extract: C:\Windows\system32\MSCOMCTL.OCX... 100%
    Registering: C:\Windows\system32\MSCOMCTL.OCX
    MSCOMCTL.OCX Installed
    Extract: C:\Windows\system32\COMDLG32.OCX... 100%
    Registering: C:\Windows\system32\COMDLG32.OCX
    COMDLG32.OCX Installed
    Extract: C:\Windows\system32\MSCOMCT2.OCX... 100%
    Registering: C:\Windows\system32\MSCOMCT2.OCX
    MSCOMCT2.OCX Installed
    Extract: C:\Windows\system32\RICHtx32.OCX... 100%
    Registering: C:\Windows\system32\RICHtx32.OCX
    RICHtx32.OCX Installed
    Output folder: C:\Program Files (x86)\Karen's Power Tools\Replicator
    Extract: PTReplicator.exe... 100%
    Extract: PTReplicator.chm... 100%
    Extract: PTReplicator.txt... 100%
    Create folder: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Karen's Power Tools
    Create shortcut: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Karen's Power Tools\Replicator.lnk
    Created uninstaller: C:\Program Files (x86)\Karen's Power Tools\Replicator\uninstall.exe

    Karen's Replicator

      My System SpecsSystem Spec

  6. #6

    Have installed the program now, what should I do now?
      My System SpecsSystem Spec

  7. #7

    Posts : 5,360
    7/8/ubuntu/Linux Deepin

    Did it say it had registered

    RICHtx32.OCX ?

    If so, that is half what you wanted to do..

    If not , there may be an issue with your system somewhere. I haven't come across this before.

    Maybe try this now:

    regsvr32 c:\windows\syswow64\MSWINSCK.OCX

    I always run cmd as admin.
      My System SpecsSystem Spec

  8. #8

    Richtx32.ocx works great now! Thanks.
    "MSWINSCK.OCX" still isn't registrated, but couldn't that be due to not being located in the windows\system32 folder during installation of "Karen's Replicator"?
      My System SpecsSystem Spec

  9. #9

    Posts : 5,360
    7/8/ubuntu/Linux Deepin

    As far as I know, Karen's doesn't use or install MSWINSCK.OCX.

    I think it should be in sysWOW64, rather than sys32.
      My System SpecsSystem Spec

  10. #10

    Thank you so much!
    It worked by placing "MSWINSCK.OCX" in syswow64, and thereafter running the "regsvr32 MSWINSCK.OCX" command in cmd (as admin). Thank you very much for your assistance.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Unable to registrer "RICHTX32.OCX" and "MSWINSCK.OCX"!!!
Related Threads
Hello My Brand new Laptop: Lenovo g505 after upgrading it to windows 8.1 from MS Apps store now i am not able to connect to internet i get "limited" or "No Internet Access". i have tried to re install the driver no luck Lenovo support suggests to do factory rest but i dont want to go back...
I just ran "sfc /scannow", got the message "Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.Log ...". I opened that with texteditor, and found 4 Cannot repair member file "Amd64\CNBJ2530.DPB of prncacla.inf ... lines in the...
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
Hi guys, as most of you will be aware with the show desktop feature in the windows, which in the system tray on bottom right of your screen. I need a tweak or registry edit to make it do "Win + M" Minimize all Windows, instead of "Win + D" show desktop. Reason is it hides my gadgets and...
As the title states, I was wondering how I would do that? Because I really want to add a custom ".tga" 'close' button to my windows theme. I am using WindowBlinds: (link) - Skin the Windows desktop interface with WindowBlinds WindowBlinds let's me edit and make my own theme by using their own...
Hello all, I'm new here, so please bare with me. I'm assuming this is the appropriate section of the forum to post this question, so here it goes.... I've just had Windows 8 Home installed over the past months, and have now come across a strange problem, which seems not uncommon from other...
So got windows 8 Dev installed so far so good, I thought I would like the left screen bump to go to last app or program used feature till I installed some games and tried to play them suddenly my left side of my screen is no good if needing to scroll to the side say in a game like Starcraft II,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook