Windows 8 and 8.1 Forums


Must Enter Admin Credentials to Install Programs

  1. #1


    Posts : 7
    Windows 8.1 Pro x64

    Must Enter Admin Credentials to Install Programs


    On a new Windows 8 Installation, I created a local non/domain user. This is typical for me. I had no idea the first user is the "magical" user.

    Then I added the domain user and made sure it was an Administrator, both on the Metro settings and on the Desktop. At least, if I go in now and look, it claims to be an Administrator.

    Then I joined the company domain and that seemed to work OK. And then I made the account a Microsoft Account type user.

    Now, whenever I install a program, it wants Admin Credentials. I put in the Domain Admin credentials and that works to install the program. But this happens over and over again, as I am moving from Windows7 to Windows 8.

    I read that any secondary users cannot install programs without being changed into an Administrator. Well, I did that, but it still does the same thing.

    Since I am part ways through my switch to Windows 8, I would rather not start over again, if there is some way to fix this, although I don't want to disable UAC either. It just seems like I should be recognized as an Admin and yet I'm not. Any ideas where I went wrong?

      My System SpecsSystem Spec

  2. #2


    Posts : 7
    Windows 8.1 Pro x64


    I may have found the problem. Maybe. The user profile situation seems different on Windows 8 from Windows 7. I still have to test further and make sure this solves it.

    Let's say that the computer name is Comp1 and the user's name is Paul. And this PC is joined to domain1.
    Going into Control Panel/User Accounts, I see 2 accounts listed:
    Comp1\Paul
    Comp1\paul.lastname

    Notice how they both have the computer name as the domain. On windows 7, seems like after I joined the domain, I would end up with a profile of domain1\paul.lastname . Maybe I'm not remembering this correctly.

    So anyway, after going into the PC as the first initial user (Comp1\Paul), then I went into control panel/User Accounts and added domain1\paul.lastname as an administrative user. My files are stored under Comp1\Paul, but now, when I logon as
    domain1\paul.lastname, suddenly I got an install to work without asking for an administrator's credentials.

    So why did this work like that, do you suppose? I'm going to mark it as solved, in any case.
      My System SpecsSystem Spec

Must Enter Admin Credentials to Install Programs
Related Threads
Hi There I am trying to troubleshoot a windows 8 Sony Vaio laptop. I am not sure exactly what has happened but I cannot run anything on it. For example when I open My Computer and the C:\ I get "C:\ is not Accessible access denied" I can open cmd prompt but if I try to run as...
I seem to have a problem with some programs not running at startup. Found out some of them need to be run as admin to even work. So changed the exe to run in admin mode and that worked, but not for startup. Then with a shortcut tried properties-advanced- run as administrator and placed it in...
Quicktime stopped working. Logged in as admin. Uninstalled then tried reinstall of 7.74.80.86 and 7.6 using 'run as admin'. No luck. Insufficient privileges to the directory--c:\program files (x86) Quicktime. When I look at the folder properties under security---'You must have read permission to...
Greetings to all, I have just realized that I can only install third party software in 'admin mode'. That never happened to me before. I have always been able to install software with my user which is 'admin' on my PC. Is it bad Doctor ? :D I installed 'classic shell' and realized the issue....
When I run, for example, command prompt under admin, my system wide shortcuts for winamp ("+" on Num Pad) are not working in that program
Hi everyone I have a small problem. I'm running windows 8 pro 64 and it appears windows is protecting it's program folders (or system folders anyways) from unauthorised modification. So, for example, I have Trion's Defiance, which I play from time to time, and it starts through a patcher that...
Is there any way to install a software without admin password in standard user account?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook