Windows 8 and 8.1 Forums

Windows 8

  1. #1


    Posts : 1
    windows 8

    Windows 8


    So I used the beta for months until it told me two days ago my beta was over.

    I have never had so many problems with a fresh install of anything before.

    It crashes if I don't install something in compatibility mode. It crashes games with errors I have never seen before even during the beta. Why dear god is this RC worse than the beta?

    The worst part is, I spent 40 bucks on this, when just today I was granted access to the programs at school, and could have gotten windows8 for free...

      My System SpecsSystem Spec

  2. #2


    Posts : 1,925
    Windows 8.1 Pro


    Many questions...

    Did you install all the latest Windows updates? Did you install the latest video driver from your hardware vendor? When you say "fresh install" do you mean you did not perform an upgrade? Have you looked at the crash results to see if you could identify where the problem was? When you say "it crashes", do you mean the OS or the apps? And by "crashes" do you mean a blue screen, or something else?
      My System SpecsSystem Spec

  3. #3


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    Quote Originally Posted by x3tsniper View Post
    So I used the beta for months until it told me two days ago my beta was over.

    I have never had so many problems with a fresh install of anything before.

    It crashes if I don't install something in compatibility mode. It crashes games with errors I have never seen before even during the beta. Why dear god is this RC worse than the beta?

    The worst part is, I spent 40 bucks on this, when just today I was granted access to the programs at school, and could have gotten windows8 for free...
    Did you install via online download? If yes, did the Windows Upgrade Assistant identify any significant problems with your system? Did your current problems start immediately after installation? Have you tried to system restore back to before your problems began? Have your run the sfc /scannow command several times in sequence?
      My System SpecsSystem Spec

Windows 8
Eight Forums Android App Eight Forums IOS App Follow us on Facebook