Windows 8 and 8.1 Forums


Album art is not showing up in Windows Explorer Help! plz

  1. #11


    Posts : 52
    Windows 8.1 Pro Pack x64


    No, the registry hack made no difference, though I did it for MP3s since that was my problem. The files appear exactly the same, without a thumbnail. I guess I'll continue to use folder arrangement. I don't really mind it, I just prefer the artist arrangement. I'm fairly confident now that this was an overlooked bug in Windows 8.

      My System SpecsSystem Spec

  2. #12


    Posts : 52
    Windows 8.1 Pro Pack x64


    I tried the suggestions in this thread (MP3 album art embedded but not showing in W.Explorer - Windows 7 Help Forums) and nothing worked, either. I thought the .reg file from a working computer would do it. The files did refresh, but when the showed up again, they still did not have artwork.
      My System SpecsSystem Spec

  3. #13


    Posts : 52
    Windows 8.1 Pro Pack x64


    I can go through my 100GB music collection and add missing artwork with Mp3tag (which is not a very user-friendly program, by the way), but even if I do, it's probably not going to add them back to Windows Explorer. I just tested it on one album: I replaced the artwork that was already there with artwork from Amazon. Then I applied it, discarded the old cover, and refreshed Windows Explorer. Of course it made no difference.

    What else can I try?
      My System SpecsSystem Spec

  4. #14


    Posts : 52
    Windows 8.1 Pro Pack x64


    I played around with Mp3tag (meaning I did nothing significant), opened WMP, refreshed my library a few times, changed the arrangement to artist, to discover that 10 of my 981 albums now had art, so I went to an album without art, clicked properties, changed the default program to Windows Media Player, and watched in amazement as all of my art for all of my albums began to appear. This problem is solved. Thanks for your help!
      My System SpecsSystem Spec

  5. #15


    Posts : 2
    Windows 8.1


    I like Soham's solution....but my problem is that when I open the Details Tab....the fields are not editable. I click and nothing happens.

    Anyone know why Windows is not allowing me to edit these fields?
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Album art is not showing up in Windows Explorer Help! plz
Related Threads
Figured it out. It was showing the files, while on the other folders it was showing the album cover which was embedded.
:mad: I have followed all the advice given that I had found thru googling, most came from off the Win7 forum here, but was related to a win8 or 8.1 upgrade.... I just purchased new Insignia multi-card reader connected to machine, got the windows connected sound, but nothing in the windows...
Hi all! I recently installed Win8 and have noticed that at some point the tags stopped displaying in Windows Explorer for media files such as mp3 and m4b. This affects my collection of Music and Audio books that I had to perform a big resue operation on. I can't sort them according to the...
Iam running 8pro 64 bit. when I open an file explorer window, sometimes there is everytihg, but most of the time, there is just "desktop" and it is searching.I have to manually right click and open new explorer to get it to show all drives and locations. Also, when I get into a window with movies...
First, It's my honor to be with you in this forum. This is my first thread ! I'm really tired and angry with a very annoying error of windows explorer. windows explorer is getting crashed while opening any folders accidentally, especially folders with large number of files and images. ...
Hi, when i click network while i am in windows explorer, the network infrastructure is not there, only the Computer is visible there and i want to fix something by changing the properties of my modem/router on the network infrastructure pls help me thnk u:(
I have checked in the only two places I was aware of that would cause this: Folder Options - View ....however, there is no option there to check show Thumbnails. I believe this option should be there at the top, but it isnt. I also went to Properties of My Computer, Advanced, Performance. ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook