Windows 8 and 8.1 Forums


AutoPlay does not launch

  1. #1

    AutoPlay does not launch


    When I insert a memory card or thumb drive I expect autoplay to launch, but it doesn't. Working on desktop, when I right click the drive in File Explorer, I can open AutoPlay and select an action. But after doing so, then removing and reinserting the card or drive, nothing happens.

    Any suggestions?

      My System SpecsSystem Spec

  2. #2


    Posts : 1,925
    Windows 8.1 Pro


    This is long since gone. After a round of viruses caused by autoplay, it was removed from Windows on USB devices.
      My System SpecsSystem Spec

  3. #3


    I stumbled onto the answer. Control panel > Hardware and sound > AutoPlay > check Use AutoPlay for all media and devices
      My System SpecsSystem Spec

  4. #4


    Posts : 1,925
    Windows 8.1 Pro


    You didn't say it was for music. I assumed you were talking about applications, in which case my answer is correct. For music, then yes your solution should work.
      My System SpecsSystem Spec

  5. #5


    Actually my memory card holds photos. When I insert it now I get Picasa as desired. And when I insert a thumb drive File Explorer gets automatically opened.

    What doesn't happen like it should is that when the use AutoPlay is left unchecked there is no AutoPlay popup menu asking what you want to do.

    Cheers.
      My System SpecsSystem Spec

AutoPlay does not launch
Related Threads
Autoplay Not Working with 8.1 in General Support
For the past few months I've noticed that Autoplay does not come up, on my PC anymore, when I insert a CD or any flash drive. I have had Windows 8 since April 2013 and I upgraded to 8.1 a few months ago. I have looked all over Google for help and answers but nothing seems to be working. I...
My computer has AutoPlay on, and is able to work (I think, I have the Shell Hardware Detection enabled on auto in my Services, and I did some registry stuff from here https://www.eightforums.com/tutorials/30511-autoplay-turn-off-windows-8-a.htmland when I insert the .reg file to enable AutoPlay this...
USB Device does not autoplay in Drivers & Hardware
Hey. I've just come across an error which is quite frustrating. I use a Sandisk Cruzer Extreme USB 3.0 32gb flash drive. When I plug the flash drive in, autoplay does not come up however the flash drive shows up on My Computer, but not Device Manager. It does not show up on the tray (the...
Solved AutoRun/AutoPlay tile in Drivers & Hardware
I have a thumb drive that I regularly plug in and out of the front of my tower using the same USB port. The drive has an assigned letter. Plugging it in is no problem. It is detected fine and I have AutoPlay set to do nothing. I do not desire to use the AutoRun/AutoPlay on the desktop taskbar to...
AutoPlay Ask Me Window in General Support
I've set the AutoPlay option for some devices to "Ask me every time". When AutoPlay is activated on those devices, I get kind of a notification box at the upper right of the screen (that fades away) that I have to click on to get my choices of what to do. Is there a way to have it just open the...
AutoPlay in Installation & Setup
There is an app here that, when opened, causes all AutoPlay optical media settings to revert to "Take No Action." Is there an AutoPlay setting that can thwart this, in the same manner that a file can be set to READ ONLY?
Solved Autoplay in Installation & Setup
Hi all, below are snips of autoplay in 7 and 8. At the top of the one from 8 it shows "Storage devices", not so in the one from 7. Is this new in 8 or is my 7 corrupted? I had the same flash drive connected for both shots. 1277 1278
Eight Forums Android App Eight Forums IOS App Follow us on Facebook