Windows 8 and 8.1 Forums


Windows 8 hangs at black screen after resume from sleep

  1. #1


    Posts : 10
    Windows 8 Pro

    Windows 8 hangs at black screen after resume from sleep


    Hi,
    Please help if you can. Installed Windows 8 Pro clean install just kept my files. Now, every time I resume from sleep it hangs at a black screen for what seems like ever. Only way to start is to hold power button to turn off then restart it. Any help would be great. Thank you so much. Not sure if I posted this in the correct area but wasn't sure where to put it. Thanks.

    Dave

      My System SpecsSystem Spec

  2. #2


    Posts : 1,925
    Windows 8.1 Pro


    Have you installed all your vendors drivers for things like video card, chipset, usb, audio, etc?

    Have you made sure you have the most recent BIOS for your computer?
      My System SpecsSystem Spec

  3. #3


    Posts : 10
    Windows 8 Pro


    Thanks for the response! Well, it installed with the drivers I already had from Vista. Which now makes sense that they may need to be updated. Is there still a good driver download site for all different drivers? or do you recommend just going to each site individually? Thanks for the help.
      My System SpecsSystem Spec

  4. #4


    London
    Posts : 90
    Windows 8.1 pro media centre 64bit


    Is your system pre built ? if so just go to the vendors web site put in the model number, in the support section normally. They should then give you a list of all current drivers available for your machine.
      My System SpecsSystem Spec

  5. #5


    Posts : 10
    Windows 8 Pro


    Quote Originally Posted by Trevers1987 View Post
    Is your system pre built ? if so just go to the vendors web site put in the model number, in the support section normally. They should then give you a list of all current drivers available for your machine.
    Thanks! That works!
      My System SpecsSystem Spec

  6. #6


    Posts : 10
    Windows 8 Pro


    Was just checking the HP site and trying to install some of the drivers. But they only have Windows 7 available and it said doesn't support my OS. Hmmm. Any ideas? Thanks.
      My System SpecsSystem Spec

  7. #7


    London
    Posts : 90
    Windows 8.1 pro media centre 64bit


    Quote Originally Posted by dbnjzb View Post
    Was just checking the HP site and trying to install some of the drivers. But they only have Windows 7 available and it said doesn't support my OS. Hmmm. Any ideas? Thanks.
    What the make of your system? So i can look into your problem feather, did all the windows 7 drivers fail to install or just certain one?, reason I ask is because most of the latest windows 7 drivers are compatible on 8 or are leased doing there job as with all new thing the bugs need ironing out.
      My System SpecsSystem Spec

  8. #8


    Posts : 10
    Windows 8 Pro


    Quote Originally Posted by Trevers1987 View Post
    Quote Originally Posted by dbnjzb View Post
    Was just checking the HP site and trying to install some of the drivers. But they only have Windows 7 available and it said doesn't support my OS. Hmmm. Any ideas? Thanks.
    What the make of your system? So i can look into your problem feather, did all the windows 7 drivers fail to install or just certain one?, reason I ask is because most of the latest windows 7 drivers are compatible on 8 or are leased doing there job as with all new thing the bugs need ironing out.
    Question, wouldn't it show an incompatibility in device manager if there was a problem with the driver?? I tried audio and network drivers. thanks.
      My System SpecsSystem Spec

  9. #9


    Posts : 1,925
    Windows 8.1 Pro


    Quote Originally Posted by dbnjzb View Post
    Thanks for the response! Well, it installed with the drivers I already had from Vista. Which now makes sense that they may need to be updated. Is there still a good driver download site for all different drivers? or do you recommend just going to each site individually? Thanks for the help.
    You should be able to get all drivers from your manufacturer for most of them. Your video card will probably be separate.
      My System SpecsSystem Spec

  10. #10


    London
    Posts : 90
    Windows 8.1 pro media centre 64bit


    try getting the latest video drivers for system i have a feeling this is where the problems lies

    Also any none functioning device will show as unknown and be marked with a yellow !
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Windows 8 hangs at black screen after resume from sleep
Related Threads
Hello Sometimes (NOT ALWAYS) my laptop simply doesn't respond when I put it to sleep mode. I just click put to sleep, then it is behaving like it is going to sleep, but then it "freezes" on black screen, HDD is running, fan is running, led indicator is flashing, but it doesnt respond. The only...
This is a Windows 8 OEM CD install, on an i7 x64 system. I have tried this with both UEFI and legacy modes. I cleaned the drive and allowed setup to partition and format how it sees fit on an Intel SSD. The system copies files, sets them up and reboots. The blue windows logo is up for a...
Hello, I thought I already had my portion of "luck" with Win 8.1 but it's not over yet. My other two threads: https://www.eightforums.com/installation-setup/31157-windows-8-1-rtm-installation-fails-dell-xps-1340-a.html (Solved)...
Thought this was problem - Microsoft writes "When you resume a computer from sleep or from hibernation, the SATA hard disk drivers require the SATA hard disks to be ready within 10 seconds. However, a large SATA hard disk may take longer than 10 seconds to be ready. In this situation, the resume...
Dear friends, I've got this big problem: when installing the windows 8, everything is fine until some point, ( everything goes as it should have, as on the other PC of mine). The setup "stops" after the configuring devices post. When it finishes configuring, the screen goes black, after which...
Hi I have win 8 installed for a few weeks now which I have been working on and off playing in a bios duel boot setup to see if I like win 8. (while keeping my win 7 setup) Every thing has been fine until for the first time I put the computer into sleep , after I tried to wake it up the...
I'm running Windows 8 8400 on a Lenovo s205 The origin of the issue: I messed up a little my MBR by removing the dual-boot system incorrectly, and had to repair it using a USB drive with Windows 8(the automatic repair did the trick). Immediately after the repair, the problem started. Steps...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook