Windows 8 and 8.1 Forums


Windows 8 refuses to mount .iso image because image is 'sparse'

  1. #1

    Windows 8 refuses to mount .iso image because image is 'sparse'


    Just thought I would share the solution I found to my problem mounting .iso images in Windows 8 Pro.

    The very helpful error message I was getting was this:
    Click image for larger version
    and in powershell I got this:
    Click image for larger version

    Essentially the problem is that windows .iso mounting does not like 'sparse' files. I had used Acronis backup to backup my original .iso files and this DOES use sparse files. You can check if a file is 'sparsed' by looking at the files details in properties. The 'P' in the attributes represents a sparse file. See the screenshot below.

    The result? When I restored my .iso images I could no longer mount them.

    The simplest solution I have found is to just copy the .iso to a new file - this seems to create the new file without the sparse flag set.

    Hope this helps somebody!

    Click image for larger version

      My System SpecsSystem Spec

  2. #2


    Posts : 1,925
    Windows 8.1 Pro


    For anyone that is curious.. Sparse files are files that have "reserved" space in them that is not technically part of the data. An application can create a sparse file so that it leaves room to expand it in the middle without having to recopy all the data. I can understand why Acronis would do this for a backup image.

    Shouldn't Acronis also have a file viewer?
      My System SpecsSystem Spec

  3. #3


    Posts : 4
    8.1

    cannot mount iso


    Has anyone found a solution to this issue within Win8.1? I am receiving the same error msg. I tried associating the .iso extension but it does not exist.

    Any help appreciated.
      My System SpecsSystem Spec

  4. #4


    Posts : 1
    Windows 8.1 Pro x64


    May I suggest a new solution. Here is a piece of code and application which may solve the problem. It sets the sparse flag to 0 (zero). This thing worked for me perfectly.


    https://github.com/AlexanderB1290/UnSparseISO
      My System SpecsSystem Spec

Windows 8 refuses to mount .iso image because image is 'sparse'
Related Threads
How to Do a System Image Recovery in Windows 8 and 8.1 This tutorial will show you how to restore the contents of your Windows 8 or 8.1 PC back to how it was at the time a system image was created if your hard disk or entire computer ever stops working. You can only do a system image...
System Image restore cannot detect image in Performance & Maintenance
Hi everyone, I have been trying to restore to a system image located on my had drive, i boot up into the recovery tool and select system image recovery, Once the box opens up it begins searching for an image to restore to. But every time i get an error saying windows can not find a system image...
Windows 8.1 System Image in Performance & Maintenance
I attempted to create a Windows 8.1 System Image for the first time since upgrading from Windows 8. My external backup drive has 229 GB of free space and Windows 8.1 says that it requires up to 59 GB for the image. Yet when I initiate the image creation, I get an error message saying that there...
Hello, under Win 8 Pro 64-bit, I discovered the following oddity: When I try to mount an ISO image using the Windows' built-in mounting function, it works when the the ISO is located on a local drive, but NOT if it is on a network drive (linked to my NAS). The latter case yields an error saying...
I've been dual-booting Windows 8 Pro and Windows 7 Ultimate, but a while back my Windows 8 kind of went "South" and wouldn't boot at all (I got an error message that a device was "not attached"). I have a recent system image on an external USB hard drive, but when I boot to "system recovery" using...
couldn't mount image in Virtualization
i use windows 8 professional edition, when i want to mount the image, the warning message came and it says "couldn't mount image because its in use" although i'm not mount it, do you have any answers ? thanks :D
Hi! I apologize in advance if this is in the wrong forum and if a thread on this subject already exists, I just couldn't think of any other place to put it. I got Windows 8 and it's working pretty much perfect after I fixed a few issues. But there's an interesting thing happening, and I don't...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook