Windows 8 and 8.1 Forums

SSD Woes - still a pain even with the newest OS!

  1. #1

    Posts : 7
    Windows 8 Professional

    SSD Woes - still a pain even with the newest OS!

    Ok, so the title sounds pretty negative so I'll give a few props first. I built my own win8 pro machine and the install (clean) went pretty flawless and fairly quick, granted the install media was dvd which was much slower than usb which I had used for the "previews". (I am surprised the boxed OS didn't ship on usb3 thumb drives instead but I suppose cd's are more compatible).

    Moving on, I decided to donate my old 32g SSD to my wife's PC and performed a clean install on her machine as well (yes, I bought a second copy of win8 pro) and this install went pretty seamless as well. However I realized space with slim and decided to do as I did with the "previews" and moved the following folders using mklink /d from a recovery command prompt (after using robocopy to capture all the data on my secondary drive)

    x:> robocopy /copyall /mir /xj x:\Users d:\Users
    x:> robocopy /copyall /mir /xj "x:\Program Files" "d:\Program Files"
    x:> robocopy /copyall /mir /xj "x:\Program Files (x86)" "d:\Program Files (x86)"

    and confirmed none failed

    Then deleted the original folders so I can make the symlinks

    x:> rmdir /s /q x:\users
    x:> rmdir /s /q "x:\Program Files" - first problem, files in use, couldn't delete
    x:> rmdir /s /q "x:\Program Files (x86)" - same here

    why would these be in use...whats the point of recovery command line if I can't work with the media offline???

    So I tried to at least make the symlink for the users folder which did delete but I kept getting an error at the command prompt:

    x:> mklink /d x:\Users d:\Users
    incorrect function

    even junctions...
    x:> mklink /j x:\Users d:\Users
    incorrect function

    A search on the web resulted in nothing for "mklink incorrect function" so I attempted a refresh from recovery which failed twice without any reason given. I then tried to restore which also failed...the funny thing was that it told me that it needed the installation media which was the 64bit dvd and after placing it in the drive it came up with this:

    Click image for larger version
    which is hilarious because this is the very same media I installed from. Ok, so now I am reinstalling clean after a reformat but I am still stuck on moving the c:\users, c:\Program Files, c:\Program Files (x86), and c:\ProgramData.

    I've seen a very indepth sysprep tool/xml script method which seems to be written prior to retail (which may still work but I'm skeptical this will go smooth either) as well as an option in the folder properties to change the location which appears to be super easy but does not seem to be built in the version I purchased (what?).

    So I am at a loss, any suggestions would be greatly appreciated but another reason for starting this thread is the amazement that there isn't a tool built into the installer that says something like "There is limited hard drive space on the system drive. Would you like assistance in moving your personal or program folders to another drive?"

    Wouldn't that seem like a no brainer? Especially with the growing popularity of SSDs?

    Oh and lastly, I was a little bummed I couldn't upgrade from RP (I know there is possibly some hack that may work but it requires modifying the install media which you can't do with the retails dvds) - you'd think MS would want to give back to those that beta tested and helped refine their product by making a simple key purchase as an unlocker to the retail version.

      My System SpecsSystem Spec

  2. #2

    Posts : 354
    Windows Server 2012 Standard w/Hyper-V

    I'll say what I've said in other threads like this. Leave the user folders alone. If you need space, and have a secondary drive, right-click, drag, and select "move" with the library folders (documents, pictures, etc).
      My System SpecsSystem Spec

  3. #3

    Posts : 7
    Windows 8 Professional

    That doesn't actually solve anything. That's like throwing in the towel. I was hoping to get some responses from some tweaker geeks that like taking on a challenge. This is a real problem and it appears MS has completely missed the boat.

    Again, I don't want to move just the folders within the user profile, I want to move all of the root program/user folders that don't need to be on the SSD, the core OS and that's it. I had this working without a hitch on CP and RP but the retail version for some reason has been crippled/changed for some reason because the mklink executions result in "incorrect function" now.

    And the answer surely isn't "go buy a larger SSD" either. I have a 256gb on my machine, but surely I don't want to waste this 32gb I purchased a few years ago and it has definitely increased the performance of my wife's pc. I just need to keep the remaining 8 gigs for updates, drivers etc. EVERYTHING else on the 7200 S3 drive!!!

    1) program files folders still in use and cannot be deleted or moved even in recovery mode (whats the point of recovery???)
    2) mklink doesn't work and errors out with an unknown error (did the syntax change in the win8 version?)
    3) location tab is only present on certain user profile subfolders (is there e reg tweak to add this to any folder?)
    4) restore option (using retail dvd) from recovery is completely broken and seems like a big oversight for an "off the shelves" product
    5) There is no easy way in win8 (just as previous OS's) to permanently relocate the users/program files and programdata folders and I suppose I was little too naive in thinking surely this would be addressed in the retail release of this OS...especially since there was so much talk about it in the MS dev channel.
      My System SpecsSystem Spec

  4. #4

    I don't have Win8 (so far I've seen no compelling reason to update from Win7-64) but I do have a small (64GB) SSD boot drive and I understand your desire to move stuff off your SSD.

    I used a program called JunctionLinkMagic to do that and I've had no problems. Frankly I was unaware of the mklink command or the robocopy program. I made my relocations with a plain copy/paste/delete and then used JunctionLinkMagic to create the links. So far I've not had any problems at all, other than the sometimes confusing situation where a set of files/folders appears to be in one place but is actually in another.

    Of course this is exactly the reason for making junction links, so I can't complain.
      My System SpecsSystem Spec

  5. #5

    Posts : 7
    Windows 8 Professional

    I've used that program before (also with my win7/64)'s basically a gui for the mklink cli and it works very well. Unfortunately it doesn't appear it is an option if I can't boot into a mode in which the folders I want to move, or copy, delete and link are in use.

    I know the issue with the mklink and "incorrect function" isn't really the root of the problem for the program files folders but I should have been able to at least move the "Users" folder as others seem to have had success with it...but I'm wondering if any of them have had success with a retail release because I too had used this method on the CP and RP release without issues.
      My System SpecsSystem Spec

  6. #6

    Posts : 1,925
    Windows 8.1 Pro

    You can't just copy your program files folders to another drive. Even if you could solve your problems with locked files, you will run into another problem.

    That problem is that most apps have registry entries that point to physical locations on disk. Once installed, and app can't just be copied to other places. This is nothing new with Windows 8, and has always been the case. (some apps don't have such entries and can be copied, but most won't work).

    All you can do is uninstall some apps and re-install them to the other drive.
      My System SpecsSystem Spec

  7. #7

    Posts : 7
    Windows 8 Professional

    That's not hopeful for windows 8 if that's true because I've junctioned both program folders on win7 Ult 64bit for years without issue.

    I've successfully junctioned the following folders (in Win7 and Win8 CP and RP):

    c:\Program Files
    c:\Program Files (x86)

    Actually, the only issue I have ever had with junctions is with the c:\Windows\winSXS folder which would cause some windows updates to fail, due to hard links, but that's it. One would expect a newer OS to not go back in time but forward.
      My System SpecsSystem Spec

  8. #8

    Posts : 1,925
    Windows 8.1 Pro

    Sorry, I had forgotten you were using junctions.

    When you said a "Recovery command prompt" what did you mean? How did you start it?

    Did you boot from the Windows install disk and do a recovery?
      My System SpecsSystem Spec

  9. #9

    Posts : 7
    Windows 8 Professional

    Yep, booted from the same disc I installed from and chose repair your computer and then troubleshoot, advanced options and then command prompt.

    I initially tried to make symlinks but then tried junctions as well. I think I'd be satisfied if I could figure out how to get the program file folders completely free from being in use and then also figure out how to get mklink to work without that odd error.
      My System SpecsSystem Spec

  10. #10

    Posts : 1,925
    Windows 8.1 Pro

    I think the recovery console requires that you log in, which means it has to load the registry. Not sure why that would lock Program Files though. Are you running any apps from there? Is your copy of robocopy in that folder?
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
SSD Woes - still a pain even with the newest OS!
Related Threads
It is getting some good reviews from gamers
Well I ran into an issue where I could not get to the wireless manager easily so I decided to make a nice Windows 8 Wireless Manager Tile for myself! After a little debugging and selecting the icon I wanted to use(not the one I wanted really) but more on that when someone can help me find the...
BSOD Pain! in BSOD Crashes and Debugging
Hi All, I have been trying, and failing, to rebuild my pc recently. I had 2 DOA ASRock mobo's, and have had to buy a new PSU all to accomodate my new GPU. Now I am getting BSOD's fairly regularly, 2-3 a day, I think they are all BSOD, but as they regularly occur when I am not at the computer,...
see full report
I live in Japan but I'm not Japanese. I've installed Windows 8 with English (United States) as Display language and the location in Region settings is set to Japan. All the pre-installed Apps in Metro are in English. Fine so far. Now when I download any App from Store, the installed...
Good morning to everyone! I hope you are all having a great day so far... I have several Windows 8 devices (Notebooks, Tablets, etc.) all running Windows 8 Pro. I have two systems which for all intents and purposes are identical in their software, apps, etc. On both of these systems, I...
I really wanted to like windows 8. When I first started using the OS, the new metro apps, etc, I saw a lot of potential, and I still do. The OS seems snappy at first, until you start doing some serious multi-tasking, and then it really seems to bog. My gut feel as to why this occurs, is that...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook