Windows 8 and 8.1 Forums


Weird graphics problem

  1. #11


    Earth
    Posts : 106
    Windows 7 Home Premuim x64 & Windows 8 Enterprise RTM x64


    Just unzip the zip file.

      My System SpecsSystem Spec

  2. #12


    The driver site you gave me doesnt give me zip files, only exe files.
      My System SpecsSystem Spec

  3. #13


    Earth
    Posts : 106
    Windows 7 Home Premuim x64 & Windows 8 Enterprise RTM x64


    Oh, then run the exe file.
      My System SpecsSystem Spec

  4. #14


    Posts : 5,707
    Windows 8.1 Pro


    I'm going to assume this never happened before in Windows 7. Definitely a driver issue unless you have different graphics settings within the game than before.

    Yes, you need to run the .exe file after downloading. If eXcite's download link didn't work by any chance,

    AMD Catalyst

    You can get the driver here too.

    Once the driver's installed, reboot, and check in Device Manager to see if the new driver was installed, and maybe run the Windows Experience Index again to see what Windows gives a score of for graphics for poops and giggles.
      My System SpecsSystem Spec

  5. #15


    Ill try your solution.
      My System SpecsSystem Spec

  6. #16


    I download the file, ran the process and when it finished, I rebooted. I still have the problem...
      My System SpecsSystem Spec

  7. #17


    Posts : 5,707
    Windows 8.1 Pro


    Huh, odd.

    Are there any settings within the game that are different than before like VSYNC or Anti-Aliasing?

    If not, then you might need to wait for official Windows 8 ready drivers from AMD within the next few months...
      My System SpecsSystem Spec

  8. #18


    *sigh* Okay.
      My System SpecsSystem Spec

  9. #19


    Posts : 5
    Windows 8 RC


    I got the same problem with the same graphic card. i even followed their directions to a T. I even installed the software so I can turn on OpenGL. for some reason the graphic drivers that Toshiba posted for the laptop I have (the ones for windows 8 beta) was taken down.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Weird graphics problem
Related Threads
Help - weird problem in General Support
I had a 2TB WD Black HD that was developing bad sectors, so I decided to replace it with a WD Velociraptor 1 TB HD. Everything seemed fine., though I didn't do a lot on the computer so I can't say for sure. Power outage the next night. Starting the next day, the computer boots up and shuts down...
Hello, Recently, I got a new graphics card for my computer (the card was Galaxy NVIDA GEForce 620). Well, after install some things changed that I do not like: Some games act weird. In particular, Halo CE. Before my graphics card, this game ran well. Now, after the card, when I start the game, it...
Weird Problem in Network & Sharing
First off I have 5 Windows computers in my house. 3 with 8.1, and 2 with Windows 7. I have an ASUS RT-AC66U wireless router that supports A, B, G, N, & AC. My problem is with my HP 7520 All-In-One printer hooked up wirelessly. With all the pc's off and the printer on in standby mode, I can start...
I have this weird problem in General Support
Hi I have this really weird problem. I recently upgraded my laptop to Windows 8. Everything went fine and there was no problem whatsoever. But recently, all the buttons inside the Metro (or, Modern) UI have disappeared. Either it shows only the outside ring with the insides blank, or boxes(like...
Solved Weird Problem in General Support
I'm having an issue I've never seen before. It seems to happen maybe a couple times a day (haven't paid that close attention yet). I'll be sitting there and notice the hard drive activity light is on steady and won't even blink. I can work on the system normally though. However when I try to...
Weird Weird Problem! in Network & Sharing
I have the strangest problem with my internet since updating to W8. My internet works absolutely fine all day, up until later in the day (not sure what time exactly this happens) but it stops working! It says it is connected but it simple can't find a network. I am connected via LAN to an...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook