Windows 8 and 8.1 Forums

AOE II Age of Kings - the ultimate catastrophe

  1. #1

    Posts : 1
    V3rminious II

    AOE II Age of Kings - the ultimate catastrophe

    Hello forumers. My name is v3rmin (as you can obviously tell from this post.)

    Recently I have been touched by a burning desire to restore some memories of my boyhood by playing a bit of AOE II. I haven't touched the game in a while and it seems like a good way to spend time when I'm not able to use the internet, which unfortunately happens all too frequently. However, between my last play date and the writing of this post, one thing has changed (apart from my age) - my system.

    I bought a new computer at the end of November, 2015. This system arrived in early December 2015, with Windows 8.1 pre-installed. My previous rig also had Windows 8.1 on it, but I was still able to play AOE on it just fine. There were no problems with graphics ("purple water", "red grass" etc) - everything was working. This new PC had infinitely better specs, yet there's a huge problem - the game installs alright, it just won't work.

    Let me expand on that.
    I have installed the full version of both the original game and the expansion pack, but neither will load properly. I click on the shortcut to run the game, I get a black screen suggesting some progress, before the whole thing crashes to desktop with zero explanation whatsoever. It just stops dead.

    No level of settings tweaking has worked thus far either. Compatibility mode for all manner of systems does not work. I get the same result.

    I was wondering if the helpful types on eightforums could help me out here, as I'm figuratively being driven up the wall by this frustrating cycle of hope and despair.

    My current system's specs
    Acer Aspire TC-705
    Windows 8.1
    Intel Core i5 @ 3.2 GHz (quad core)
    Nvidia GeForce GTX745 4GB
    12GB RAM
    2TB HDD (2 x 1 TB drive)

    My old system's specs
    Compaq CQ-2000
    Windows 8.1
    AMD Vision E1 @ 1.4 GHz (quad core)
    AMD Integrated Graphics
    4GB RAM
    500GB HDD

    As you can see, my new computer is far superior - and yet it can' play a 17 year old game?
    What's going on?

      My System SpecsSystem Spec

  2. #2

    Posts : 25
    Windows 8.1 64 bit (updt)

    Due to your new rig having 12 GB RAM, I assume you now have a 64 bit o/s.
    Those very old games are most likely 16 bit; they will work on a 32 bit version of Win 8.1 under compatibility mode.
    However, if 16 bit, they will not work on a 64 bit operating system.
      My System SpecsSystem Spec

AOE II Age of Kings - the ultimate catastrophe
Related Threads
Solved catastrophe with upgrade in General Support
Hello,I am new to this forum and decided to start with general support hopefully to get kicked in the right direction. Less then a year ago I purchased a new HP all in one that came with Windows 8.1 installed.The offer for upgrade to Windows 10 came and I went for it.It worked ok for about a...
Is it possible to downgrade my windows 8.1 pro pc to windows 7 ultimate?
HELP!! how can i fix this? (Mercenary Kings) i bought it from Steam and when i try to play it says this...
Solved Upgraded from Win 7 ultimate to Win 8 pro in Windows Updates & Activation
and now I would like to upgrade/build a new computer and use this license. Is this legal? How do I deactivate/surrender this license paving the way to install the purchased license on the new computer? Thanks
Catastrophe! in Installation & Setup
Had a minor problem with my internet toolbar this morning and thought I'd try a system restore to get things back to the way they were. Unfortunately - I did a 'Computer Refresh' and seem to have lost everything I had - all my systems etc., seem to have disappeared and all I'm left with is my...
BTW ., i hate windows 8 new start menu ., i miss the old cute menu anyway ., im asking about windows 8 ultimate 86 thx a lot
Eight Forums Android App Eight Forums IOS App Follow us on Facebook