Windows 8 and 8.1 Forums

PS3 Controller no longer working after 8.1 upgrade

  1. #1

    Posts : 1
    Windows 8.1

    PS3 Controller no longer working after 8.1 upgrade

    Hello, I am having trouble getting my Playstation 3 controller to work with Windows after upgrading to Windows 8.1

    I had it setup where all I would have to do is plug my PS3 controller via usb to my laptop and it would recognize it as an Xbox 360 controller.

    To do this I installed the Official Xbox 360 controller drivers from Microsoft (the newest one available was for Windows7 64bit) and then I ran the XInput Wrapper drivers acquired from here: and it would trick my laptop into thinking I had an Xbox 360 controller plugged in and I would be able to use my PS3 controller to play games.

    However, after upgrading my laptop to Windows 8.1, it stopped working. I uninstalled the Xbox 360 controller driver as well as the XInput wrapper drivers and reinstalled them but to no avail.

    Was wondering if anyone else was having this issue or was able to get their PS3 controller to work with Windows 8.1.

    - Thanks in advance!
    Attached Thumbnails Attached Thumbnails Troubleshoot.jpg  

      My System SpecsSystem Spec

  2. #2

    I had problems with SCP XInput Wrapper in the past. As of now, the most reliable tool for connecting your DS3 to your PC is via MotioninJoy.
      My System SpecsSystem Spec

PS3 Controller no longer working after 8.1 upgrade
Related Threads
I seem to be going round in circles trying to reconnect a working Windows 8 laptop to the WiFi after upgrading to 8.1 It refused to recognise the existing and working WiFi upon reboot after upgrade. I have twice ran the 'netsh wlan delete profile name=' command to remove the profile,...
This evening I went to use by portable USB drive and noticed it wouldn't work. I tried another port and it still didn't work. I then tried another device on the same ports and it also did not work. I opened up device manager and saw that my VIA USB xHCI controller was no longer listed under USB...
ALT+TAB has been around forever in Windows but in the last week or so I have notice on two computers running Win 8 that it doesn't work anymore. What up with that?
Hi. First, im on a Lenovo Y510p Laptop. Yesterday, windows updated through windows update and when i logged into my computer, none of my usb ports were working. As in: My external mouse and keyboard were not connecting, they were working just before the update though.(they are new.) Device manager...
First off I hope I have this posted in the right place. And I tried searching the forum for similar problems but didn't find any like mine. Found a lot of 8.1 related problems with the desk top but I don't think I found any exactly like my problem. My problem is ever since I installed windows...
since I have upgraded to 8.1 my remote control no longer works it is detected in device manager and driver is installed but when I click skip,play, stop etc nothing happens. I use it mainly for my music. is there a way to get it working again. I use the default music app to play music which I...
I upgraded from W7 to W8 last week and have since watched movies and played music from my laptop via my Samsung LCD TV which is connected by optical cable to my 5.1 Samsung surround sound. All was working well in W7 however since the upgrade I've no longer got an option to play the sound...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook