Windows 8 and 8.1 Forums

Age Of Empires Conquerors fails to load

  1. #1

    Posts : 9

    Age Of Empires Conquerors fails to load

    Alright I have read so many threads and posts trying to figure this one out.
    I have AoK and it runs fine.
    I have AoC and I can rarely get it to load. The only time it loads is if sometimes I load AoK first then immediately load AoC.
    I have played around with every possibility on the compatibility mode and resolution and I still get the same result. AoK does not need to use the compatibility mode at all.

    When I go to load AoC I receive,
    "Age of Empires II Expansion has stopped working
    A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

    It does not notify me. It works on my laptop which has windows 8.1
    I have reinstalled both AoK and AoC many times clean.
    I have tried both minimal and maximum on installing the game.

    Please Help!

    Thank you,


    Attached is my Direct X Diagnostic Tool

      My System SpecsSystem Spec

  2. #2

    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit

    Give this thread a look, post #15 has some tips: Windows 8 with age of empires?
      My System SpecsSystem Spec

  3. #3

    Southern California
    Posts : 788
    Windows 8.1 Pro with Media Center x64

    Steam has a somewhat upgraded version of that game that works in the Win8 environment. I myself have not been able to get those games to work with Win7 or 8, or to work well at least. I recommend tossing the old game that was created for XP, and purchase one from Steam or similar platform.
      My System SpecsSystem Spec

Age Of Empires Conquerors fails to load
Related Threads
My problem is that my computer no longer is able see Windows 8.1 on bootup. I get a “Loading OS….” message and nothing happens. Before this happened, I reset my computer from Windows with the intent to change a BIOS setting for the CPU fan and an Windows update was applied on reboot. Windows...
Running Windows 8.1 and File History was working OK for my computer, actually on two different computers worked just fine. (I never could get File History to work with Windows 8). Then suddenly this feature just up an quit. Got a little "red" flag in the Action Center. Using the control panel an...
Win 8 fails to load 2 apps on initial start up. Razr Game Booster and Acronis Scheduler.If I do an immediate Re Start both apps will load correctly. SFC tells me no problems. Event log says Acronis failed to start, nothing listed for Razr app. Any body run into anything like this ? Any...
Windows 8.1 Chrome Avast I note that the boot log indicates that driver dxgkrnl.sys failed to load 4 (separate) times. It could be loaded 1 time an attempt in the middle of the failed ones. Nevetheless the PC seems to work fine. Is there anything that I should do or check in my PC?
i wish to play age of empires on it but it just opens any ideas? also i tried changing compatability it didnt fix anything
Hi! I've just installed "Age of Empires" (conquerors) on my computer, in windows 8. It works just fine, the only problem is that the image is kind of wierd:/ When i used to play it before on vista, windows7 I was watching the game from above sort of, but now in windows 8 it's like im...
So i've had the game for almost ten years and it worked fine for ages but since I have gotten new computers it doesn't seem to work. I dont know if its the new computers or if its the OS. The game installs fine, but when I go to play it, it comes up with the loading screen but then stays at my...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook