Windows 8 and 8.1 Forums


PC lags after gaming for 2 years

  1. #1


    Posts : 2
    Windows 8 Pro 64 bit

    PC lags after gaming for 2 years


    Hello, so I bought a laptop 2 years ago:

    ASUS A46CM (64 bit)
    Original Pre-installed OS: Windows 7 Professional
    Intel Core i3 (2 Cores, 1.8 Ghz)
    [Integrated] Intel HD Graphics 4000
    [Dedicated] NVIDIA GeForce GT 635M with 2 GB vRAM
    4 GB DDR3 RAM
    500 GB HDD

    I play some games like CoD4 and Black Ops 2 and Minecraft frame rates are smooth, at about 30 - 40 fps. I play Battlefield 3 too, on medium settings and get about 30 fps
    After a year I upgraded to Windows 8 Pro and started playing more games, and their performance was smooth, and I had no worries of lag at all.

    I installed NVIDIA GeForce Experience and my drivers are updated weekly - monthly, but then I noticed my games started getting slower and slower gradually.

    Far Cry 3 originally maintains a 45 fps performance on medium settings, and Battlefield 4 gets 30 - 40 fps performance on low settings.
    Now they start to go to 30 - 20 fps. I tried everything from rolling back drivers to updating to latest drivers, putting my games on an ext. hard drive, clearing up my disk space.

    When Windows 8.1 came out a year later, I updated to it, and my games run terrible. I tried fixing it, reading game setting forums, rechecking the DirectX versions I had, running every game I had on its lowest settings, anti-aliasing off, lowest textures and everything and of course, adding programs to the list in NVIDIA Control Panel (and setting it to Performace rather than Quality)

    Far Cry 3, Black Ops 2, Battlefield 4 all on their lowest settings start with 30 fps, and then 5 seconds later drop down to 5 - 15 fps, and it only goes to 20 fps max, but drops down to 10 fps. I installed some games like Hitman: Absolution and Borderlands 2, and on their unchanged optimal settings, they also have the same results.

    I thought the problem was my OS (Windows 8.1) so I clean-installed Windows 7 back, and it actually play games worse (crappy cut off audio) than Windows 8 or 8.1.

    And now I upgraded (clean-install) to Windows 8, and the peformance was just was bad as how it was on 8.1, even when I had no additional bloatware installed except my Intel and Nvidia and Wi-Fi drivers. Now my laptop's using the 337.88 NVIDIA Driver.

    I am really tired of this problem and I just want to get back to the state where my laptop was, when gaming was still smooth as it first was(not as smooth as gaming PCs but you get the point

    If anyone can help me with this problem, I greatly appreciate it.

    Thank You.

      My System SpecsSystem Spec

  2. #2


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    Have you tried the original drivers from 2012? Switchable graphics tend to cause problems.
    When you run some video benchmark, can you check, which GPU is active/loaded?
      My System SpecsSystem Spec

  3. #3


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Yea, I would try going back to how it was originally when you bought it. OS, drivers, everything. See how it acts then. If all good at least you'll know it is something with the newer software.

    If you truly clean install everything back to OEM state and still lags on games that it originally didn't, seems it would have to be a hardware issue.
      My System SpecsSystem Spec

  4. #4


    Posts : 2
    Windows 8 Pro 64 bit


    I already did a clean install of my original OS Windows 7 and my original NVIDIA driver that came with my computer when I got it (I downloaded the driver from the ASUS drivers site), and it's still slow.

    Benchmarking was done when my laptop was not running other programs except the game and Fraps

    Do you think my NVIDIA card is burnt or something? (Sorry I'm a beginner-moderate when it comes to this texh) Because I play games quite regularly before
      My System SpecsSystem Spec

  5. #5


    Posts : 216
    Windows 8.1 Pro with Media Center


    Although you say you did a clean install of your original OS, was it from the original Asus media with the appropriate drivers for the entire system? Sometimes the drivers are a separate option after the install.

    Similarly, when you did the Windows 8 (or Windows 7 reinstall), I assume you loaded up all the ASUS specific drivers, not just the NVidia driver?

    If not, go to Asus's site and get all the drivers, not just the video one.

    On Asus's site then also is a note about Intel Rapid Store Technology and the NVidia drivers. Go here and select Win 64bit.

    ASUSTeK Computer Inc. -Support- Drivers and Download A46CM
      My System SpecsSystem Spec

  6. #6


    Posts : 53
    7 x64


    I really dont think that downloading specific driver version from asus instead of downloading that version from anywhere else would solve the problem, asus and other companies DO NOT write drivers themselves.
    1) Maybe your laptop is overheating, you should clear all the dust from inside and apply a new thermal paste to cpu.
    2) There might be some serious problems with switching gpu, and because it fails to switch, games runs on intel graphics instead of nvidia geforce, and then you have low performance in games. You should investigate in that.
      My System SpecsSystem Spec

  7. #7


    Posts : 154
    Windows 8.1 Professional 64-bit


    Quote Originally Posted by 149guy View Post
    I already did a clean install of my original OS Windows 7 and my original NVIDIA driver that came with my computer when I got it (I downloaded the driver from the ASUS drivers site), and it's still slow.

    Benchmarking was done when my laptop was not running other programs except the game and Fraps

    Do you think my NVIDIA card is burnt or something? (Sorry I'm a beginner-moderate when it comes to this texh) Because I play games quite regularly before
    If your card was damaged then the performance would be the least of your problems. Try doing what basher has suggested. Laptops tend to suffer form heat problems, especially if they're clogged with dust.
      My System SpecsSystem Spec

  8. #8


    Posts : 216
    Windows 8.1 Pro with Media Center


    The main point I was trying to make is if he reinstalled all the other drivers for the system. Even though the symptom may appear to be a video problem, it could be something to do with the hard drive controllers, the system chipset, etc.

    Yes, he should get the video driver from Nvidia, but it's sometimes best to start with the one on the manufactuer's site (if they have it) and upgrade after testing.

    Also, you can run into problem with the latest release of the video driver. I just download the latest NVidia driver and it was missing the CUDA codec. I had to roll back to the 337 release.
      My System SpecsSystem Spec

  9. #9


    Posts : 1
    Windows 8.1 Pro x64


    The best way to know and sort out your hardware is give it a good clean, with compressed air, this might sound silly but ive done this, take it apart eg memory, hdd, gpu, soundcards etc and give it a good clean.

    Ive used compressed air and the hoover nozel on all my stuff to keep it tip top condition, remember to get rid of all dust, as dust causes heat which causes drop in performance.

    Once everything is assembled, start again, wipe the hdd and reinstall the os. then do all windows updates, then drivers, then install security apps included all fully updated.

    Ok if your playing offline then really you should disable network card, uneeded programs running in the background eg security, spyware and malware apps... see what frame rate you get...

    Really you should upgrade your memory to 8gb ram, it helps the overall performance of games, and sometimes security software can interfere with your performance.

    Let us know how you get on...
      My System SpecsSystem Spec

PC lags after gaming for 2 years
Related Threads
Wierd lags and CPU overloads. in Performance & Maintenance
So as the topic states I've started to have wierd lags. I think it started only during things loading, such as starting a program or opening an internet brower. Now it's so bad I can't watch a movie since 1/3 of the sound is either going robotic stuttering or gone all together however the video is...
Solved BSOD on every start, LAGS in General. in BSOD Crashes and Debugging
Hi, You guys have always been of great assistance in the past, especially when I had a major problem. Now I have two. When I start up my computer, go into windows, it takes a while to load then I get bsod and it restarts then works perfect, so now if I run it cold, I reset it immediately...
Hi, You guys have always been of great assistance in the past, especially when I had a major problem. Now I have two. When I start up my computer, go into windows, it takes a while to load then I get bsod and it restarts then works perfect, so now if I run it cold, I reset it immediately...
Well I guess this is where this issue should be posted. Sorry if this is a sore subject but I've done all my searching, and they all come up with the solution of "update your drivers man." All my drivers are up to date. So anyways, while playing movies (which are stored on a Maxtor 250gb HD), I...
Windows 8 lags at login in Performance & Maintenance
hi; so when i login to windows it lags for about a minute and then starts working normally; i don't know when exactly this happened, i mean after installing what app; but the lag time is increasing day by day; ! help; ?
PC lags for a few seconds every 4-5 minutes in Performance & Maintenance
I brougth this PC on Christmas, and it is as Asus K55VJ I detected this problem on the past Thursday, 29/2. The problem is the following: every 4-5 minutes the PC the mouse movement lags and the image and sound lags too, well the PC lags. The lags only last for 1-2 seconds, and donīt know...
Internet Explorer lags/freezes in Browsers & Mail
Hello, I am having troubles with IE even from clean install. IE freezes a lot or crashes for example on Facebook, or at battlelog.battlefield.com . It's almost unusable... I have tried reinstall whole OS, but didn't help. Any ideas ? I don't want to use anything else, I just want this one fixed.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook