Windows 8 and 8.1 Forums


S.T.A.L.K.E.R SoC Windows 8.1 problem launching

  1. #1


    Posts : 11
    windows 8.1

    S.T.A.L.K.E.R SoC Windows 8.1 problem launching


    I can't get S.T.A.L.K.E.R Shadow of Chernobyl to work on windows 8.1 64-bit. When I installed the game (6 days ago) it worked fine. It worked without any issues for several days. Then today when I boot my machine and try to start the game, it doesn't start end show a dialogue box that says:

    "The application is not compatible with the installed operation system. Please upgrade to Windows 98SE, Windows 2000 or better."

    I have attached a screenshot.

    1) Why does the game suddenly stop working?
    2) How do I make the game work again?

    I don't understand why it doesn't work anymore. It worked when I installed it. It worked after a reboot, and after then next reboot. Not it doesn't work. The only thing I have done since I last played the game on windows 8.1 64 bit, was to install new nvidia drivers 337.88 for my graphic card (uninstall old ones, reboot, install new ones, reboot).

    Click image for larger version
    Last edited by tiresmall; 27 May 2014 at 21:34.

      My System SpecsSystem Spec

  2. #2


    Posts : 11
    windows 8.1


    Here is a list of what I tried (in order) to try to solve the issue:

    --
    1) Reboot and try to restart S.T.A.L.K.E.R Shadow of Chernobyl (SoC).
    2) Change compatibility settings for the program (tried all available (with/without admin) + reboot + restart SoC).
    3) Tried to close down other programs etc.
    4) Search the web like an idiot, where no one seemed to have my exact problem, and no solutions to similar problems seemed to solve my issue (note: I never tried to reinstall anything).
    --

    None of it worked. The only thing I had done since SoC last worked was reinstall graphic drivers + assign a keyboard shortcut to start my browser. So I continued with a more drastic approach:

    --
    5) Restore a system partition backup that was 5 days old (from before I installed the new nvidia drivers).
    6) Check that SoC starts and work. It did.
    7) Disable automatic windows updates, uninstall all nvidia stuff and reboot.
    8) Check that SoC starts and work. It did.
    9) Install new nvidia drivers (but this time make sure nvidia does not automatically install any updates or game profiles - I didn't do this before).
    10) Check that SoC starts and work. It did.
    11) Recreate my keyboard shortcut to my browser.
    12) Check that SoC starts and work. It did.
    13) Enable automatic windows updates.
    --

    SoC still works several reboots later.

    ==> I am not sure why SoC wasn't able to start, as described in my first post. I think it may have been caused by nvidia being set to 'Automatically apply optimal settings updates'. If anyone is in contact with nivida, will you pls inform them that this may be an issue with SoC + Windows 8. <==

    If anyone has information about what caused the issue, then pls reply.
      My System SpecsSystem Spec

  3. #3


    USA
    Posts : 689
    Windows 8.1 Pro with Media Center

    According to MS, the game is compatible with 8.1...


    Not sure why your copy stopped working because according to Microsoft's compatibility Center the game is compatible with 8.1 - Windows 8.1 compatibility for STALKER: Shadow of Chernobyl version 1

    Out of curiosity I installed my retail copy on my 8.1 machine (click my system specs), patched it, and other than ramping up my GPU fan, the game is running without issue (for what little I checked).

    Anyway do you have the latest patch (1.05)? - Patches - S.T.A.L.K.E.R.

    BTW where did you get you game from? Perhaps something got corrupted and the games needs to be reinstalled.
      My System SpecsSystem Spec

  4. #4


    Posts : 11
    windows 8.1

    The game stopped working again (same symptoms)


    The problem described in the first post is back. It turns out, that approximately 2 days after you install the game, it stops working, with the symptom described in the first post.

    I haven't made ANY changes to windows or S.T.A.L.K.E.R since my last post (except for a couple of save game files - but the game worked the day after I created the save game files).

    Does anyone know what is going on here and how to fix it ?

    sygnus21 wrote:
    >according to Microsoft's compatibility Center the game is compatible with 8.1.

    Microsoft says a lot of shit. The game IS compatible with windows 8.1 ... for 2 days. On my freshly installed windows 8.1. Every time I made any changes to windows 8.1 (or the applications/drivers), I rebooted several times, and verified that the game still worked (start game, load safe, play a while, create a safe file, reboot, etc). The game runs better (for the 2 days it works) than under any other windows I've tested on. But then it stops working, with most cryptic error message.

    sygnus21 wrote:
    >I installed my retail copy on my 8.1 machine (click my system specs), patched it,
    >and other than ramping up my GPU fan, the game is running without issue

    Yep, it runs fine ... for 2 days.

    sygnus21 wrote:
    >Anyway do you have the latest patch (1.05)? - Patches - S.T.A.L.K.E.R.

    Of course!!

    sygnus21 wrote:
    >where did you get you game from? Perhaps something got corrupted and the games
    >needs to be reinstalled.

    It's obvious that something goes wrong ... after it has worked perfectly for 2 days. The game works fine all the time on my windows 98SE, windows xp (32 bit) and windows 7 (32 bit), although the game crashes a lot more often while playing on the older operating systems with different graphic cards/drivers. On windows 8.1 the game seems to never crash (with my hardware/drivers/os) but it becomes 'incompatible' after 2 days

    Does anyone know why or have a solution to the problem ?
      My System SpecsSystem Spec

  5. #5


    USA
    Posts : 689
    Windows 8.1 Pro with Media Center


    Just tried the game again (two days later) and it's still running without issue. Again, perhaps your game is corrupt? I note you quoted me on everything but my question as to where the game came from?

    Just trying to help.

    BTW - Tips on Troubleshooting Game Issues - Windows 7 Help Forums
      My System SpecsSystem Spec

  6. #6


    Posts : 11
    windows 8.1


    Sygnus wrote:
    >perhaps your game is corrupt?

    I just can't use this information. It doesn't solve any problems. The disc does not seem to be corrupt. Neither the DVD nor the hard disk. The DVD and the installed game works fine on my win98SE, winXP and win7 (So the DVD seems to be in perfect health). And the harddisk of the windows 8.1 pc also seems to be in perfect health (check disk = 0 errors).

    >I note you quoted me on everything

    I do this to make it clear what I am responding to. Unambiguously. In the old days of the internet, people always did this. This enables you to see exactly what I reply to.

    I tested some more. The game first checks to see if it can run on the OS; then it checks to see if the DVD is inserted. Then it starts the game. Sometimes the game will start normally, and other times the game will emit the error shown in the first post. It seems that you need to reboot to change the behavior.

    If you reboot, the game usually starts. Sometimes it emits the same warning. Because the game is copy protected, it's not legally possible to debug the binary, without circumventing the copy protection (I tried to debug it with windbg).

    What seems strange, is that the error is not consistent. Either the game should NEVER start or it should ALWAYS start. It shouldn't toggle between these two modes at random.

    I am convinced, it's a bug in the Windows 8.1 operating system. There are similar problems with windows 8.1 and fx firefox which you can find if you search the web. It seems the problems with firefox occurs, if you start firefox from metro. If you don't start firefox via the metro gui, firefox shuts down fine, when you close it. If you start firefox via the metro gui, firefox _may_ hang when you close it. I may be wrong, oc.

    I will try to get my windows 8.1 to work, but this is the last MS software I will ever buy. From now on, any new installations will be Linux or Unix. It's free, the support is better, and you have access to the source code, so you can fix the bugs yourself. Buying Windows 8.1 makes me feel like I got hustled.
      My System SpecsSystem Spec

  7. #7


    USA
    Posts : 689
    Windows 8.1 Pro with Media Center


    Well, I don't have anything else to add.

    Good luck.
      My System SpecsSystem Spec

S.T.A.L.K.E.R SoC Windows 8.1 problem launching
Related Threads
I recently bought a new laptop computer with windows 8.1, the first couple days it worked just fine. Then, after a software update upon shutdown; the next time I turned it on the live tiles and apps stopped launching (such as windows live mail, built-in webcam, settings, calendar, skype, skydrive,...
I have had my windows 8 laptop since January and have had absolutely no problems with it until now. i recently just took my laptop away on a holiday with me for a couple of weeks where i did not have any internet connection. The laptop was working fine and had no issues with playing a few games or...
Windows 8 nothing is launching? in Software and Apps
So recently on my Windows 8 laptop i have a problem where no apps open. I have tried to open everything in the start screen but nothing opens. When i go to desktop nothing opens except for files?? This has been going on for a while and I cant seem to find a solution :cry:.
Recently upgraded to Windows 8, "as upgrade". Errors occured when trying to launch game after install. Deleted game files and completely reinstalled SC2 HOTS and coming up with same exact errors. Reinstalled Video Drivers, tried adjusting paging file. "Ran fixer for game files". Out of ideas......
I installed Bulletstorm on my Win 8 PC the other day and while it installed, it hasn't been launching for some reason. Whenever I try to launch it nothing ever comes up. I tried launching it from the Start Menu, Game Explorer, Steam, and the actual exe but nothing worked. I even tried launching...
Solved Apps not launching? in Drivers & Hardware
Hi, I've installed the 32-bit Preview of Windows 8 on my HP Slate. It installed without problems :D, replacing Win7. The problem is that apps don't launch in Metro mode. The only app that launches is the Control Panel. All other tiles bounce when I tap them but nothing else happens. I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook