Windows 8 and 8.1 Forums

Cannot install games - need administrator privileges

  1. #1

    Posts : 38
    Windows 7 Ultimate X64

    Cannot install games - need administrator privileges

    I thought I had finally gotten my sons computer going. Except for a number of everyday applications that require authorization to open everytime, like Winrar.

    But no so. My son has a significant investment in games.

    1. One game, Sim City 4, wont install because it says "You need administrator privileges to install this game". There is no way to run as administrator from the retail CD. So we copied the files to HD, and tried to install from there, at least we could run setup.exe as administrator, but the game would not run. Complained of missing files (X_INPUT).

    2. We backed up many of his Game CDs to our file server some time ago. This way, when we have to reinstall stuff, it's much faster from the server, than from the DVD drive. We found that in every instance, trying to open the .ISO or .RAR archives resulted in an error, where on windows 7 there was no problem. The error message is simply that the file could not be opened, yet they are fine.

    3. We tried to install Star Craft 2, but it does nothing. Running it from the retail CD did nothing. Copying the files to the HD and then running setup as administrator did nothing.

    you get the picture.. As we go through installing his games, we find so many that require elevatred rights or just wont install. Borderlands 2 which he just bought, managed to get running but it comes up with errors at the start, then crashes when you try to exit. But it works fine on Windows 7.

    I turned off UAC, and turned off approval mode, but this did not solve any of the problems. All it did was disable metro apps, which he wants to be able to run.

    Installed the games using the built in administrator accounts, but when attempting to run then from his account, they either do nothing, or just crash, such as with KOTOR.

    I'm going to try creating a WIndows 7 VM on his Windows 8 computer as a short term solution, as dumb as that is! I have a few spare Windows licences. But I'd prefer to resolve the issues if possible.

    All the research I've done says "live with it". You can't disable UAC, you can't get rid of the incessant and frequent nags, permission errors or lack of elevated privileges. I've been using computers since 1982, and never have I had so much problems getting anything done.

    Any help would be greatly appreciated.

      My System SpecsSystem Spec

  2. #2

    Lynnwood, WA
    Posts : 173
    Windows 8, Windows 7

    I suggest you change his account to an Admin-level one, install the games, then revert it back. I couldn't quite tell if you had tried that, already.
      My System SpecsSystem Spec

  3. #3

    Posts : 38
    Windows 7 Ultimate X64

    oops.. My bad, his account is an administrator account.

    He is an experienced (power) computer user so he's used to being able to do what he wants.. Struggles a bit with the Windows 8 philosophy of "We'll (M$) decide what we want to let you install on your computer, not you!"
      My System SpecsSystem Spec

  4. #4

    Strathpine, Queensland
    Posts : 179
    Windows 8 Pro 64 Bit

    Quote Originally Posted by TanyaC View Post
    oops.. My bad, his account is an administrator account.

    He is an experienced (power) computer user so he's used to being able to do what he wants.. Struggles a bit with the Windows 8 philosophy of "We'll (M$) decide what we want to let you install on your computer, not you!"
    Alright, here's my suggestion:

    With the .ISO files you have, use Daemon Tools (Lite or Pro) to "mount" them, it will more so add a "virtual DVD drive" to the computer, and mount the .ISO as a virtual DVD/CD, so you can use any available autorun/setup. This way, Windows reads it as a legitimate disc. (To mount the .ISO after you've installed Daemon Tools, just double click it. Notice the new icon for .ISO files)

    Anither way is to try ripping the games that aren't installing off discs (use IMGBURN or similar to get the .ISO) then again, mount in Daemon Tools and install.

    Note that; all the above require administrator rights, and may do so whilst playing as well.

    Daemon Tools Lite and IMGBurn

    (Sorry, normal HTML word hyper linking that I use didn't work)
      My System SpecsSystem Spec

  5. #5

    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    Hi there
    if there is an .EXE, .MSI or other install type file on the install media try RIGHT mouse clicking on that and then chose "Run as administrator". That often works when a user even defined as an admin account doesn't work.

    Another issue might be that the target directories for the game might be "Owned" by the system --try changing a few of the file / directory permissions.

      My System SpecsSystem Spec

  6. #6

    Posts : 85
    Windows 10 64-bit/ Windows 8.1 64-bit

    I'm not far in KOTOR, just on the Endar Spire but I can run the game so far. That being said, I've installed a few games on my computer without any problems. Try running KOTOR in administrator mode with XP SP3 compatibility enabled. I haven't had to do that yet but maybe it'll help you.
      My System SpecsSystem Spec

Cannot install games - need administrator privileges
Related Threads
I just bought this laptop last week. It came with Windows 8. When I go to the store to update to Windows 8.1, it tells me "You need to use an account with Administrator privileges to install Windows 8.1, try logging in with the user account of an administrator of this PC and trying the update...
I run BOINC, to give my spare processor time to science. I recently (after 8.1 released) decided to complete migration from Windows 7 Ultimate to Windows 8, basic edition, because Pro didn't really offer any functions I needed, that I didn't yet have. Or so I thought. I installed BOINC. Set it...
How to change Administrator privileges for user ? in User Accounts and Family Safety
Hai I am install windows 8 ,and my account is Administrator privileges ,if i see in control panel in User Accounts my account as Local Account Administrator Password Protected,but i cant run application as administrator,every time i need to click Run as administrator, and also i cant create...
I don't have administrator privileges in Performance & Maintenance
I'm the administrator of my pc for example if i want to access device manager an error pops that i don't have permission to access it . I can't turn off windows defender and whenever i click on change UAC settings the screen flash and nothing happens . Please help
I have a new KS810-P Keyscan Keyboard Scanner and it says I need to run the software as Administrator. How do I install that software in Windows 8? Please be specific, I find that most Computer people always assume too much.
Solved Lost administrator privileges in User Accounts and Family Safety
I was frustrated that Windows 8 required me to input my password every time, but after searching online, I found out a way to automatically sign in whenever I start up my computer. Later on, I decided to change my Microsoft account to a local account (can't remember why), and then I changed back....
Administrator account with no privileges in User Accounts and Family Safety
This is bugging the life out of me, as I want to get stuff done. Both me and my friend are running local accounts, and none of us has rights to access temp files. Installation files are bugging, telling me that the "data is corrupt" or "can't find the files". What procedures do I need to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook