Windows 8 and 8.1 Forums


Anyone help with Richo SD Card Driver on a Sony VAIO

  1. #1


    Nottingham UK
    Posts : 4
    Windows 8 Pro

    Anyone help with Richo SD Card Driver on a Sony VAIO


    I've installed windows 8 pro on a Sony VAIOVPCEB3E1E/PI

    Managed to sort everything out apart from the SD Card reader. Device manager recognises the card reader as :

    Ricoh PCIe Memory Stick Host Controller

    Then when I plug in the SD card I usually use as readyboost, I get an audible ding that it's noticed something there, and it also installs to device manager something called :

    SD Storage Class Controller

    This however has a yellow exclamation mark, and nothing I do or any driver from the Sony website will fix it.

    Pre Windows8 Pro , I had the consumer preview installed, that worked fine and I could use the readyboost.

    Anyone got any idea's?

      My System SpecsSystem Spec

  2. #2


    Posts : 73
    7, 8 whatever


    From my experience helping others with this driver, just download the latest and greatest from any distributor. For example, ASUS, ACER, HP etc...

    Install and done. Check Device Manager dates to see that the install worked.
      My System SpecsSystem Spec

  3. #3


    Nottingham UK
    Posts : 4
    Windows 8 Pro


    I've tried the one from Sony's website, no joy. I've even looked at Richo's website, but it's next to impossible to find a driver on there with the information I have.
      My System SpecsSystem Spec

  4. #4


    Posts : 73
    7, 8 whatever


    Yeah man. Google it and find latest from anywhere else. Latest = best, no matter source. All hardware ids are included...at least I've never been stumped before.

    Let me know how it goes and I'll make it happen for ya if help still needed after. In the off chance this advice isn't helping, tell me the error code still shown in the Device Manager, after a reboot.

    Good to update motherboard bios to latest for good measure, too.
      My System SpecsSystem Spec

  5. #5


    Nottingham UK
    Posts : 4
    Windows 8 Pro


    Nothing doing still. Tried uninstalling the ricoh device too. Wondered if maybe the Sony driver I used had messed up somehow, then ran one of the latest Ricoh driver packs from HP, and Sony. Still nothing

    Left with an unidentified Base system device (I know this to be the ricoh)
    and the SD Storage Class Controller is still present with its yellow exclamation mark (this is the actual SD card), it disappears and reappears in device manager every time I plug in or unplug the SD card. The error message presented from device manager on this one is :

    This device cannot start. (Code 10)
    {Operation Failed}
    The requested operation was unsuccessful.
      My System SpecsSystem Spec

  6. #6


    Posts : 73
    7, 8 whatever


    Interesting.

    Are you dual booting with any Linux variant? If so, therein lies the cause.

    If not, I would boot into safe mode, delete the Ricoh from the device manager while checking the box to also delete the driver.

    BUT

    Before doing so while in safe mode, find out the .inf for it by checking the Details tab and also delete that manually. Check C:\Windows\System32\drivers and then also manually delete the .sys file(s) for it.

    Reboot and see if it works. If not, try installing latest driver now again.

    Good luck. Also, make sure that bios is updated to latest as per above. Disable all unnecessary items in it such as serial/parallel ports, or floppy never in use etc...

    Try a different card in the reader if necessary.
      My System SpecsSystem Spec

  7. #7


    Nottingham UK
    Posts : 4
    Windows 8 Pro


    No dual boot at all, just windows 8 pro.

    I've got the Base driver working, with Sony's driver, so I know that's ok now. But the problem persists with the SD Host Controller. This only appears when I insert a card. Tried deleting the inf file, its still the same. Driving me nuts now.
      My System SpecsSystem Spec

  8. #8


    Posts : 2
    Windows 8 pro


    Hi Im having same problem - how did you ever manage to get the sony driver to load -Ive been trying and its driving me nuts - if I run the driver from sony it says succeeded but when I check in device manager it still says base system device with the exclamation mark.
      My System SpecsSystem Spec

  9. #9


    Posts : 2
    Windows 8 Pro


    Hello, I am having same and plus another two problem with drivers.

    > Yellow Mark on Base System Device
    > Yellow Mark on Unknown Device
    > ATI Mobility HD 5000 Series (WDDM-v1.2) drive, Can not install the original driver of ATI and not getting the desired graphic performance.

    I am using sony vaio vpceb390x. I have installed all the latest updates of drivers but these three isn't working in any way. I am not a computer hardware expert but did whatever I could. But no progress.

    Please help me out from this problem.
      My System SpecsSystem Spec

  10. #10


    Posts : 2
    Windows 8


    OK I have a vaio VPCEB15FM bought from someone using win 7 I did full recovery and then removed original drive and replaced with an ssd windows 8 installed etc. Same problem as above tried downloading the drivers blah blah wouldn't work. Then I remembered an old trick and put the restored win 7 drive in a caddy and simply connected caddy to the vaio and then updated the base thing and the other thing which is actually a sony parsnip or something (only found that out after) the thing installed. I updated it by simply selecting the whole of the sony drive and letting windows scan it took 3 minutes and worked, if I just let it scan the program files it didn't work so were its actually held I dunno. I will try and work it out and it may be possible to upload it as a zip file or something. But to recap its a Ricoh PCIe Memory Stick Host Controller (base unit thing) and Sony Firmware Extension Parser device is the unidentified one, dunno if this helps anyone
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Anyone help with Richo SD Card Driver on a Sony VAIO
Related Threads
BSOD Driver power state failure on Sony vaio in BSOD Crashes and Debugging
HiI am frequently getting a BSOD at sporadic intervals with 'Driver power state failure' irrespective of battery / plugged in and irrespective of what program is running. SF Diagnostic files are attached. Thanks for your help!
sony Vaio windows 8 in General Support
Hello....got a Sony Vaio windows 8....and noticed it has only C disc......so in case i qould like to format the laptop in the future,all data inserted would be eraSED,as it will format all Data C.....is there any way to open a new DATA D DISC?
Sony Vaio Pro 13 BSOD (I think) in BSOD Crashes and Debugging
Hi all, I have just recently got myself a Sony Vaio Pro 13 and I think I am having issues in regards to a BSOD. The symptoms seem to be related to power/standby but could be wrong. Yesterday, I shut the lid and went away. Got back from lunch and realised the fan was on full-speed while the...
clone HDD Sony Vaio Tap 20 in Performance & Maintenance
I have a AIO Sony Vaio Tap 20 that I really like, but I want to run off of a different HDD that is a hybrid drive (SSD + HDD) to increase the responsiveness. I have cloned the drive using Macrium's Reflect, but the drive won't boot. At power up, it says "a required device isn't connected" and I...
SONY VAIO drivers in Drivers & Hardware
Can someone help me with finding Sony Vaio VGN-FW130E drivers for windows 8? My laptop model is not supported for win8 in sony's support...
Hey, I have a Sony Vaio laptop with intel HD4000 and a radeon 7670m running Windows 8. Will using the leshcat labs drivers enable switchable graphics for me? I was also told I shouldn't install the latest drivers from ATI, just use the ones Sony releases. Is this true or is this just what Sony...
Hi all I've got a sony VAIO laptop with two slots on the front for SD/MMC cards and the sonu pro duo cards. Works perfectly on W7 but on W8 only the SD card is recognized -- I copied the drivers from W7 (at first W8 didn't recognize the card at all) but after installing only SD cards were...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook