Windows 8 and 8.1 Forums


HDD struggling to read data

  1. #1


    UK
    Posts : 41
    Windows 8.1 Update 1 64bit Pro

    HDD struggling to read data


    Ok here is the situation.

    I noticed yesterday on my WD Green drive some data was slow to read e.g. excessive time to start playing video file, and at same time was read errors logged in SMART so decided to order 2 new drives and move the data.

    Today I got the drives, swapped some cables round as one of my red's I realised was on the asmedia controller and I want all my red's on the intel controller, and installed the 2 new WD red drives.

    For reference here is the setup

    Intel controller

    Samsung 850 pro ssd - system drive
    WD Black 640 gig
    2 Existing WD red 3TB
    2 New WD red 3TB

    Asmedia controller
    WD green 2TB
    DVDRW

    Out of case temporarily due to lack of SATA ports
    Samsung 750gig

    Now today something unexpected happens, I am sorting out the data that will be going to the new redundant setup and suddenly I notice when trying to play a video stored on the hdd the hdd light is on all the time and the video isnt loading, task manager reports a constant high speed been read (in this case 140megabyte/sec). Explorer gets the not responding status, and killing it stops the i/o. I repeat and same file again same issue. I deleted the file. After checking over some other files same problem again on another file, I discovered tho after leaving it 20 minutes the video did actually start playing. Now some more weirdness, it seems I only have to highlight the file in explorer for the everlasting i/o, I dont even need to try and load the file, so selecting a bad file is enough for a constant hdd light and high hdd activity.

    So I ran a chkdsk scan, no errors.

    Now running a chkdsk forced bad sector scan /R flag and its reading most sectors quickly, but some are pausing for extremely long times, e.g. sector 1935 took over 30 minutes to read, I am watching the smart data whilst this is going on and no error counters are budging, so no reallocated sectorsm no raw read error rate, no calibration errors. Also no weird noises from the hdd. The scan has a ETA of 4 hours to finish So will be a while to see what it reports.

    So it seems I was planning to just remove a 2TB drive but a quite new 3TB is acting like its dieing. (7 months old). I may have been lucky in the past but I have never had a HDD in any of my pc's have issues before at such an age, Ironically only yesterday I had no such issues in the same directory as I was only in the same folder yesterday assessing what I would do with the data.

    As to the data I have data in one of 2 groups.

    1 - Data I can afford to lose, I just redownload it, so things like games of steam, downloaded youtube videos and other stuff which is still on the internet to download.
    2 - Data that would be annoying to lose and either hard to get back or impossible. Alot of this data is already on redundant storage. But not all of it.

    To maximise efficiency of hdd space since I am not made of money I have the 2 existing reds on a dynamic disk setup. They both have a mirrored 750gig partition for important data, and rest of space as individual partitions for data in group #1. Some #2 data is on the drive I have issues reading from now, also some is on the wd green drive, always planned to move to a mirrored partition, but up until day wasnt actioned.

    Today was also when I was going to start doing active backups as well, probably online backups. My really important data like work stuff and emails is already backed up, plus all that is also on the mirrored storage as well. Also to add save game files are also backed up I use steam save game manager for that,

    I am annoyed that it looks like I am going to have to replace at least one of the 7 month old RED's already.

    I am curious tho is there other possible causes of what I am seeing other than HDD failure, as typically on failures I associate weird noises from the drive and/or SMART failures, which neither is happening.

    One of the RED's was previously on the asmedia (dont know which tho off hand), so is it possible e.g. moving a drive that was formatted and written to on the asmedia to the intel cause it to struggle to read the data? I dont think its the sata cable as it was the same files consistently been an issue, not random and not all files either.

      My System SpecsSystem Spec

  2. #2


    UK
    Posts : 41
    Windows 8.1 Update 1 64bit Pro


    An update it appears to have not found any bad clusters in used files, but it is still scanning, now is on the stage scanning free clusters, which is a lot as the hdd was less than 50% full.

    Really odd so it would seem chkdsk and smart both failing to find issues but there is definite issues reading, after this is done I will try swapping the cable with another drive.
      My System SpecsSystem Spec

  3. #3


    Do note that chkdsk /r can take a very log time (even over 24 hours in some cases with larger drives) to complete, often appearing to be hung. And in some cases, it may appear to be stuck at one sector but in reality, the display is just not being updated. So just let it run until complete.

    You definitely should copy off any data you don't want to lose.

    Is the drive still under warranty? You might also run WD Data Lifeguard Diagnostic for Windows on the drive. If it fails WDs own diagnostics, they will not hesitate to RMA it if still under warranty.
      My System SpecsSystem Spec


HDD struggling to read data

Similar Threads
Thread Forum
Struggling to install .NET Framework 3.5
Hi there, I've tried a lot of different methods in order to install 3.5. All have failed so far. I'm really hoping that somebody in the know will be able to help me with this. First of all, I was running 3.5 fine as I could run programs that use it fine previously. This was on Windows 8.1...
Software and Apps
Grrrrr - struggling just to do the basics on my pc
Nothing personal but I hate Windows 8. I'm seriously struggling just to do the basics on my pc with it and WHY do I have no games? Where is my Mahjongg and Spider Solitaire? Why did my internet explorer icon disappear into thin air after a few days and I can't find it now?????? This is...
General Support
Optical drive often won't read DVD data disks
Both optical drives are shown as working properly in Device Manager, but 70% of the time will not read data DVD disks. That includes data disks burnt using Nero and ISO Joliet format; and either mutli-session or finalized after burning. And disks formatted like a flash drive in UDF format using...
General Support
Data CD not being read
I'm concerned that I might have disabled a utility using Task Manager's advice for saving memory. I put in a Data CD and it isn't noticed. (Audio CDs are rocognized as "Audio CD" with no ID info). I went to the Windows troubleshooting page and clicked the "fix it" link and the CD was picked up...
General Support
8 struggling technologies: Which ones will survive?
8 struggling technologies: Which ones will survive? - InfoWorld
Windows 8 News
SSL Certificates for my NAS - struggling. Help!!
Hi there, Struggling to get Certificates to work on Win8 for https login to my NAS. With https enabled on NAS I keep getting the Red https splash security page on both IE and Chrome. Followed the instructions to generate/edit the Certificate from the NAS (produces new cert timestamp of Feb...
System Security
Struggling BSOD Crashing all over Christ...mas!! :(
Hey would really Like some help, I have had loads of problems not sure what is causing the crash please help:cry::cry: If it I a driver I even tried reloading from a prevous point to try and help
BSOD Crashes and Debugging

Eight Forums Android App Eight Forums IOS App Follow us on Facebook