Windows 8 and 8.1 Forums


"No valid serial port" I'm out of ideas.

  1. #1

    "No valid serial port" I'm out of ideas.


    Computer-HP 2000 Notebook PC
    0S-Windows 8.1

    Alright guys here's the issue. I'm trying to use Samsung diagnostic and monitoring software called SNET Pro 2 for their HVAC systems. SNET loads with 0 issues. (I have the prolific driver on my laptop as well). Every time I attempt to connect to the diagnostic tool via usb I get a message "no valid serial port" this occurs with or without anything in any of the USB's. I contacted Microsoft help and told them I updated all of my drivers etc and they were of no help, they told me they had seen this a few times before and they referred those people directly to HP for help. I went to HP online to search for available drivers and/or updates there were none. I then contacted HP by phone and got a whole deal about paying money for them to guess at it and wasn't happy with the level of confidence they had. Any help would be greatly appreciated. In a bit of a hurry at the moment if I sound like an idiot or left something out don't hesitate to tell me. Thanks.

      My System SpecsSystem Spec

  2. #2


    Welcome to the forum. Does this actually use a few port if so have you actually got one or is it setup wrong and looking for a com port instead of USB?
      My System SpecsSystem Spec

  3. #3


    Are you using the latest version of this software? As seen here, that is V1.4.5. I see there is a 7/13/2016 USB to Serial Prolific Driver available there too.
      My System SpecsSystem Spec


"No valid serial port" I'm out of ideas.

Similar Threads
Thread Forum
"Ethernet" doesn't have a valid IP config, only 1 computer
While this, or similar, issue seems to have happened elsewhere, if the various threads are any indication, however none of the solutions have worked with my issue. Computer was working fine on Thursday. Appears to have been an update/restart overnight. Now there is no internet connection on a...
Network & Sharing
"Ethernet doesn't have a valid IP configuration"solutions?
Hi guys. So when I turned on my desktop today, I got the limited network sign. I am using Powerline, so it showed as Ethernet, just as usual. I had the powerline adaptors unplugged, since I moved my PC to another room for a day, and then back again in the old place where it used to work perfectly....
Network & Sharing
Error with windows reset "The media inserted is not valid"
So my computer started blue screening on start-up. I tried using system restore while bootingóboth points I had were corrupted. I did chkdsk /r and I have to restart to start it. I restart, and the thing freezes on 20% for 2-3 hours, and my computer restarts. Not sure if it's a crash or something...
General Support
"Ethernet" doesnt have a valid IP / gateway not available
Hello, Recently I have been intermittently getting disconnected from the internet while gaming / streaming. If I ran the troubleshooter, the error that I got was "Default gateway not available". Resetting my router/modem and restarting the PC every time it happened seemed to resolve this for a...
Network & Sharing
""Ethernet" does not have a valid IP config" help
So I've been using this router, Belkin N+ wireless router F5D8235-4 v2, for a while now and It hasn't had problems most of the time and I've been using it fine with my DSL modem. My mother connects with her Nook tablet, my father with his laptop, and sometimes my phone and no problems. Until the...
Network & Sharing
Wifi Problems "doesn't have a valid IP configuration"
Hi all, I recently got windows 8 and have found it to be rather volatile. I use WiFi in my house on my desktop Intel PC and my computer strangely sometimes works to get to the internet and sometimes it doesn't coming up with connection limited and after troubleshooting it "doesn't have a valid ip...
Network & Sharing
"Ethernet" doesn't have a valid IP configuration
Hi, I'm using an ethernet cord to connect to my internet and it has been working well until Thursday morning when I turned on my laptop (Windows 8) to see a yellow triangle sign in the bottom right hand corner, in front of the ethernet connected symbol. Since then I haven't been able been able...
Network & Sharing

Eight Forums Android App Eight Forums IOS App Follow us on Facebook