Windows 8 and 8.1 Forums

I removed a printer, and now I can't re-add it

  1. #1

    Posts : 1
    Windows 8.1

    I removed a printer, and now I can't re-add it

    I've been having trouble with my printer being "offline" a lot and I thought that removing the printer and then connecting to it again would solve that. But, now that I've removed it (via the PC settings) I can't find a way to add it again. When I've tried to connect to a printer via the PC settings, the printer I want (which is a Canon model) does not show up on the list. I've also tried adding the printer locally, but it doesn't show up. I don't know the IP or the port or any sort of thing that can help me manually search for the printer. Please help I haven't been able to find any information on this problem.

      My System SpecsSystem Spec

  2. #2

    If Windows does not have your printer model already in its tables, you generally install the driver (downloaded from Canon) first, then you attach the printer (if connecting directly to the PC) then you add the printer in Control Panel. If the printer is networked, you should be able determine the IP address by printing a test or status page using the printer's front panel menu system, or you can look in your router's admin menu for "connected devices" to see the assigned IP address.
      My System SpecsSystem Spec

I removed a printer, and now I can't re-add it
Related Threads
Hi there everyone! Windows 8 machine sharing printer with 8 and 7 machine. Under Advanced sharing settins, I've enabled Network sharing in private, public/guest and all networks and disabled password protected sharing. Under printer properties, I have selected to share the printer under the...
Hello, I have an Epson color 580 printer from like 15 years ago. Worked great with XP. When I tried to print with W8.1, it directed me to save the file as an .xps or something. I couldn't get the .xps to print. I did some reasearch and people said to disable the windows .xps viewer or...
Apps removed in Software and Apps
Just thought I would mention this. I uninstalled all the Microsoft Apps. I freed-up 4.5 GBs by doing so. I never used them anyway. I ran sfc /scannow & DISM afterwards & sfc again after rebooting.
Just removed windows 8 in General Support
After running windows 8 RP sice it's released, I had to dump it. Not sure what went wrong, tried moving files to an external drive just to discover only 3 out of 25 were moved, the rest are gone. Tried to move files between internal drive, same thing, so disappear, only a couple actually moved....
Hi there (note Pos in title of post means Possible -- not the other meaning often shortend to pos !!). Not being able to share printers easily WILL be a drawback. I've run into what I hope is MY error but I can't see any way around this Computer is running W8 Development Preview X-64 ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook