Windows 8 and 8.1 Forums


Samsung 850 evo or Any modern SSD's on LGA775 ICH7 board

  1. #1


    Posts : 1
    Windows 8.1

    Samsung 850 evo or Any modern SSD's on LGA775 ICH7 board


    Hello guys i kust wanna ask who those who knows someone or who owns a ICH7 board with any modern SSD i know that Trim works on IDE mode! But i wanna know does the SSD's lifespan degrade when on older board with no AHCI support? I read somewhere that they had a BSOD and Computer freezes on about 30 seconds. Please help me i wanna know before i buy it.

      My System SpecsSystem Spec

  2. #2


    TRIM works the same way. The key thing here is "modern" SSDs. Modern SSDs do not suffer from the limitations of first generation SSDs. They still have limits, but the numbers are so high, only very busy data centers need to worry about them.
      My System SpecsSystem Spec

Samsung 850 evo or Any modern SSD's on LGA775 ICH7 board
Related Threads
CLONE FAIL FAIL FAIL So I have a Haswell i7 rig (GTX 780) with Platinum PSU etc etc... W8.1 Pro (and a few other W8.1 PC`s I tried the clone op with also)........ .... and on the SSD to clone in question, it is a Samsung EVO 250Gb SSD. It seems to work perfect. But its getting near...
Solved BSOD being caused by on-board NIC? in BSOD Crashes and Debugging
I need a little help and hope someone here can lend a hand. I'm having very regular BSOD on my system, which appear to be due to the ethernet card on the motherboard. I think this because at the same time the BSOD occurs, , there is a event log entry from e1dexpress saying a network link has...
So i had my pc tech stick my mini ITX board into a new case and all is working good, but i notes he turned off a setting in the bios he told bios to not halt on errors, i went and turned it on and i see the reason he did is due to the power sensor not being there anymore, as it had a power board in...
Board's Icon in Site Stuff
I don't know if anyone even cares about this, but it makes me chuckle to see the Internet Explorer 8 icon on a Windows 8 forum. I'm sure it was just migrated from SevenForums, but anyone wanna volunteer to put an IE 9 or 10 logo in place of the old one on this board? The mail one is still up to...
OK, so I had a similar issue with sound in Windows 8 that has been described multiple times in this forum. 1. The sound was crackling and buzzing so I installed Realtek audio drivers, as suggested in this forum, and it started working; albeit temporarily. 2. The sound will now work fine...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook