Windows 8 and 8.1 Forums

USB mouse not working, giving Code 43 in device manager

  1. #1

    Posts : 1
    Windows 8.1

    USB ports, giving Code 43 in device manager

    Hello All,

    I am running Windows 8.1 on a laptop and almost always use a USB mouse. The aforementioned mouse has never had any problems before, and was working perfectly yesterday. Today, however, I plugged in the mouse and was told that: "The last usb device you connected to this computer malfunctioned", and the mouse was not working, however it did light up as it does when plugged into something. I restarted the computer and tried again, but to no avail. In device manager, where the mouse is usually shown, it simply said "Unknown USB device (Device Descriptor request failed)". I updated the drivers of both the USB port the mouse was plugged into and also attempted to update the drivers of the device, but both times it was said to be "up to date". When plugged into another laptop, the mouse worked fine, and when I plugged a pen drive into the port, it also worked fine. All 4 of my ports work fine with a pen drive, but I recieve this error whichever port I plug the mouse into. I have trawled multiple forums to try and find a solution, but none have worked.


    I found a suggestion on the MS help forums which suggested to uninstall every single USB device listed in device manger. I am now no longer getting the issue mentioned above. Instead NONE of my USB ports work with ANYTHING, the mouse included, but also my hard drives and pen drives. The mouse still works fine in othe computers. In device manager, all the usual devices are showing up along with 3 that read:

    Unknown USB device (Port reset failed)

    Please help
    [UPDATE 2]

    Gaaaah, time is slipping by me and I still have no mouse. Something good has happened this time though, which is that after enabling USB debug mode in the BIOS I now have one port working. STILL HAVING THE SAME ERROR AS BEFORE THE TOTAL BREAKAGE THOUGH, my mouse still is not working.

    [UPDATE 3]

    It has been a week and I am still mouseless, USB 3-less and having to operate out of one port. I have read somewhere that resetting the BIOS will fix this issue, so I am going to call a technician round to reset it. Will update shortly
    Last edited by arcayn; 29 Jul 2016 at 02:32.

      My System SpecsSystem Spec

USB mouse not working, giving Code 43 in device manager
Related Threads
Hello, I am new to Windows 8 and have recently purchased an Asus N550JK. The touch screen worked for the first day and then stopped. After that, I even reset the laptop to original out of box condition and it didn't work. A few days later, after trying everything I could find, it actually...
If you have ever wanted to change that boring "HID-compliant Mouse" title to something more descriptive, this tutorial is for you. The name of any device can be modified with this method and can help you organize your devices better in Device Manager. First, open Device Manager by opening a run...
Hey :) I ve had a problem with the internet so I decided (foolish decision) to remove the network adapter s driver (Realtek PCIe GBE Family Controller). After I removed and connected the wire to the pc it shows the adapter in the device manager net adapters list, yet there is a yellow exclamation...
I recently bought a used Sapphire HD7970 GHZ Edition 3GB, which I got quite cheaply but it did need a little work doing to it. Firstly the fan cable had, in the hands of the original user, somehow snapped and they had repaired it to run on a normal motherboard 4 pin fan lead. When I got the card...
Hello Everyone! , My touchpad is not working and it's driving me crazy. I tried installing ELAN Driver from Acer Driver section and it didn't work. So I downloaded Synaptics driver, still no change! . I just realised that the PS/2 compatible disk is not working and it shows error (Picture ...
Solved Device Manager Error Code 19 in Drivers & Hardware
I just noticed that the DVD drive of my Sony laptop (Win 8.1x64) has a yellow exclamation mark in device manager with the following error message: "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)" I tried...
Hello, I have an M-Audio midi-uno and it isn't popping up anywhere in windows 8; it plugs in via usb 2.0. When I plug it in a light on the device turns on and slowly flashes on/off. When I plug it into my piano and play notes the indicator lights that show key presses flash on/off Yet when I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook