I got a powered USB hub and hooked it up to a USB3.0 port on my laptop. Windows 8.0 core says it "did not recognize the device" in ther words it wont work. Device manager displays 1 unknown device instance outside the USB-controllers parent branch. I tried the following;

-Under device manager, uninstall all USB drivers one by one then reboot and, connect the device again.... Same
-Tried the other USB-port on my laptop.... Same.
-used the automatic conflict detect feature, it just says it detected 1 device is not detected, then nothing... Same
It says thhe following: error usb\vid_0000&pid_0002\5&2f4793fc&0&1

Then I found this:

Got the fix in the artcile by e-mail from Microsoft but not sure if I should use it and... if you would read the registry modifications n the discription, I got a bit lost there.

My final question, if I should download the Rollup pckage from Microsoft which has more fixes for Win8.0. incluing this one, should this rollup also automatically change my registry to the correct settings needed for this fix?