Windows 8 and 8.1 Forums


USB 3.0 connection randomly stops working

  1. #1

    USB 3.0 connection randomly stops working


    I have a 1/2-Tb drive using a USB 3.0 connection to my computer. Over the last three or four months, the connection will stop working in more-or-less random times. I can turn off the power to the drive, wait for about a minute, turn power back on and restart the computer, and that will get the connection back. I'm worried about this "fix" not working one of these times and me losing the use of the drive. Anyone have a clue on how to fix?

      My System SpecsSystem Spec

  2. #2


    Posts : 511
    Windows 10 Pro 64 bit


    I don't know what kind of drive you have, but I had the same problem with a WD external USB 3. I called WD and they said to go in Services and change Computer Browser and UPnP Device Host to automatic instead of manual. That fixed mine.
      My System SpecsSystem Spec

  3. #3


    I'm afraid I'm going to sound like a real dunce, but how do I "go in services?" I'm sure I've probably done it before, but I don't use the computer a whole lot anymore. I spent what seems to me to be a long time working on computers in one form or another (mostly writing business applications and building my own home computers) for close to 30 years, and now there's not a whole lot of enthusiasm left for them.
      My System SpecsSystem Spec

  4. #4


    Posts : 511
    Windows 10 Pro 64 bit


    Quote Originally Posted by txakura View Post
    I'm afraid I'm going to sound like a real dunce, but how do I "go in services?" I'm sure I've probably done it before, but I don't use the computer a whole lot anymore. I spent what seems to me to be a long time working on computers in one form or another (mostly writing business applications and building my own home computers) for close to 30 years, and now there's not a whole lot of enthusiasm left for them.
    On the desktop Click on Control Panel. Then AdministrativeTools >Component Services >Serveries(Local) >Double click on Computer Browser >In Start up Type >ChooseAutomatic >Check apply then OK. Then restart computer. Do the same thing for UPnP Device Host. Hope this helps.
    Click image for larger version
    Click image for larger version
      My System SpecsSystem Spec

  5. #5


    Thanks, that was pretty easy. One thing... when I reached the point where I could do something with "Start Up Type", I could only choose what was available in the drop-down list (I chose "Automatic") - for both Browser and UPnP. I hope I went to the right place.

    I figure I should wait about a week to be sure if the fix takes. I'll be sure to let you know - and mark this solved.
      My System SpecsSystem Spec

  6. #6


    Posts : 511
    Windows 10 Pro 64 bit


    Quote Originally Posted by txakura View Post
    Thanks, that was pretty easy. One thing... when I reached the point where I could do something with "Start Up Type", I could only choose what was available in the drop-down list (I chose "Automatic") - for both Browser and UPnP. I hope I went to the right place.

    I figure I should wait about a week to be sure if the fix takes. I'll be sure to let you know - and mark this solved.
    That was the correct thing to do. What kind of drive do you have?
      My System SpecsSystem Spec

  7. #7


    Wowsers! Fantastic illustrations, Clint!

    I note I see this complaint all the time - with as many solutions as complaints which may or may not work. I am really curious if this one holds. How long ago did you apply this fix, Clint? And are you connecting this USB3.0 drive to a USB3.0 port?
      My System SpecsSystem Spec

  8. #8


    Posts : 511
    Windows 10 Pro 64 bit


    Quote Originally Posted by Itaregid View Post
    Wowsers! Fantastic illustrations, Clint!

    I note I see this complaint all the time - with as many solutions as complaints which may or may not work. I am really curious if this one holds. How long ago did you apply this fix, Clint? And are you connecting this USB3.0 drive to a USB3.0 port?
    I have been using this for about a year. I do have it plugged in a USB 3 port. There are a couple of other things you can do that may fix it.
    In Device Manager> Universal Serial Bus controllers> Intel USB 3.0 eXtensible Host controller-1.0 (Microsoft)> properties>Power Management tab> uncheck Allow the computer to turn off this device to save power.
    And Universal Serial Bus controllers>USB Root Hub (xHCI)> properties>Power Management tab> uncheck Allow the computer to turn off this device to save power.
    This is a link to the same problem with a lot of good info. Help! After installing Windows 8.1, my USB drive disappears or file transfers stop unexpectedly
    If you have a Western Digatl external HD, Run the Smart Ware program that came with it and under settings. sleep timer> choose never.
    Hope this helps.
    Click image for larger version
      My System SpecsSystem Spec

  9. #9


    Yeah, I have seen those other fixes suggested and for some they work, some they don't. And for some they work for awhile then stop. So a year is very encouraging.

    TBH, I have been very discouraged with USB altogether. While getting faster and faster with each new version sure is nice, USB2.0 was also supposed to fix all the problems (including these connection issues) USB1.0 had, but didn't. Then USB3.0 was supposed to fix all the problems USB2.0 had, but didn't. People report problems all the time of lost devices and USB ports no longer working, or this USB3.0 device not really compatible with that USB2.0 port (or the other way around) and more. Maybe there are just too many cooks involved in setting up the new protocols each time. I don't know. And again, faster speeds/more bandwidth is great but at this point, I would like to see a new USB revision where everything just worked like it is supposed to. That is, a truly "universal" serial bus. What a concept, huh?
      My System SpecsSystem Spec

  10. #10


    what happened to firewire? or whatever APPLE uses was pretty darn good..

    - and their USB ports/drivers/host controllers are pretty darn fast.. faster than my windows PC usb 3.0.. and I have a $1000 laptop..

    I used to have a MacbookPro laptop that I used Bootcamp on just to use Mac Hardware with Windows ha.. now I'm back to PC but I remember having no problems or speed issues with the mac hardware running windows.. funny yah..


    oh and Clint, do you know the specifics on why "turning off power saver" is the trick? why isn't that just turned off on everything when I choose "high performance plan" in power settings or something..

    ah Microsoft..
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
USB 3.0 connection randomly stops working
Related Threads
Internet Connection stops working in Network & Sharing
Hey there guys so I bought a new Lenovo Y50 laptop and I have been having issues since I bought it, internet connection will just go away at times, however I can still use skype while browsing will not work, or sometimes nothing works at all while I'm still connected to the network. The laptop has...
This mouse randomly stops working. When I click on "Show Bluetooth Devices" with my touchpad it immediately starts working again. My laptop is always plugged in. Sometimes I can be idle for a really long time and it still works. Other times it seems to stop while using it. Sometimes...
Okay well this happened like 2-3 weeks ago, i have an extremely annoying problem.. The sound of my computer would randomly stop working for some reason.. Not only that, but when i watch youtube the video or any video it won't load and it would literally pause or freeze. To fix this i would have...
I installed my new Hyper 212 EVO cpu cooler yesterday. It was fine, 40C idle etc. 53C load. Then I started getting crashes in the middle of playing games. Basically, my PC seems to stay on.. the GPU fan is still spinning. But as soon as my monitor screen turns black, my cpu fan stops spinning...
I have WIN 8.1 installed on a Gateway DX 4822IE 10 and now IE 11 continually stop working,can find no fix on MS web site, any ideas on this????
Hi All I have a clean install of windows 8.1 and the sound was working but the sound quality was poor/bad so I did some digging around to try and fix the sound quality which didn't work by the way and now my sound randomly stops eg. watching YouTube pause then come back and no sound, restarts...
Hi there. Sorry if this is in the wrong section but didn't know where else to post it. I have an odd problem and cannot for the life of me figure it out. Last night I had a BSOD on my week old Samsung 350E7C laptop. It was a Power_Drive_State_Failure. It has since recovered but now every time I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook