Windows 8 and 8.1 Forums


All USB ports not working. Suspected USB driver issues

  1. #31


    Posts : 35
    Windows 8.1


    Quote Originally Posted by ComputerGeek View Post
    I just skimmed the thread so I'll just ask: Are you still having problems with your USB controllers as shown in your first post? I've seen those symptoms and in many cases solved the problem before. It's typically caused by either:
    > Microsoft usb controller driver is corrupt and/or
    > A 3rd party driver filter is interfering with the usb controller driver

    So before starting down that path... are you still having the problem? I yes, start by providing a Problem Device report
    List any Problem devices
    • Click the Start Orb, type msinfo32 in the search box. Hit Enter
    • Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Did as you said, and here you go.

    Intel(R) 8 Series/C220 Series USB EHCI #1 - 8C26 PCI\VEN_8086&DEV_8C26&SUBSYS_11381462&REV_05\3&11583659&1&E8 The drivers for this device are not installed.
    Intel(R) 8 Series/C220 Series USB EHCI #2 - 8C2D PCI\VEN_8086&DEV_8C2D&SUBSYS_11381462&REV_05\3&11583659&1&D0 The drivers for this device are not installed.
    Not Available USB\ROOT_HUB30\4&143A614A&2&0 The drivers for this device are not installed.

      My System SpecsSystem Spec

  2. #32


    Posts : 50
    windows 8.1


    Yep. Looks like the driver files are corrupt. First, set Windows to display know extensions (makes it easier to do the next steps)
    • Control Panel->Folder Options->View
    • Uncheck "Hide extensions for know file types"


    Tell me which of these files are (or aren't) there

    1. C:\Windows\inf\usbport.inf
    2. C:\Windows\inf\usbport.pnf
    3. C:\Windows\system32\drivers\usbehci.sys
    4. C:\Windows\system32\drivers\usbhub.sys
    5. C:\Windows\system32\drivers\usbport.sys



    /* EDIT */
    Fixed typo. File 4 should be usbhub.sys
      My System SpecsSystem Spec

  3. #33


    Posts : 35
    Windows 8.1


    1. Does not exist
    2. Does not exist
    3. Does not exist
    4. Does not exist
    5. Does not exist

    None of the files are there.
      My System SpecsSystem Spec

  4. #34


    Posts : 50
    windows 8.1


    None??? That's odd. But in any case, we'll manually restore and see if Windows will do the rest.

    1. Browse to C:\Windows\System32\DriverStore\FileRepository
    2. Now scroll down looking for folder names that start with usbport.inf. There may be more then one folder name starting usbport.inf. If so,choose the folder with the most recent time/date stamp.
    3. You'll find copies of the files in the folder

    > Copy usbport.inf to C:\Windows\inf\usbport.inf
    > Copy usbport.pnf to C:\Windows\inf\usbport.pnf


    Reboot your computer. On startup, does Windows reinstall the driver?
      My System SpecsSystem Spec

  5. #35


    Posts : 35
    Windows 8.1


    Quote Originally Posted by ComputerGeek View Post
    None??? That's odd. But in any case, we'll manually restore and see if Windows will do the rest.

    1. Browse to C:\Windows\System32\DriverStore\FileRepository
    2. Now scroll down looking for folder names that start with usbport.inf. There may be more then one folder name starting usbport.inf. If so,choose the folder with the most recent time/date stamp.
    3. You'll find copies of the files in the folder

    > Copy usbport.inf to C:\Windows\inf\usbport.inf
    > Copy usbport.pnf to C:\Windows\inf\usbport.pnf


    Reboot your computer. On startup, does Windows reinstall the driver?
    Okay trying this now. The folders name was usbport.inf_amd64_5b9f5e3f7703e95d, Are these amd drivers? Does this have any relevance to my problem?
      My System SpecsSystem Spec

  6. #36


    Posts : 35
    Windows 8.1


    Just rebooted, windows did not re-install the driver on start up. Or if it did I'm not sure how to check.

    Either way, still showing warning signs as before in device manger.
      My System SpecsSystem Spec

  7. #37


    Posts : 35
    Windows 8.1


    So I went into device manager and tried manually updating the drivers. Only 2 did. Now I'm left with three different warnings.

    No usb's working.

    Here's an updated Problem devices from msinfo32:

    Not Available USB\ROOT_HUB30\4&143A614A&2&0 The drivers for this device are not installed.
    Not Available USB\ROOT_HUB20\4&3681B103&1 The drivers for this device are not installed.
    Not Available USB\ROOT_HUB20\4&317533BD&1 The drivers for this device are not installed.
      My System SpecsSystem Spec

  8. #38


    Posts : 50
    windows 8.1


    Quote Originally Posted by mynameisinuse View Post
    Okay trying this now. The folders name was usbport.inf_amd64_5b9f5e3f7703e95d, Are these amd drivers? Does this have any relevance to my problem?
    Not a problem. That's just naming convention for x64 driver

    Let's try this next:
    Right click an "enhanced" controller->Update Driver. Browse your computer for the driver and browse to the usbport.inf_amd64_5b9f5e3f7703e95d folder
      My System SpecsSystem Spec

  9. #39


    Posts : 50
    windows 8.1


    Good work! You were a step ahead of me.

    The Root Hubs use the same driver installation files. So manually update the hubs as well pointing to same files as before
      My System SpecsSystem Spec

  10. #40


    Posts : 35
    Windows 8.1


    Quote Originally Posted by ComputerGeek View Post
    Quote Originally Posted by mynameisinuse View Post
    Okay trying this now. The folders name was usbport.inf_amd64_5b9f5e3f7703e95d, Are these amd drivers? Does this have any relevance to my problem?
    Not a problem. That's just naming convention for x64 driver

    Let's try this next:
    Right click an "enhanced" controller->Update Driver. Browse your computer for the driver and browse to the usbport.inf_amd64_5b9f5e3f7703e95d folder
    Tried it, says "Windows could not find driver software for your device".

    But then again I tried this on whats listed as an unknown device, whats coming up as a warning.

    Whats an "enhanced" controller?
      My System SpecsSystem Spec

Page 4 of 7 FirstFirst ... 23456 ... LastLast
All USB ports not working. Suspected USB driver issues
Related Threads
Solved usb 3 ports not working in Drivers & Hardware
recently bought a new asus desktop pc with usb 2 & usb 3 ports . the usb2 slots are all ok. just bought a sandisk 16 gb usb 3, no go in usb 3 m but works ok in usb2
USB ports stopped working. in Drivers & Hardware
On my Hewlett-Packard 110-412na machine running Windows 8.1, the USB ports stopped working a couple of times recently Since USB is the only interface between keyboard and rodent, and I waited 20 minutes or so, I had to switch the machine off and back on again. I looked in Device Manager...
Hi everyone :) I brought a Toshiba Satellite laptop late last year and am starting to have some problems with the USB ports. I'm running Windows 8.1 and somethings that used to work in the ports are no longer working. For example I connected my car GPS into the USB port the other day and...
USB 3.0 ports not working in Drivers & Hardware
Hi there... So, my USB 3.0 ports are not working with my USB 3.0 ext-HDD. It's an ADATA Nobility NH13 I don't have any other USB 3.0 equipment to test, but the ext-HDD works perfectly on my laptop and on my TV as well, so it's definitely not the HDDs fault. When I plug in USB 2 devices, they...
usb 3.o ports suddenly not working in Drivers & Hardware
I dont know why but my external hard drive isnt showing up when connected.. Windows makes the connection noise when I plug it in but it dont show up in disk management, device manager or anywhere else... If I plug it into a regular usb port it works fine... And its a usb 3.0 capable drive it worked...
USB Ports not working in Drivers & Hardware
Ok so I have a windows 8 64 bit machine. I have a xerox personal scanner as well as a dell 2330d printer. My issue is that the scanner only works if i have it plugged into one of my usb ports on the front of my machine and will not work on any that are on the back of the machine. As for my...
Solved None of my USB ports are working. in Drivers & Hardware
I hope this is the right place to post. So I upgraded this morning from windows 7 to 8 and it all seemed to be working alright. Then my usb ports stopped working. Can't use mouse, doesn't recognize external hard drive or anything else. For the first few minutes it was all working ok and I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook