Windows 8 and 8.1 Forums


1333Mhz ram showing as 1600

  1. #1


    Posts : 10
    Windows 8.1

    1333Mhz ram showing as 1600


    Hello. I currently have 4GB of Ram DDR3 at 1333Mhz, but for some reason on the task manager it's shown as 1600Mhz.
    Do I have to somehow manually change it to 1333Mhz? Or could I just let it be like this? Also, does this influence how my pc works in any way?

    Here's a picture of the task manager (I am currently running a game so that's why 80% of the ram is being used)

    Thanks!

    Click image for larger version
    Last edited by Brink; 31 Oct 2015 at 10:10. Reason: embedded image

      My System SpecsSystem Spec

  2. #2


    Cross Plains
    Posts : 255
    Windows 10 Pro


    Are you sure the RAM you bought is 1333 and not 1600? What brand and model of RAM is it? Are you doing any overclocking?

    The fact that Windows doesnt know what type of RAM it is (i.e. DDR2, DDR3, etc) makes me wonder what is really going on. It doesnt seem like it is reading it correctly. I would look at the manufacturers website for the motherboard to see if there are any drivers that need to be download and installed or updated. However if it isnt really causing problems I dont think I would get too worried over it.

    As a check to see if its a Windows issue or not, you could download CPU-Z and that would give you all the info you need on your RAM config, plus your CPU and GPU config as well. You will find this info under the memory tab like I show in this screenshot of my system here:

    Click image for larger version

    See what this says and post a screenshot of it if you would.

    EDIT:

    Also take a screenshot of the SPD tab if you would please. It might help us figure out what is going on there.
      My System SpecsSystem Spec

  3. #3


    Posts : 10
    Windows 8.1


    Just looked on the RAM stick and there's a sticker glued to it with the brand Sycron. It's also written DDR III 1333 on it.

    The drivers should be up to date, I've reformatted the PC circa 1,5 months ago and it seems that for Asus it takes a long time to update their drivers.

    Here is the memory photo Click image for larger version
    And here's the SPD one Click image for larger version

    Thanks for helping me!
      My System SpecsSystem Spec

  4. #4


    Cross Plains
    Posts : 255
    Windows 10 Pro


    Thank you for the info.

    By this, it looks like your RAM config is correct and there is nothing wrong. Your RAM is executing at 1333 Mhz like it should be. This is shown by the DRAM Freq. field in the Memory tab and by the Freq. field under JEDEC #4 in the SPD Timings table.

    My guess is that for some reason Windows is unable to read the specs from the RAM itself or from the BIOS. Honestly if it hasnt been causing any noticeable issues with the way your system works, I wouldnt worry about it at all. Its just a minor annoyance, thats all from what I can see.
      My System SpecsSystem Spec

  5. #5


    Posts : 10
    Windows 8.1


    I see. Thank you for your help!
      My System SpecsSystem Spec

  6. #6


    Cross Plains
    Posts : 255
    Windows 10 Pro


    Your welcome.
      My System SpecsSystem Spec

  7. #7


    FTR, I just looked in TM on 3 of my systems here and none identified the RAM as DDR2, DDR3, etc.

    The speed is identified correctly, however. Your RAM speed in CPU-z is properly identified as 667MHz, and as double data rate (DDR), is 1333MHz RAM. So not sure why TM is reporting it as 1600.

    Do I have to somehow manually change it to 1333Mhz? Or could I just let it be like this? Also, does this influence how my pc works in any way?
    No, you do not have to change it and no, it will not influence how your PC works - unless it is running at 1600 and in that case, as long as it is not overheating or causing system crashes, would make your PC perform better, not worse.

    Out of curiosity, what does Speccy show for your RAM speed?
      My System SpecsSystem Spec

  8. #8


    Posts : 10
    Windows 8.1


    Like the two of you said, as long as it's just a wrong reading, it shouldn't be any problem.

    Is this what you've asked for? Click image for larger version
      My System SpecsSystem Spec

  9. #9


    Yes, and there it says 669.6. Double that and you get 1339.2 - close enough to 1333.
      My System SpecsSystem Spec

  10. #10


    Cross Plains
    Posts : 255
    Windows 10 Pro


    Quote Originally Posted by Itaregid View Post
    FTR, I just looked in TM on 3 of my systems here and none identified the RAM as DDR2, DDR3, etc.

    The speed is identified correctly, however. Your RAM speed in CPU-z is properly identified as 667MHz, and as double data rate (DDR), is 1333MHz RAM. So not sure why TM is reporting it as 1600.

    Do I have to somehow manually change it to 1333Mhz? Or could I just let it be like this? Also, does this influence how my pc works in any way?
    No, you do not have to change it and no, it will not influence how your PC works - unless it is running at 1600 and in that case, as long as it is not overheating or causing system crashes, would make your PC perform better, not worse.

    Out of curiosity, what does Speccy show for your RAM speed?
    Thats interesting. My Dell Latitude is listed correctly as having 8.0 GB of DDR3 RAM in the TM and my Dell Precision Workstation is listed as having 16GB of DDR2 FB-DIMM RAM.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
1333Mhz ram showing as 1600
Related Threads
I bought an additional ram the old one is 1333 MHz ,1.50 V and the new one (Hyundai) is 1600 MHz 1.35 v , they are running together in one laptop ,is that fine ? Wont my laptop crash in the future ( cpu or motherboard) ?
My Monitor has been showing stretched-out images lately. I knew that my screen resolution is not right. I tried to change the screen resolution but there were only two options (1024 X 768 & 1280 X 1024) but none worked. It is my old monitor so I know that the correct resolution is 1600 X 900. Then...
When I had 8gb of 1600mhz RAM, I had 777MB reserved. I didn't really think much of this, but I recently installed another kit of 4x2gb of RAM. The Hardware Reserved has gone up to 8.8gb, leaving me at 7.2 to use. I have 4x4 Crucial Ballistix 1600mhz RAM My MoBo is GIGABYTE Z68X-UD3H-B3 ...
I bought my PC about 5 months ago and since then I've noticed my HDD has only 1.5 GB assigned to it. Many things show I actually have 32 GB. I have just been installing my programs to my D: drive instead of my main drive. (My D: drive has 8 GB) C: drive showing only 1.5 GB: 55524 ...
Haswell Real World Performance: DDR3-1600 is Not Enough http://www.corsair.com/~/media/Corsair/Blog/2014-02/HaswellRealWorld/HRW-AIDA64.jpg
POST not showing in Performance & Maintenance
Running Window 8 x64 on an Asrock z77 extreme4. All of a sudden the POST menu doesn't show. Neither does the Asrock BIOS screen with the login option. The screen stays black until the Windows 8 login appears and continues. I updated the graphics drivers, but it made no difference. ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook