Windows 8 and 8.1 Forums


USB device sporadically disconnects/reconnects on win 8.0

  1. #1


    Posts : 3
    Windows 8.0

    USB device sporadically disconnects/reconnects on win 8.0


    First of all, hello to everyone, as I have just registered on this forum and this is my first post.

    Here's my situation and hope someone can please lend a hand:

    I've had a sim racing rig setup for about a year but hadn't been able to even switch it on for the past few months. A few days ago I switched it back on again and after updating everything (basically Avast antivirus, Mozilla Firefox, Java and Windows updates) my USB sim racing wheel (Fanatec CSR Elite Wheel) has been randomly disconnecting for about a second and reconnecting again while playing a game (mainly iRacing, but also Grid 2), which is very annoying because while it's disconnected the car wheels turn completely left and usually make me crash. It has only happened while paying a game, never while doing someting else on the pc.

    I've tried googling for a solution, but after trying several things like disconnecting other USB devices, reinstalling or updating drivers, connecting the wheel to other USB ports or deactivating windows power saving options in the device manager, its still happenning.

    In the hope that it can help find the cause, I've captured a usb event trace with logman (*.etl file) during which it happened twice towards the end. I'd very much appreciate it if anyone who has the knowledge to understand the file could take a look at it and give me their opinion, because I lack the knowledge to understand it myself. You can download the file from here. It's compressed into a 7MB zip file, so it needs to be unziped.

    Anyway, I really hope someone can help me, because I can see this thing driving me crazy until I somehow figure out what's wrong.

    Thanks.

      My System SpecsSystem Spec

  2. #2


    Cross Plains
    Posts : 255
    Windows 10 Pro


    I had a similar issue on my Toshiba Satellite laptop. Turns out there are some revisions of Intels XHCI USB 3.0 controller that dont operate correctly and will cause that sporadic disconnect/reconnect when there is even just a semi-high power device connected to the USB port. It was said to be a driver issue and Intel knew about it, but had no plans to fix it.

    If you have an Intel USB controller on your motherboard this may end up being your issue as well.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.0


    Hi ArazelEternal,

    Thanks for your reply.

    As far as I can tell from the specs, my motherboard has 2 Fresco FL1009 chips for handeling the usb 3.0 ports, so no Intel, and I have the wheel connected to a usb 2.0 port anyway, so I understand the problem you mention shouldn't be the cause in this case.
      My System SpecsSystem Spec

  4. #4


    Cross Plains
    Posts : 255
    Windows 10 Pro


    Well, just because it isnt Intel doesnt mean it cant have a similar issue.

    Judging by how you say you've tried multiple things in your post, Id almost have to say its a hardware issue, or something weird that Windows is doing. Next thing Id recommend is to look into an external self-powered USB hub. Plug that into it and see if it changes the way it acts at all. Next step would be a add in PCI USB card.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    Windows 8.0


    I'll keep that in mind thank you.

    I think I might be getting slightly ahead of myself though. I probably should make sure it's not a problem in the wheel's hardwarde so, just to rule that out, I'm going to try it with my laptop to see if it still happens.
      My System SpecsSystem Spec

  6. #6


    Posts : 50
    windows 8.1


    Also check if there is a BIOS update for your computer
      My System SpecsSystem Spec

USB device sporadically disconnects/reconnects on win 8.0
Related Threads
I bought this computer at the end of May. It's an Acer Aspire TC-605. Sporadically (sometimes it's OK for 2 weeks, sometimes it's bad twice a day) it hangs. What happens most of the time is, I come to my computer and it looks like the screen is off, but when moving the mouse or touching...
Hi There, so I'm currently Experiencing 2 issues. I dont know if they are related or not so I'm posting in the same thread. 1. When I Open Device Manager It's much slower than it should be. WHile its loading the hardware list It will stop responding ( you can see " not responding" in...
Hello! I am new to this forum but I always come here searching for answers and I usually receive them. Please forgive me if I do not provide all of the necessary information. Whatever, you request I will attempt to retrieve it. Please keep in mind that I am not networking guru so I will need...
I built a bare bones system about 2 months ago and have been struggling with BSODs which occur randomly while using different programs and at different times throughout the day. I have updated all drivers and installed the latest bios for the motherboard. These are a list of the BSOD descriptions...
About a few days ago I tried copying some stuff from my old laptop to my new one with my Toshiba HDD (750GB). Some are large sizes. At least 2 files were corrupted and from then on out, I've been having issues with the external. The folder it was in could not be deleted. I tried EVERY possible...
So I recently bought a Vantec SATA/IDE to USB 2.0 Adapter. Once I got it I hooked it up to my 750gb Seagate Barracuda hard drive; it let me view the files, but after I wanted to access my user folder, it said something about not having permission and closed unexpectedly. After that happened, I shut...
Hello people! I have a problem like the topic might have suggested. I've tried three mice, Logitech G400, Razer Deathadder 3.5 and a random Logitech wireless but the problem remains. I haven't found any coincidents when i run a specific program or game. Sometimes it goes a day or two without...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook