Hi there,

I'm usually playing games with a Razer Nostromo, a USB-connected keypad. However, as of yesterday it suddenly went off and now windows doesn't recognize it. Now, whenever I plug it in windows tries to 'install software necessary for the device to work' which 'may take several minutes', but it doesn't really do anything. I once even got that several times at once.
It might be broken, so I'm just trying to rule out possibilities here.
Things I tried:
- turning it off and on again
- plugging it into every USB-Port my PC has
- updating, downgrading and reinstalling drivers
- uninstalling and disabling USB-Ports and reinstalling them via reboot
- uninstalling and disabling the keypad itself in the device manager, and reinstalling it via drivers
- uninstalling every bit of software I installed since it 'broke'

Things I haven't tried:
- plugging it into another PC, as my roommate isn't here and I have no other

I would be so so very thankful if someone had another idea for that list or a fix for my problem. Otherwise I'll just have to accept that it broke, rent a little on razer's website and get a new one anyway...
Thanks in advance!