Windows 8 and 8.1 Forums

repair my 64GB SD card which can't be opened and formatted

  1. #1

    repair my 64GB SD card which can't be opened and formatted

    64GB SD card doesn’t work! It reports “please insert a disk into removable disk” when I try to open it in My Computer, and it can’t be formatted either and it reports error “Windows couldn’t …format”!!
    I’ve searched this question online a whole day and tried all possible solutions found online, such as format it in Disk Management or with Command line. None of them works. I post question here to seek help from you. Are there other solutions to fix it? Thanks!

      My System SpecsSystem Spec

  2. #2

    There are sadly too many fake 64GB cards out there. It’s really difficult to repair USB drives when they get badly physical damage. I’ve experienced same problem with my USB drive. I couldn’t open it and see its correct size in My Computer. Neither Disk Management nor Command Prompt is able to reformat or fix it. It seems that the memory chip is damaged, which leads to system can’t format it. Another reason of such problem might be bad sectors which can’t be read or written. Since formatting is a sort of writing operation and rewrites file system. Thus if the drive has bad sectors, then it can’t be formatted.
    In a word, if you can’t repair it by yourself, then buying a new SD card is a batter choice.
    How to fix - Windows was unable to complete the format error on USB drive
      My System SpecsSystem Spec

  3. #3

    Posts : 315
    Windows 8.1 consumer 64 bit

    I bought a 64gb micro SD card for my phone. I tried to format it on my PC to FAT32 format and Windows could not do it. I put it in my Android phone and the phone asked if I wanted to format it. I said yes and it worked. So if you or a friend have an Android phone you may want to give it a try.
      My System SpecsSystem Spec

repair my 64GB SD card which can't be opened and formatted
Related Threads
Hi all, For some odd reason my laptop decided to not boot into windows anymore; It would be stuck "boot looping" with my MSI laptop logo and a loading sign (rotating circle). I had Kali Linux and Windows 8 installed on the laptop and neither one would work. So I formatted the entire HDD with all...
I recently purchased an 64GB SDXC card and formatted it to Fat32. Sometimes it works, but most of the time I am unable to copy files to it. Windows 8 keeps saying problem with drive or something that pops up in top right corner. Anything I can do about this? The SDXC card is Pixtor SanDisk.
For my birthday I got some money that I've decided to use to get a Windows tablet. But I'm not entirely sure which one I should get, or if I should just buy a bunch of games for my 3DS and Wii U. My two options are: 8" Lenovo Mixx 2 (64gb) or equivalent 10" Surface RT (64gb) first gen. ...
Laptop Freezes After Lid is Opened in BSOD Crashes and Debugging
Hello All My Lenovo U310 Ultrabook does not function properly after being put into sleep mode. If I close the lid and open it again, it will work for 10 seconds and then it will crash, forcing me to restart my computer every time. I have tried to fix this in countless occasions, but I have...
Does this 64GB (32GB cache capacity) mean that I will only be able to use 32 GB of the 64 GB ? What will the cache be used for?
128GB Surface Pro ships with 83GB free, 64GB has only 23GB I think I mentioned earlier, why bother with such a small capacity SSD in the first place and why not allow the option of installing larger capacity hard drives? What's left after installing an Office suite and other programs, such as...
I just changed the wifi card in my laptop and forgot to back it up first. After changing it it failed to boot because of a recent hardware change. I downloaded a copy of windows 8 pro to attempt to do a repair install, and did the automatic repair option but it failed to do it. Is there a way I can...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook