Windows 8 and 8.1 Forums


WD 1TB External HDD not working on USB 3.0, But works on U

  1. #1


    India
    Posts : 7
    Windows 8.1

    WD 1TB External HDD not working on USB 3.0, But works on U


    As the title says, My WD 1TB External HDD is not working on USB 3 port, I mean the light is on I can feel it vibrate, But it isn't getting detected..

    It was working fine a few days ago, Until there was a power surge and this problem started.. Since I had 2 USB 3.0 Ports, I plugged it into the other one it it worked after plugging in and out several times..

    Now there was a sec power surge and the same thing is happening again on the 2nd port! I tried plugging the drive in both USB 3.0 ports, But the HDD light just keeps on, Where as it's supposed to be blinking..

    Now you might think that the problem is in the HDD, But it can't be since the HDD works fine on a usb 2.0 port..

    And the usb 3.0 ports are fine because my mouse and keyboard work on those ports.. Anyone have any suggestions?

    Thanks!

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    First I think I would invest in an UPS with surge protection if my power surged that much.

    Is there another computer with 3.0 ports you can try the drive on, a friend or family member's computer? A mouse and keyboard working on the ports is not the same as a hard drive.

    You could try uninstalling the USB 3.0 hub in Device Manager, then reboot and let it re-install.
      My System SpecsSystem Spec

  3. #3


    India
    Posts : 7
    Windows 8.1


    Quote Originally Posted by popeye View Post
    First I think I would invest in an UPS with surge protection if my power surged that much.

    Is there another computer with 3.0 ports you can try the drive on, a friend or family member's computer? A mouse and keyboard working on the ports is not the same as a hard drive.

    You could try uninstalling the USB 3.0 hub in Device Manager, then reboot and let it re-install.
    Already tried reinstalling the usb 3.0 hub, Didn't work.. And there is no one that I know of that has a usb 3.0 port I don't really need a ups, As they were working on something and power surges only happen a max of 5 times a month (Only in summer) so that would be pretty much wasting cash...
      My System SpecsSystem Spec

  4. #4


    Hi there,


    You can try uninstalling the USB drivers for the device, Windows will install the same device driver for each port you connect it to. Usually those phantom devices are not listed in Device manager. To list them follow the instruction here: https://technet.microsoft.com/en-us/.../cc958122.aspx . Once all the drivers are listed delete them and reboot the system. Then try to connect the external drive again. Hope that helps.
      My System SpecsSystem Spec

  5. #5


    India
    Posts : 7
    Windows 8.1


    Quote Originally Posted by TechpumpkinWD View Post
    Hi there,


    You can try uninstalling the USB drivers for the device, Windows will install the same device driver for each port you connect it to. Usually those phantom devices are not listed in Device manager. To list them follow the instruction here: https://technet.microsoft.com/en-us/.../cc958122.aspx . Once all the drivers are listed delete them and reboot the system. Then try to connect the external drive again. Hope that helps.
    Thank you, But it still does not work
      My System SpecsSystem Spec

  6. #6


    Posts : 50
    windows 8.1


    Quote Originally Posted by Icedwhisper View Post
    <snip> here is no one that I know of that has a usb 3.0 port
    Then take it to a Best Buy or closest computer store and test it there. Testing to see if it works on another machines is next best step (machines = at a store, test it on one or two different machines while you're there)
      My System SpecsSystem Spec

  7. #7


    India
    Posts : 7
    Windows 8.1


    Quote Originally Posted by ComputerGeek View Post
    Quote Originally Posted by Icedwhisper View Post
    <snip> here is no one that I know of that has a usb 3.0 port
    Then take it to a Best Buy or closest computer store and test it there. Testing to see if it works on another machines is next best step (machines = at a store, test it on one or two different machines while you're there)

    Yeah, I guess I'll do that.. Thanks for your help!
      My System SpecsSystem Spec

  8. #8


    Test on a different computer and let us know how it goes, you can also try to boot with a Live Linux CD and check if it will be detected on the USB 3.0 ports then. Also can you give the exact model of the HDD?
    Last edited by TechpumpkinWD; 10 Jun 2015 at 09:16.
      My System SpecsSystem Spec

  9. #9


    India
    Posts : 7
    Windows 8.1


    Quote Originally Posted by TechpumpkinWD View Post
    Test on a different computer and let us know how it goes, you can also try to boot with a Live Linux CD and check if it will be detected on the USN 3.0 ports then. Also can you give the exact model of the HDD?
    I don't know why, But the drive now works on the USB 3.0 port.. Here is what I did:

    Downloaded Elementary OS
    Booted it live using a USB drive
    Took my HD off the USB 2.0 port and plugged it in the USB 3.0 port
    It still didn't get detected, So I restarted to my normal Windows 8.1.
    As the computer was booting up, It just started working..

    This is really strange, Maybe the USB Port is dying?
      My System SpecsSystem Spec

  10. #10


    Is the HDD working properly on both the USB 3.0 ports now?
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
WD 1TB External HDD not working on USB 3.0, But works on U
Related Threads
This is a recent problem. I have a Toshiba Canvio external drive, not SSD. It's got Bitlocker, so when I turn my PC on or awake from sleep, I have to enter a password to access the drive. Now, if I restart my PC, it works fine. Recently though, when I awaken from sleep, I'll click on the drive to...
I have a lenovo b570e laptop and am running Windows 8.1. I recently bought a new monitor (ASUS ve248h) to use as a dual monitor along side my own laptop however upon connecting the HDMI cable with the monitor it doesn't appear to work. I have tried updating the drivers and the hdmi port does...
hi, my seagate external hard drive and my kingston usb stick suddenly stopped working on my win 8.1 notebook. i have been using them both for months without any problems and they still work perfectly fine on other (windows 7 and vista) computers. My notebooks hardware should be fine because my...
Hello - I almost went over the edge last night as I was trying to get my laptop webcam and mic to work with a website that essentially gives virtual interviews. The site did not recognize my webcam and would not produce that adobe flash message that you need to agree to for the webcam to become...
I have a WD My Book Essential USB 3.0 3 TB external HDD that i bought just under 2 years ago (still under warranty for a few more months) and it doesnt work at all. -doesnt show up in My Computer at all -makes an unusual sound with varying beeps and clicks and definitely sounds like an "error...
Hi all, Brand new to these forums! Would appreciate any help! My tech background is limited. I upgraded my Dell XPS One 27 from Windows 7 to Windows 8 Pro--not a clean install, I wanted to keep all my files and programs. Reinstalling all of that would have been a bit annoying and never...
I have a LaCie 2big Quadra 4TB external hard drive, the older model that does not have USB3. Anyway, it has an eSATA port, as does my laptop. The eSATA port on my laptop is actually part of the Intel HM76 chipset, not some half-arsed jmicron add on. On Windows 7 x64, the hard drive worked...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook