Windows 8 and 8.1 Forums


Brand new pc wont boot or power on after I unplugged it

  1. #1


    Posts : 3
    windows 8

    Brand new pc wont boot or power on after I unplugged it


    So basically I unplugged it from the socket because I needed to rearrange chords for space and once I replugged it in, it just simply does not boot or power on. The green light on the motherboard is on and I didn't turn off the PC when I unplugged it. Did I fry the PSU? Really need some help.

    Thanks

      My System SpecsSystem Spec

  2. #2


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Something you might overlook. There's a switch on the PSU. Did you accidentally switch it off ?
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    windows 8


    a switch on the PSU? or you mean the one on the back of the case
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Back of the case where the PSU is.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    windows 8


    I definitely know its on
      My System SpecsSystem Spec

  6. #6


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Normally when you connect the power cord to the outlet, the led light on the board will be on even the PC is not turned on. It's hard to tell which one went bad unless you open the case and do some test. If it is a brand new PC, you should bring it back to where you bought and let them test for you.
      My System SpecsSystem Spec

  7. #7


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Personally I would try plugging the machine into a known good outlet and see what happens. If still not booting, then get a meter and check what the voltage is at he outlet. As long as the power strip is on, there is no "Master Outlet", then the computer should boot. The only other thing I would check for, is making sure all cables are connected all cards and devices are connected to the Motherboard.
      My System SpecsSystem Spec

Brand new pc wont boot or power on after I unplugged it
Related Threads
Culprit Machine: ASUS N551-JK Windows 8.1 64 bit (non-touch) On-Going Problem: While computer is unplugged from the power source (ie charging cord), it will ever so often give me a BSOD about Driver Power State Failure. I did some searching and most of the results were to check and make...
So im using black glass enhanced on my visual style but it doesnt work when the cable unplugged, It was worked when cable plugged the transparency looks great with my visual screen. I already tried setting the power option to high performance when using battery and all other stuff like graphic...
i don't exactly know where the best place to put this tread is, or if this is even the right forum. But i'll make a post here anyways. So two days ago my laptop was not able to turn on at all and so i checked the ac adapter and it was beeping so i got brought a replacement from Canada Computers....
I just got back from vacation andwent to turn on my pc which worked before on my Gigabyte GA78LMTS2 and now cant boot into Windows, instalation media, anything. it just hangs on the BIOS load screen. I am using AHCI for my sata. Any help?
Last night I updated windows 8.1 from windows 8. It got to the stage where it needs to restart so it done that started the configarations and once it reached 100% it restarted. Since then what happens is when i press power on the samsung logo comes on the screen then the black screen with the...
Last night I installed windows 8.1 preview through the windows store. It all worked fine and it seemed like there was nothing wrong. When I woke up this morning my pc gets past the windows loading screen (The new fish thing looks just plain stupid) but then my screen just goes black. The screen is...
My PC wont Boot! :( in General Support
Hey guys im very sad because my pc wont boot. Iv got a custom PC running 2500K CPU It loads the ASUS Mobo screen then a black screen with a white Dash appears on the top left side of the screen which keeps flashing and thats it. What do you think it could be? plz id appreciate any help...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook