Windows 8 and 8.1 Forums

SD Cards No Longer Recognised

  1. #1

    Posts : 8
    Windows 8.1

    SD Cards No Longer Recognised


    I have a Toshiba Satellite Pro L870 running Windows 8.1.

    It has an SD card slot on the front of it which I have used with no problems for quite a while. However, for the last couple of months, it has become temperamental, sometimes recognising the card and sometimes not. The other day, it has given up entirely and refuses to recognise any SD card.

    I have an external USB card reader which I have tried to use, but it is also refusing to recognise the SD card.

    This is where it gets a bit confusing. If I insert a 1gb SD card I have, the card reader recognises it and I can use it. However, it won't recognise two 32gb SD cards that I have. I have tested these on another laptop and they are both working fine. The 1gb SD card doesn't work in the front slot though.

    Does anyone have any idea why I am having these problems?

      My System SpecsSystem Spec

  2. #2

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    You can try to check with the manufacturer website if they have:
    1. Latest BIOS
    2. Latest Driver for SD slot.
      My System SpecsSystem Spec

  3. #3

    Follow directions in this MS article, see if that helps: Advanced troubleshooting tips for general USB problems in Windows XP

    If not, try this:
    • Shutdown and unplug all USB devices.
    • Boot to BIOS Setup and load defaults (F5 or F9 usually).
    • Boot your computer and create a new Environment variable called devmgr_show_nonpresent_devices and set it's value to 1 as follows:
      • Right click on My Computer and select Properties
        • XP - Click on the Advanced tab
        • Vista or Windows 7 - Click on ]Advanced System Settings in left pane.

      • Click on the Environmental Variables button
      • Click the New button under the User variables for xxxxx" area.
      • Set the Variable name as: devmgr_show_nonpresent_devices
      • Set the Variable value to: 1
      • Click OK as needed to close all the windows you opened.

    • Open Device Manager (Control Panel, System, Hardware tab, Device Manager)
    • Click on View then Show hidden devices.
    • Scroll down to USB and click on the plus to expand it.
    • Uninstall the ones that are somewhat greyed out (indicates not connected). DO NOT uninstall your mouse if you are using a USB mouse.
    • Shutdown and reboot, let Windows rediscover everything and load necessary drivers. This can take a few minutes, be patient.

    Then try the SD card again.
      My System SpecsSystem Spec

  4. #4

    Posts : 8
    Windows 8.1

    Thanks for your replies.

    I have followed these steps but I'm still having the same result.

    Interestingly, the USB card reader I have also has an old CF card in it. If I have the 32gb SD card in at the same time, it doesn't work. However, as soon as I take the SD card out, I can use the CF card.
      My System SpecsSystem Spec

  5. #5

    Maybe the CF card has gone bad.
      My System SpecsSystem Spec

  6. #6

    Posts : 8
    Windows 8.1

    The CF card seems to be working ok. I've also tried removing it from the card reader, but it doesn't make any difference unfortunately.
      My System SpecsSystem Spec

  7. #7

    Can you try the card on another computer?
      My System SpecsSystem Spec

  8. #8

    Posts : 8
    Windows 8.1

    I've tried that and all of the cards work perfectly, so it seems isolated to just this laptop.
      My System SpecsSystem Spec

  9. #9

    Does it work if you boot to Safe Mode?

    Posted by Macboatmaster on G2G

    Windows key + C.
    Hold shift key and click RESTART.
    Click on Advanced Options then Startup Settings.
    Click Restart and you have almost the full advanced Boot Options menu like XP, Vista or Win 7.
      My System SpecsSystem Spec

  10. #10

    Posts : 8
    Windows 8.1

    I have tried restarting the laptop in safe mode, but I am getting exactly the same results unfortunately!
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
SD Cards No Longer Recognised
Related Threads
My Dell laptop has a SD card reader slot in the front. This was fine until a few days ago, when it stopped responding to an SD card being inserted (it's the same card that was recognised before, and is recognised in a different laptop so I know the card is okay). I can't see the card reader...
Device not recognised in Drivers & Hardware
Upgraded laptop, old Toshiba Tecra, to Windows 8 but find software doesn't recognise Vodafone K4201 Mobile Dongle or SanDisk Cruzer Blade. Has USB Dongle registered as Remote NDIS Internet Device and SanDisk as a Remote Disc Reader. Have tried to update USB drivers via Toshiba and SanDisk but had...
Solved USB Device not recognised in Drivers & Hardware
Hello, Recently my "PS to PC Converter" USB device, as shown in image was not recognized by my laptop. It was working fine as of yesterday, where I was playing FIFA with my friend. Then today when I plug it in, it says USB device not recognized even though I can still on the analog but the...
usb devices not recognised in Drivers & Hardware
Hello all recently, I updated my Ipad but following that, I couldn't get it to connect to my Windows 8 PC ( I spent 3 hours on the phone to Apple and they couldn't sort it); then the PC stopped recognising my android phone and today, I tried to connect a camera. I also tried to install new video...
Hi all Got a Compro S350 satellite TV card and have Windows Media centre. I boot my PC, start media centre, go onto live TV and it tells me no TV signal/device is found. I simply reboot and it works fine. Not that hard to get around but annoying all the same. Any ideas?
Hi I've just installed Windows 8 on my Dell Inspiron (about 4 years old) but find that my wireless Dell keyboard doesn't work, although the wireless mouse does. In fact some of the buttons on the keyboard work (such as the calculator symbol, but not the alphanumeric keys). Presumably this is...
USB device not recognised in Drivers & Hardware
Hello, i have my smartphone's docking station connected to usb and im getting error "USB device not recognised", in Windows 7 there was an option in Device Manages "Don't tell me about USB errors" but i cant find it in Windows 8. Any1 know where is it or how to fix it. Thanks.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook