Windows 8 and 8.1 Forums


Unable to copy files to USB drives due to write protect

  1. #1

    Unable to copy files to USB drives due to write protect


    Hi,

    I was doing word editing on my win 8 pc from my USB drive. When I click save, the computer says that I cannot save it with the same name. I then proceeded to save it on the desktop with a different name. I then tried to copy it back to the USB drive, it says the drive is write protected.

    I did try another word file on another USB drive, it says write protected. How to solve this problem? I did try this method:



    However, this method formats the drive which I don't want to happen. Also, while following the instructions in the youtube video, I got stuck when it came to formatting the drive. It says the drive is protected.

    I then took the USB drives to my windows 7 laptop and it works, so there must be something wrong with Windows 8 and not the USB drives.

    Any ideas?
    Last edited by Brink; 13 May 2015 at 09:43. Reason: embedded video

      My System SpecsSystem Spec

  2. #2


    Posts : 22,581
    64-bit Windows 10


    Hello mystvearn,

    You might see if this below may be the issue and be able to help. Option Three seems appropriate for this.

    Disk Write Protection - Enable or Disable in Windows - Windows 10 Forums
      My System SpecsSystem Spec

  3. #3


    I found this and it worked. I modified the registry from 1 to 0.

    The Disk Is Write-Protected error for Removable Disks

    Thanks for the help
      My System SpecsSystem Spec

Unable to copy files to USB drives due to write protect
Related Threads
I need a software that can password protect a particular folder and disable the option to copy them to any other location but at the same time I want to be able to run a particular application or video inside that folder. Does anyone know any good software that can help me with this.
Hi all, Please can somebody help me, I've a relatively new SanDisk Cruzer Slice 64GB USB pen drive, which I use for work mainly. It has somehow managed to write protect itself and no matter what I do I simply cannot remove it! I've scanned with Antivirus, nothing found I've tried regedit...
As well as my C: drive, I have a large (2Tb) Z: drive on my PC. I then use the "subst" command (using XSubst as the GUI) to create virtual drives pointing to various directories on Z:. For example, P: actually points to Z:\PHOTOGRAPHS, M: points to Z:\MUSIC and O: points to Z:\DOWNLOAD. I can do...
I have two drives. The C drive is an SSD containing Windows and Vegas Pro 12 and MAGIX's Movie Edit Pro 2013 Plus. The HDD is a 3TB drive that is paritioned as E, F, and G. When I render a file, it will render to any folder in the C drive and the E partition. It takes about 1 minute or so for...
Remove Write Protect on USB in General Support
This just happened to me recently , I am unable to drag or delete files on the usb, any idea how this can be fixed?, I tried the registry method, didn't work.
how can I remove my write protect on my TDK 8GB USB Flash Drive? there is no physical switch on the usb i have tried the registry trick by adding a key in 'local_machine/system/currentcontolset' called 'SystemDevicePolicies' & adding a dword called 'WriteProtect'
What hard drive utility would allow me to measure the read write speed of my various USB Hard drives I don't mind smart monitor etc but don't need that the commercial ones seem complex has anyone found this function in a freeware utitily Any tips appreciated Kevin
Eight Forums Android App Eight Forums IOS App Follow us on Facebook