Hi All,

I'm hoping someone on here will be able to help me with an issue I am having with the latest TomTom app 'MyDrive' which is for Windows (Desktop based).

The TomTom is a GO 40 and due to it having a web-based OS it shows up as a Network Device rather than a Mass Storage Device when connecting to the laptop therefore it shows as a 'Local Area Connection'.

Now I have been having issues that when I launch the MyDrive app everything is fine and logs me in and recognises the GO 40 but then after 2-3mins it blocks my Wi-Fi so that I cannot get any internet via Internet Explorer nor Firefox now if I use a Wired Connection I have no issues but this defeats the object of having a Wireless Laptop.

So I called the Customer Service line and they could not help and told me that the application MyDrive Connect does not alter any Wi-Fi Internet settings so I am really stumped.

After much searching around and testing I've come to a dead end here is what I have tested.......

I have used a neighbours laptop (W8.1) and their Wi-Fi and installed MyDrive Connect, launched the app connected the GO 40 and no issues with accessing the internet via Internet Explorer nor Firefox and still going strong after 10 minutes.

I then tried my laptop on my neighbours Wi-Fi and I get the same issues as before....after 2-3mins of launching the MyDrive Connect app I get frozen out of accessing the internet through either Internet Explorer nor Firefox.

Before all of the above I had uninstalled all the drivers/app/cleared out all the internet caches and history. Now I have resorted to refreshing my laptop in the hope to fix this issue....thinking that maybe somewhere along the lines a Registry value has been affected/corupted somehow....so after 20hrs of downloading Windows updates and eventually getting on to W8.1 with all the Microsoft Updates loaded I downloaded a fresh copy of MyDrive Connect and I got the same issues......

Wired Connection
Opened the MyDrive Connect app waited 5mins then tried the internet via Internet Explorer & Firefox and no problems there....connected my GO 40 and it linked to the MyDrive app and again after 5mins no issues with the internet at all.

Wireless Connection
Opened the MyDrive Connect app and waited 5mins then tried the internet via Internet Explorer & Firefox and I could not access anything not even google.co.uk. So then I went to the Microsoft Troubleshoot Wizard and it diagnoised the issue of needing the reset the Wi-Fi Adaptor within the laptop...this I tested several times and each time after 2-3mins on Wi-Fi I could not get any internet access.

This could be a really simple fix but I do not know where to turn for this as when on a Wired Connection I have no issues at all so it is seeming to be that the MyDrive app is triggering something in the settings to block the Wi-Fi. I have also tried the above with all Firewalls turned off so I know it's not my Anti-Virus software blocking the access.

Any help, advice would be great.